Willkommen

RGSS Editor Hilfedatei
Willkommen

Willkommen zur RGSS Editor Hilfedatei!

RGSS Editor ist ein erweiterter Skripteditor für die Skriptsprache des RPG Maker™ XP von Enterbain. Er bietet vielfältige Möglichkeiten und Werkzeuge, die das Erstellen eigener Skripts erleichtern soll.
In dieser Hilfedatei werde ich alle Funktionen und Eigenschaften von RGSS Editor beschreiben und erläutern.
Wenn Sie zum ersten Mal RGSS Editor benutzen empfehle ich Ihnen diese Hilfedatei genau zu lesen und sich Schritt für Schritt in die Bedienung des Programms einzuarbeiten.

Viel Erfolg und viel Spaß,
!Tocs!

Copyright © 2007 !Tocs!


Features

Features

RGSS Editor besitzt viele Funktionen und Fetaures, die Ihnen als Skripter das Schreiben eigener Skripts vereinfachen sollen. So enthält RGSS Editor standardmäßig

  • eine Zeilennummerierung neben dem Code,
  • Syntaxhighlighting, um das Lesen zu vereinfachen,
  • eine Suchen bzw. Suchen& Ersetzen Funktion,
  • die Möglichkeit Zeilenmarkierungen einzufügen,
  • zu einer bestimmten Zeile zu springen,
  • einen Syntaxabschnitt farblich zu markieren,
  • den RPG Maker ™ XP von Enterbain
  • und den RMXP Skript Explorer von Monsta zu starten

uvm.

Außerdem besitzt Sie mit RGSS Editor die Möglichkeit

  • Aufgaben zu verwalten, um noch zu erledigende Dinge zu vermerken,
  • Dateiverweise einzubinden, um bestimmte Dateien mit einem Skript zu assoziieren,
  • Klassen mit Hilfe des Klassen-Assistenten und nur wenigen Klicks einzufügen,
  • Variablen kompfortabel übder den Variablen-Assistenten einzufügen,
  • einen Informationsheader per Klick einzufügen, der alle nötigen Daten über den Autor und das Skript enthält,
  • eine Hilfedatei im Textdatei Format auf Grundlage von Kommentaren zu erstellen,
  • Ihr Skript als HTML-Datei zu exportieren,
  • Ihr Skript samt Dateien zu einem Archiv zu packen

und noch mehr. Aber sehen Sie selbst.


Der Editor

Der Editor

In diesem Abschnitt erhalten Sie detailiertere Information übder die Bedienoberfläche von RGSS Editor. Er ist besonders für Anfänger und Personen die noch nie mit RGSS Editor gearbeitet haben hilfreich.

Dieser Abschnitt enthält folgende Themen:

Die Menü- und Symbolleiste
Die Statusleiste
Das Detailfenster
Die Sidebar
Das Editorfenster

Wichtige Tastenkürzel


Die Menü- und Symbolleiste

Die Menü- und Symbolleiste

Die Menü- und Symbolleiste sind die haupt Schaltflächen in RGSS Editor.
Über sie sind fast alle Funktionen von RGSS Editor erreichbar.

Die Menüleiste:

Datei:
Enthält alle nötigen Funktionen zum erstellen neuer Skripts, öffnen vorhandener Skripts im Textformat, speichern, drucken und exportieren.

Bearbeiten:
Bietet Zugriff auf Funktionen wie Rückgängig, Wiederholen, Ausschneiden, Kopieren, Einfügen, setzen und springen zu Zeilenmarkierungen, markieren von Syntaxabschnitten sowie einfügen von Codeschnipseln.

Ansicht:
Ermöglicht das temporäre Anpassen der Erscheinung von RGSS Editor.
Benutzen Sie für dauerhafte Änderungen das Optionsmenü-

Werkzeuge:
Gibt Ihnen die Möglichkeit umfangreiche Werkzeuge von RGSS Editor wie den Klassen Assistenten, den Variablen Assistenten usw. aufzurufen.
Außerdem können sie über den Untereintrag Optionen in das Optionsmenü gelangen.

Fenster:
Arrangieren Sie alle geöffneten Fenster, um den Überblick zu behalten.

Plugins:
Listet alle gefundenen Plugins auf und ermöglicht sie zu starten.

Extras:
Gibt Ihnen die Möglichkeit auf zusätzliche, bereits in Windows enthaltene Funktionen zuzugreifen.

Hilfe:
Gibt Ihnen Zahlreiche Informationen und Hilfestellungen zu RGSS Editor und RGSS.

Die Symbolleiste:

1: Erstellt ein neues Dokument.
2: Öffnet ein Skript im Textformat
3: Speichert ein Skript unter dem Standardpfad
4: Speichert das Skript unter dem angegebenen Pfad
5: Druckt das aktuelle Skript aus
6: Zeigt, wie das aktuell ausgewählte Skript nach dem Druck aussehen wird
7: Macht ungewollte Aktionen Rückgängig
8: Stellt rückgänig gemachte Funktionen wieder her
9: Entfernt den ausgewählten Code und fügt ihn der Zwischenablage hinzu
10: Kopiert den ausgewählten Code
11: Fügt den Text aus der Zwischenablage ein
12: Fügt das komplette Skript der Zwischenablagen hinzu
13: Springt zu einer ausgewählten Zeilenmarkierung
14: Markiert den ausgewählten Code in einer bestimmten Farbe
15: Zeigt auf Klick den Schnipseldialog oder öffnet den Dialog zum Erstellen eines neuen
Schnipsels.
16: Startet den RPG Maker ™ XP
17: Startet RMXP Skript Explorer von Monsta
18: Öffnet diese Hilfedatei
19: Vergrößert oder verkleinert das Detailfenster


Die Statusleiste

Die Statusleiste

Die Statusleiste liefert Informationen über den aktuellen Zustand on RGSS Editor.

Auf der rechten Seite finden Sie den aktuellen Zustand des kompletten Programms.
Dieser sollte im Normalfall "Bereit" sein. Beim Laden des Programms oder Öffnen der Skriptdatenbank werden enbenfalls Zustände angezeigt, die Informationen übder den Fortschritt des Prozesses liefern.

Auf der linken Seite der Statusleiste finden Sie bei geöffnetem Skript den Namen des aktuellen Skripts.


Das Detailfenster

Das Detailfenster

Das Detailfenster enthält zwei Rgisterkarten. Eine für Aufgabenlisten und eine für Dateiverweislisten. Die Funktionen beider Registerkarten sind über das Optionesmenü und über ein Kontextmenü zu erreichen.

Die Aufgabenlisten:

Über die Aufgabenlisten Registerkarte lassen sich
Aufgaben deffinieren, die Sie an noch zu
erledigende Dinge erinnern sollen.
Standardmäßig ist keine Aufgabenliste
eingerichtet und RGSS Editor wird Ihnen einen
Warnhinweis anzeigen, wenn sie versuchen eine
neue Aufgabe hinzuzufügen. Daher müssen Sie
zunächst eine Aufgabenliste auswählen oder eine
neue Aufgabenliste erstellen.

1: Erstellt eine neue Aufgabe in der ausgewählten
Aufgabenliste.
2: Löscht die ausgewählte Aufgabe.
3: Löscht die alle Aufgaben dieser Liste.
4: Speichert die ausgewählte Aufgabenliste. (Listen
werden beim Beenden von RGSS Editor automatisch
gespeichert).
5: Ruft das Opzionsmenü auf, in dem Aufgabenlisten
verwaltet werden können.

Die Dateiverweislisten:

Über die Dateiverweise Registerkarte lassen sich
Dateiverweise deffinieren, die später vom
Skript-Pack Assistenten verwendet werden
können. Auf diese Weise ist die
Wahrscheinlichkeit geringer das Dateien, die das
Skript benötigt verloren gehen. Standardmäßig ist
ist keine Dateiverweisliste eingerichtet und RGSS
Editor wird Ihnen einen Warnhinweis anzeigen, der
Sie darauf hinweist das zuerst eine
Dateiverweisliste erstellt werden muss.

1: Erstellt einen neuen Verweis zu einer Datei.
2: Löscht den ausgewählten Verweis.
3: Löscht alle Verweise dieser Liste.
4: Speichert alle Verweise dieser Liste (Listen
werden beim Beenden von RGSS Editor automatisch
gespeichert).
5: Ruft das Opzionsmenü auf, in dem Dateiverweislisten
verwaltet werden können.


Die Sidebar

Die Sidebar

Über die Sidebar sind wichtige und häufig verwendete Funktionen von RGSS Editor schnell
zu erreichen. Im Gegensatz zur Symbolleiste sind die hier aufgeführten Funktionen aber umfangreicher. Über den Unterpunkt "Sidebar" im Optionsmenü ist die Sidebar anpassbar.

RE sofort beenden: RGSS Editor wird ohne Umwege
direkt und ohne verzögerung beendet.

RMXP Starten: Öffnet den RPG Maker ™ XP.

Skript Explorer starten: Öffnet den RMXP Skript
Explorer von Monsta.

Suchen nach...: Geben Sie hier den Suchbegriff ein,
nach dem Sie suchen möchten. Alle bereits gesuchten
Begriffe werden gespeichert.

Suchen in...: Wählen Sie aus, ob Sie im Internet oder
in einem der geöffneten Skripts suchen möchten.

Groß-/Kleinschreibung.: Wählen Sie diese Option,
wenn bei der Suche nach einem Begriff in einem der
geöffneten Skripts die Groß- bzw. Kleinschreibung
beachtet werden soll.

Ganzes Wort suchen.: Wählen Sie diese Option, wenn
bei der Suche nach einem Begriff in einem der geöffneten
Skripts nur das komplette Wort gesucht werden und
Ergebnisse, die Bestandteil eines anderen Wortes sind
übersprungen werden sollen.

Suchen.: Klicken Sie auf diese Schaltfläche, um mit der
Suche zu beginnen.

Rechner.: Klicken Sie auf den kleinen Pfeil, der nach
unten zeigt, um den Rechner zu öffnen.

Tutorials: Klicken Sie auf eines der aufgeführten Items, um das dazugehörige Tutorial zu öffnen.


Das Editorfenster

Das Editorfenster

Im Editorfenster haben Sie die Möglichkeit Ihre Skripts zu schreiben.
Es besitzt eine Zeilennummerierung, Syntaxhighlighting und vieles Extras mehr.

Abb.1

So können Sie bspw. eine Textdatei per Drag&Drop in das Editorfenster einfügen indem Sie einfach eine Textdatei in den blauen Bereich links ziehen.
Beachten Sie dabei jedoch, dass bereits enthaltener Code gelöscht wird.

Außerdem wird zu jedem Editorfenster eine eigene Registerkarte am oberen Rand von RGSS Editor angelegt. Über diese Rgeisterkarten ist eine schnelle und übersichtliche
Navigation zwischen den einzelnen Editorfenstern möglich. (siehe Abb.2)

Abb.2

Über das Kontextmenü des Editorfensters sind zudem weitere nützliche Funktionen erreichbar. Dort finden Sie unter anderem noch einmal alle nötigen Bearbeitungswerkzeuge
wie "Ausschneiden", "Kopieren" usw., sowie Informationen über die Zeilen bzw. die aktuelle Zeile Ihres Skripts und die Möglichkeit zu einer bestimmten Zeile zu Springen.
Auch haben Sie die Möglichkeit sich über das "Skriptinformation"-Item, weitere nützliche Informationen zu Ihrem Skript anzeigen zu lassen.
Sie können außerdem Ihr Skript als "RMXP Skript Explorer" Skript oder HTML-Datei exportieren und nach bestimmten Begriffen suchen bzw. diese ersetzen.

Abb.3


Wichtige Tastenkürzel

Wichtige Tastenkürzel

Um die Handhabung von RGSS Editor noch einfacher und intuitiver zu gestalten gibt es natürlich auch in RGSS Editor Tastenkürzel, mit denen wichtige Funktionen im Handumdrehen aufgerufen werden können.

Alt+1 = Gehe zu 1. Zeilenmarkiereung
Alt+2 = Gehe zu 2. Zeilenmarkiereung
Alt+3 = Gehe zu 3. Zeilenmarkiereung
Alt+4 = Gehe zu 4. Zeilenmarkiereung
Alt+C = Windows Rechner anzeigen
Alt+E = Explorer öffnen
Alt+O = Programm öffnen Dialog anzeigen
Alt+S = Windows Dateisuche öffnen

F11 = Zwischen Vollbild und normaler Ansicht wechseln
F1 = Hilfedatei öffnen
F2 = Tutorial anzeigen

Strg+A = Alles markieren (geöffnete Skripteditor)
Strg+C = Markierten Text kopieren (geöffnete Skripteditor)
Strg+D = Detailfenster anzeigen/verstecken
Strg+F = "Finden" Dialog anzeigen
Strg+G = "Gehe zu Zeile..." Dialog anzeigen
Strg+N = Neues Skript erstellen
Strg+O = Skript im Textdatei Format öffnen
Strg+P = Skript ausdrucken (geöffnete Skripteditor)
Strg+R = "Finden&Ersetzen" Dialog anzeigen
Strg+S = Skript speichern (geöffnete Skripteditor)
Strg+V = Text aus der Zwischenablage einfügen (geöffnete Skripteditor)
Strg+X = Markierten Text ausschneiden (geöffnete Skripteditor)
Strg+Y = Letzte Aktion rückgängig machen (geöffnete Skripteditor)
Strg+Z = Rückgängig gemachte Aktione wiederherstellen (geöffnete Skripteditor)


Wie?

Wie?

Wenn Sie noch nie mit RGSS Editor gearbeitet haben werden Sie am Anfang vllt. einige Fragen haben, auf die Sie nicht sofort eine Antwort finden.
Um solche und andere Fragen geht es in diesem Abschnitt. Es werden wichtige Funktionen und ihre ganuen Funktionsweisen erklärt und noch mehr.

Folgende Fragen können Sie in diesem Abschnitt finden:

Wie erstelle ich ein neues Skript?
Wie öffne ich ein vrohandenes Skript?
Wie speichere ich ein Skript?
Wie benutze ich die Zeilenmarkierungen?
Wie erstelle ich eine neue Aufgabe?
Wie erstelle ich einen neuen Dateiverweis?
Wie erstelle ich eine Klasse?
Wie erstelle ich Variablen?
Wie erstelle ich einen Infoheader?
Wie erstelle ich eine Hilfedatei im Textdatei Format?
Wie packe ich mein Skript?
Wie erstelle ich ein eigenes Skript in der Skriptdatenbank?


Wie erstelle ich ein neues Skript?

Wie erstelle ich ein neues Skript?

Ein Skript in RGSS Editor zu erstellen ist ganz einfach.
Und wie Sie noch merken werden gibt es in RGSS Editor oft mehrere Wege, die zum Ziel
führen! So Auch hier.

1. Klicken Sie in der Menüleiste auf das Item "Datei" -> "Neu".
2. Drücken Sie auf das mit 1 gekennzeichnete Item der Symbolleiste .
3. Drücken Sie Strg+N.
4. Ziehen Sie eine bereits vorhandene, leere Textdatei per Drag&Drop ind den
d unkelgrauen Bereich von RGSS Editor.

Geben Sie dannach im erscheinenden Editorfenster ihren Code ein.


Wie öffne ich ein vorhandenes Skript?

Wie öffne ich ein vorhandenes Skript?

Oft werden Sie in die Situation kommen ein vorhandenes Skript zu öffnen.
RGSS Editor stellt ihnen dabei verschiedene Möglichkeiten zur Verfügung!

1. Klicken Sie in der Menüleiste auf das Item "Datei"->"Öffnen" und wählen sie eine
Textdatei aus.
2. Klicken Sie auf das mit 2. gekennzeichnete Item der Symbolleiste und wählen Sie eine
Textdatei aus.
3. Drücken Sie Strg+O und wählen Sie eine Textdatei aus.
4. Ziehen Sie eine Textdatei in den dunkelgrauen Bereich von RGSS Editor.
5. Ziehen Sie eine Textdatei in den blauen Bereich eines Editorfensters .


Wie speichere ich ein Skript?

Wie speichere ich ein Skript?

Wenn Sie ein Skript erstellt haben möchten Sie dies bestimmt auch speichern.
Und auch hier gibt es wieder mehrere Wege!

Wenn Sie ihr Skript noch nicht gespeichert haben oder es unter dem selben Pfad wieder speichern möchten:

1. Klicken Sie auf das Item "Datei"->"Speichern" in der Menüleiste.
2. Klicken Sie auf das mit 3 gekennzeichnete Item in der Symbolleiste.
3. Drücken Sie Strg+S.

Wenn Sie ihr Skript bereits gespeichert haben und es unter einem anderen Pfad speichern möchten:

1. Klicken Sie auf das Item "Datei"->"Speichern unter..." in der Menüleiste.
2. Klicken Sie auf das mit 4 gekennzeichnete Item in der Symbolleiste.


Wie benutze ich die Zeilenmarkierungen?

Wie benutze ich die Zeilenmarkierungen?

In RGSS Editor gibt es die Möglichkeit bis zu vier Zeilenmarkierungen anzulegen.
Zeilenmarkierungen werden dabei unabhänig von den anderen Editorfenstern für jedes
Editorfenster einzeln gespeichert.

Um eine Zeilenmarkierung zu setzen öffnen Sie ein Editorfenster.
Positionieren Sie nun per Klick den Cursor in der gewünschten Zeile.
Klicken sie nun in der Menüleiste auf das Item "Bearbeiten"->"Zeilenmarkierung"->
"Setzen"->"1 Slot A" (oder einen der anderen vier Slots).

Hinweis: Bereits gesetzte Slots werden beim erneuten Auswählen überschrieben.

Wenn Sie jetzt zu einer Zeilenmarkierung springen möchten gehen Sie wie folgt vor:

1.Möglichkeit:
Klicken Sie in der Menüleiste auf das Item "Bearbeiten"->"Zeilenmarkierung"->"Gehe zu..."->[Einen der Slots]

2.Möglichkeit:
Drücken Sie Alt+ 1-4.

3.Möglichkeit:
Klicken Sie auf eines der Unteritems des mit 13 gekennzeichneten Items in der Symbolleiste .


Wie erstelle ich eine neue Aufgabe?

Wie erstelle ich eine neue Aufgabe?

Wie bereits vorher erläutert gibt es in RGSS Editor die Möglichkeit Aufgaben zu erstellen.

Um eine Aufgabe zu erstellen ist es aber zunächst nötig eine Augabenliste zu erstellen.
Ziehen Sie dazu das Detailfenster groß (oder klicken Sie auf das mit 19 gekennzeichnete Item in der Symbolleiste). Wählen Sie die Registerkarte Aufgabenlisten aus und klicken Sie auf das Item "Neue Aufgabe". In dem daraufhin erscheinenden Hinweis klicken Sie auf "Ja".
Das Optionemenü wird sich öffnen und Sie scrollen herunter bis zum Abschnitt Aufgabenlisten (Abb.1)

Abb.1

und klicken Sie auf die Schaltfläche neue Liste. Geben Sie nun einen Namen für die neue Liste ein und bestätigen Sie mit "OK".
Schließen Sie das Optionsmenü jetzt per Klick auf "OK".

Nachdem Sie nun eine Aufgabenliste erstellt haben müssen Sie noch die gewollten Aufgaben hinzufügen! Klcken Sie dazu mit der rechten Maustaste auf Anzeige für Aufgabenlsiten (Abb.2) und wählen Sie "Neue Aufgabe".
Geben Sie in dem erscheinenden Dialog die Aufgabe ein und bestätigen Sie mit "OK".

Abb.2


Wie erstelle ich einen neuen Dateiverweis?

Wie erstelle ich einen neuen Dateiverweis?

Um einen neuen Dateiverweis zu erstellen ist es zunächst einmal notwendig eine Dateiverweisliste zu erstellen!
Wählen Sie hierzu die Registerkarte "Dateiverweise" im Detailfenster aus, klicken Sie mit der rechten Maustaste auf den leeren Bereich und wählen Sie "Neuer Verweis" aus.
Bestätigen Sie den erscheinenden Hinweis mit "OK", so dass sich das Optionmenü öffnet und scrollen Sie bis zum Abschnitt "Verweislisten" herunter (Abb.1).

Abb.1

Klicken Sie jetzt auf die Schltfläche "Neue Liste". Geben Sie im erscheinenden Dialog den Namen der Verweiliste ein, bestätigen Sie mit "OK" und schließen Sie das Optionsmenü mit einem Klick auf "OK".

Nachdem Sie eine Verweiliste erstellt haben können Sie nun Dateiverweis hinzufügen!
Klícken Sie dazu mit der rechten Maustaste auf das Verweislisten-Fenster (Abb.2) und wählen Sie "Neuer Verweis" aus. Wählen Sie nun im erscheinenden Dialog eine datei aus und bestätigen Sie mit "OK".

Abb.2


Wie erstelle ich eine Klasse?

Wie erstelle ich eine Klasse?

In diesem Abschnitt geht es nun um eine der wichtigsten Funktionen von RGSS Editor, dem Klassenassistenten.

In RGSS Editor ist es mit Hilfe des Klassen-Assistenten ganz einfach Standardklassen für Ihr Skript zu erstellen! Öffnen Sie zunächst den Assistenten, indem sie auf das Item "Werkzeuge" -> "Assistenten" -> "Klassen Assistent" klicken. (Abb.1)

Geben Sie nun zunächst den Namen der Klasse ein und wählen Sie eine Elternklasse
(in RGSS Superclass) aus. Wenn ihr Skript
keine Elternklasse haben soll wählen Sie den
Eintrag "(Keine)".
Als nächstes müss Sie die zu verwendende
Methode auswählen. Also entweder "Main" oder "Initialize". Jenachdem welche Methode
Sie ausgewählt haben wird der Assistent die
dazugehörigen Codezeilen einfügen.

Wenn Sie nun noch Objekte (bzw, lokale Variablen) einfügen möchten geben Sie im unteren textfeld der Gruppe "Objekte integrieren" den Namen der Variable ein und klicken Sie auf hinzufügen.

Um die Klasse nun in ein Editorfenster bzw. Skript einzufügen klicken Sie auf "Einfügen".

ACHTUNG!: Wenn kein Editorfenster geöffnet ist wird auch keine Klasse erstellt. D.h. es wird kein Editorfenter automatisch erstellt.

Über die beiden Symbole im oberen Bereich des Assistentenfensters lässt sich der Assistent schließen (X) oder verkleinern bzw. vergrößern (Pfeile nach oben bzw. unten).
Um den Assistenten zu verschieben klicken Sie mit der rechten Maustaste auf den oberen Bereich des Assistentenfensters.


Wie erstelle ich Variablen?

Wie erstelle ich Variablen?

Ein ebenfalls wichtiger Assistent von RGSS Editor ist der Variablen-Assistent, mit dessen Hilfe auf einfachste Weise globale Variablen erstellt werden können!
Um den Assistenten zu öffnen klicken Sie auf das Item "Werkzeuge" -> "Assistenten" -> "Variablen Assistent" der Menüleiste .

Um eine Variable zu erstellen geben Sie in dem leeren Textfeld den Namen der Variable ein, die erstellt werden soll, und wählen Sie im Feld rechts daneben die Arte der Variable.

Klicken Sie dannach auf "Hinzufügen", um die Variable der temprären Liste hinzu zu fügen.
Wenn Sie die Art der Variable noch einmal ändern möchten können Sie dies per Rechtsklick auf die gewünschte Variable tun.
Nachdem Sie alle Variablen erstellt haben, die Sie Ihrem Skript hinzufügen möchten klicken Sie auf "Einfügen".

ACHTUNG!: Wenn kein Editorfenster geöffnet ist werden auch keine Variablen erstellt. D.h. es wird kein Editorfenter automatisch erstellt.

Über die beiden Symbole im oberen Bereich des Assistentenfensters lässt sich der Assistent schließen (X) oder verkleinern bzw. vergrößern (Pfeile nach oben bzw. unten).
Um den Assistenten zu verschieben klicken Sie mit der rechten Maustaste auf den oberen Bereich des Assistentenfensters.


Wie erstelle ich einen Infoheader?

Wie erstelle ich einen Infoheader?

Noch ein wichtiger Bestandteil von RGSS Editor ist der Informations-Assistent.
Mit seiner Hilfe können Sie ganz einfach Infoheader erstellen, die Ihr Skript kennzeichnen
und die wichtigsten Informationen über es ausgibt.
Um den Assistenten zu öffnen klicken Sie auf das Item "Werkzeuge" -> "Assistenten" ->
"Informations Assistent" der Menüleiste.

Wenn der Assistent geöffnet ist (Abb.1) klicken Sie auf weiter.

Abb.1

Es folgt Schritt 1. Wählen Sie "Neuen Infotag erstellen." und klicken Sie auf "Weiter".

Wenn Sie bereits einen Infotag erstellt und diesen gespeichert haben wählen Sie "Vorhandenen Infotag laden." und klicken Sie ebenfalls auf "Weiter".
Es erscheint ein Dialog, in dem Sie den erstellten Infotag auswählen müssen.

Abb.2

In Schritt 2 können Sie nun alle nötigen Informationen einstellen, sowie auswählen, ob Sie den Infoheader in einem neuen Editorfenster einfügen und einen SDK-Header verwenden möchten.

Klicken Sie auf "Fertig", um den Infogeader in ein Editorfenster einzufügen.
Infoheader werden automatisch am Anfang des Skript eingefügt, egal an welcher Position sich der Cursor befindet.

Abb.3

Wenn Sie die eingestellten Informationen speichern möchten klicken Sie auf Infotag speichern und wählen Sie einen Speicherort, sowie den Dateinamen aus.


Wie erstelle ich eine Hilfedatei im Textdatei Format?

Wie erstelle ich eine Hilfedatei im Textdatei Format?

Oft kommt es vor, dass andere Personen nicht genau wissen, wie sie mit einem Skript um zu gehen haben! Das liegt häufig daram, dass diese Personen die Anleitung nicht richtig lesen, sie die Anleitung nicht finden oder es erst gar keine gibt.

Aus diesem Grunde besitzt RGSS Editor einen ganz einfachen Assistenten, der Hilft eine Anleitung im Textdatei Format zu erstellen.
Um eine solche Datei zu erstellen ist es allerdings notwendig bestimmte Kommentare in Ihr Skript einzufügen, damit der Assistent erkennt welche Kommentare er verwenden soll.
Alle Kommentare, die folgendermaßen beginnen werden vom
Assistenten hierbei beachtet: #///
Wichtig ist außerdem auch, dass in der Zeile, in der der Kommentar steht nichts vor dem Kommentar stehen darf! Auch keine Leerzeichen.

Wenn Sie alle nötigen Kommentare in Ihr Skript eingefügt haben öffnen Sie den Assistenten indem Sie auf das Item "Werkzeuge" -> "Assistenten" -> "Hilfe Assistent" in der Menüleiste klicken.

Klicken Sie jetzt auf "Weiter", um mit dem Assistenten fortzufahren.

Wählen Sie nun bei Schritt 1 den Pfad aus, in dem die Hilfedatei erstellt werden soll und klicken Sie auf "Weiter".
Wählen Sie jetzt bei Schritt 2 aus, ob Sie einen Header integrieren möchten. Aktivieren Sie ggf. das Häckchenfeld und geben Sie alle nötigen Daten ein.
Klicken Sie auf "Weiter", um mit Schritt 3 fortzufahren.

In Schritt 3 wird schließlich die Hilfedatei mit alle nötigen Daten erstellt. Wenn der Assistent fertig ist klicken Sie auf die Schaltfläche Fertig, um den Assistenten zu beenden.


Wie packe ich mein Skript?

Wie packe ich mein Skript?

Wenn Sie soweit sind, dass Ihr Skript fertig ist, werden Sie eine weitere Funktion von RGSS Editor zu schätzen wissen! Den Skript-Pack Assistenten.
Mit seiner Hilfe lassen Sich Skript mit samt den dazugehörigen Dateien einfach in einen Ordner oder ein Archiv packen, so dass Sie es gleich weiter an Andere geben können.

Um den Assistenten zu öffnen klicken Sie in der Menüleiste auf das Item "Werkzeuge" ->
"Assistenten" -> "Skript-Pack Assistent".

Geben Sie hier alle nötigen Daten wie Zieldatei, Dateianhänge usw. an. (Wenn Sie das Häckchenfeld "Dateiverweise einbinden" aktivieren werden alle Dateien der aktuellen Dateiverweisliste ebenfalls gepackt.
Nicht existierende Dateien werden dabei automatisch ignoriert.)
Haben Sie alle Informationen eingestellt wählen Sie die Registerkarte "Packen" und klicken Sie auf die Schaltfläche "Packen".

Ihr Skript wird daraufhin gepackt!
Wenn Sie die Option
"In Ordner" gewählt haben werden Ihr Skript und alle anderen Dateien einfach in den Zielordner gepackt! Haben Sie die Option "Zu Zip-Archiv" gewählt werden alle Dateien in ein Zip-Archiv im ausgewählten Zielordner gepackt.


Wie erstelle ich ein eigenes Skript in der Skriptdatenbank?

Wie erstelle ich ein eigenes Skript in der Skriptdatenbank?

Wenn Sie viele Skripts haben, ist es oft schwer den Überblick zu behalten und man verliert oft einige Skripts bzw. man findet sie nicht mehr wieder!
Ich empfehle Ihnen für eine geeignete Verwaltung deshalb den Skriptexplorer von Monsta. Sie können jedoch auch die bereits enthaltene Skriptdatenbank von RGSS Editor erweitern.
Begeben Sie sich dazu in den Programmordner von RGSS Editor und öffnen Sie das Verzeichnis
"\Data\Script Database\My Scripts". Fügen Sie dort einen Ordner mit beliebigem Namen hinzu und kopieren Sie Ihre Skripts in diesen Ordner. In den "My Scripts" können sie so viele Ordner einfügen wie sie möchten! Sie werden dann alle von RGSS Editor eingelesen. Wichtig ist, dass Unterordner in diesen Ordner nicht beachtet werden, ebenso wie Skripts die direkt im Ordner "My Scripts" liegen. D.h. damit ein Skript erkannt wird muss es in einem Ordner innerhalb des "My Scripts" - Ordners liegen.


Über RGSS Editor

Über RGSS Editor

In diesem Abschnitt erhalten Sie noch ein paar allgemeine Informationen über RGSS Editor!

Wenn Sie noch Fragen haben können Sie diese über folgende Wege an mich richten:

1. Forenthread oder PN an !Tocs! auf www.rmxp.de .
2. Forenthread oder PN an !Tocs! auf www.rpgxp-world.net .
3. Forenthread oder PN an !Tocs! auf www.rpg-xp.net .

Die größte wahrscheinlichkeit mich zu erreichen und der beste Weg ist wahrscheinlich der Forenthread auf www.rmxp.de!


Programmgschichte

Programmgschichte

Version 0.8.0.0 erste Betaversion

Version 0.8.5.0 zweite Betaversion
Weitere grundlegend Funktionen und Assistenten hinzugefügt.
Detailfenster hinzugefügt.

Version 0.9.0.0 erste öffentliche Betaversion
Weitere Tools wie Farbauswahl und Tastencodes hinzugefügt.
Bugs beseitigt.

Version 0.9.5.0 zweite öffentliche Betaversion
Autoload und Autosave hinzugefügt.
Codeschnipsel hinzugefügt.
Syntacmarker hinzugefügt.
Bugs beseitigt.

Version 0.9.5.5 letzte geschlossene Betaversion
Editor Performance und syntaxhighlighting verbessert.
Neues Optionsmenü.
Sidebar hinzugefügt.
Neuer Style hinzugefügt.
Supertooltips hinzugefügt.
Skriptdatenbank erweitert.
Bugs beseitigt.

Version 1.0 Vollversion (erschienen am 21. April 2007)
 Veröffentlichung der Vollversion


Dateibibliothek

Dateibibliothek

RGSS Editor
Aktuelle Version 1.0 (21. April 2007)
Tutorialpaket Verion 0.1.0.0

!Tocs!
RGSS Editor.exe (V. 1.0.0.0)
RE_Core.dll (V. 1.0.0.0)
RE_Pluginloader.dll (V. 0.1.0.0)

Mark Krueger
ICSharpCode.SharpZipLib.dll (V. 0.84.0.0)

Marc Cramer
mkc_CodeBox (Edited by !Tocs!).dll (V. 1.1.0.0)

Component Factory Pty Ltd
ComponentFactory.Krypton.Toolkit.DLL (V. 2.5.1.0)

Skybound Software
Skybound.VisualTips.dll (V. 0.9.1.0)

Developer Express Inc.
DevExpress.Data.v6.3.dll (V. 6.3.3.0)
DevExpress.Utils.v6.3.dll (V. 6.3.3.0)
DevExpress.XtraEditors.v6.3.dll (V. 6.3.3.0)
DevExpress.XtraNavBar.v6.3.dll (V. 6.3.3.0)


Credits

Credits

An dieser Stelle möchte ich (!Tocs!) als Ersteller dieses Programm noch einmal bei allen Personen und Communities bedanken, die entscheidend bei der Entwicklung von RGSS Editor geholfen haben!

Abt Ploutôn (Betatesting/Support)
Kudesnick (Vista Iconpack)
Monsta (Betatesting/Support)
Nomad (Betatesting)
Pain (Betatesting/Support)
Firephoenix (Betatesting/Setup/Suport/Artworks)
www.rpgxp.de - Community (Support)
www.RPGXP-World.net - Community (Support)
www.rpgxp.de (Hosting)
www.rpg-xp.net - Community; especially Xelax90 & Thunderbolt256 (Support)


($title$)

($title$)

($content$)