DynRPG: About DynRPG

DynRPG v0.11
RM2k3 Plugin SDK
  • Main Page
  • Related Pages
  • Modules
  • Namespaces
  • Classes
About DynRPG
Author:
David "Cherry" Trapp

Also visit the main page, Cherry Tree!

Download

Yes, this is the first paragraph, because I know people are looking for it most of the time, probably. So be it.

Click me hard!

Contact

And yes, this is the second paragraph, because people seek this information very often too.

If you have any questions, you may either ask in of the following forum threads:

  • English: Thread on RMN
  • German: Thread on Multimediaxis
  • French: Thread on Oniromance (my reponses will be in English though)

...or write me an e-mail at dynrpg@cherrytree.at!

Oh, and if you find errors in this documentation, or bugs in the patch or the SDK, please tell me too!

Introduction

DynRPG is a plugin SDK for RPG Maker 2003. "SDK" means "Standard Development Kit", and in this case it means that everyone can create his own extensions to the RPG Maker software now, as long as he knows how to use C++. DynRPG not only offers the average programmer access to the world of "patching", but it also provides the basis for far more powerful extensions than all "patches" made for the RPG Maker before.

DynRPG works using plugins. Plugins can be written in C++, they will be loaded when the game starts and they are notified of certain events (like the drawing of a new frame, the writing to a variable, etc.) and are allowed to react to these events.

What in past were "patches" are now going to be simple plugins. Any game using DynRPG can be extended by a new feature by simply putting a plugin file into a folder called DynPlugins. That's far easier than "patching", something which many game makers are even afraid of, because they think it might harm their game. And if somebody doesn't like a certain plugin, all he needs to do is deleting it.

So, DynRPG is beneficial to both plugin makers and game makers:

  • Plugin makers can use a simple C++ library to write powerful plugins and distribute them to other game makers!
  • Game makers get many new possibilities just by adding these plugins to their game!
  • Professional game makers are able to write plugins which exactly fit to their game's needs, for example they might write part of their action battle system in C++ or apply a custom design to the default battle system, or maybe they even create a whole minigame using DynRPG... the possibilities are endless!

Important links

Are you a game maker? Then look at The Patch to find out how to install and use the DynRPG Patch and what features it has!

Are you a plugin maker? Then you might start with the Getting Started section, and make sure you follow the Rules and guidelines for plugin developers! Of course, you can also explore the SDK documentation using the navigation bar and the search function. The two main sections you need are the RPG namespace and the Callbacks.

Parts

The name "DynRPG" means this project as a whole... but actually, it consists of several parts:

  • The DynRPG Patch: This is the only real patch here. Yes, I was not completely honest: The game makers don't get completely rid of "patching", since they have to install this one patch. It is a small patch for RPG Maker 2003 version 1.08, which loads the DynRPG Loader at startup, notifies it of game events and also applies several bugfixes to the RPG Maker. The DynRPG Loader then looks for plugins, loads them and later forwards game events to them. The DynRPG Patch is compatible with most of the other RPG Maker 2003 patches out there. More information here: The Patch
  • The DynRPG Patcher: This simple tool installs the DynRPG Patch for you.
  • The DynRPG Loader: That's a little DLL file called dynloader.dll which is the middle-man between the DynRPG Patch and the plugins.
  • The DynRPG SDK: That's the library and the C++ header files which allow you to create your own plugins for DynRPG very easily. (If you are no programmer but just a game maker looking for ready-made plugins, you don't need to bother yourself with this.)
  • The plugins: Although not actually part of the DynRPG project, the plugins are what makes the whole thing useful. They can extend the features of the RPG Maker (as in the past patches did), but in a far more powerful way. A plugin is a simple DLL file which is placed in the DynPlugins folder of a game.
Generated on Mon Feb 6 2012 22:24:57 for DynRPG by doxygen 1.7.6.1


DynRPG: Related Pages

  • Related Pages
  • Modules
  • Namespaces
  • Classes
Related Pages
Here is a list of all related documentation pages:
  • The Patch
  • Rules and guidelines for plugin developers
  • Changelog
  • Getting Started


DynRPG: The Patch

  • Classes
The Patch

Installation

It couldn't be easier: You just run the patcher (that's the file called dynrpg_patcher.exe), select your project's RPG_RT.exe file and that's it, at least in most of the cases. DynRPG should be compatible with all other 1.08-based patches.

In case you don't have RPG_RT.exe version 1.08, the patcher will offer you to install it. However, this will remove all existing modifications (other patches, custom icon, etc.). But don't worry, in case anything goes wrong there is always a backup (that's the file with the .bak extension). If you install the patch "over" an existing (older) version of the DynRPG Patch, there will also be a backup of the dynloader.dll file.

You don't need to include the backup files (ending with .bak) in your finished game. Also, players don't need to install anything special to run a game which uses DynRPG.

The patcher will also automatically create a DynPlugins folder for you, so you can immediately start adding and using plugins.

Extra Features

Of course, the main feature of the DynRPG Patch is interfacing the DynRPG Loader, which then loads the plugins. (See Parts for more information.) But that's not everything, the patch also comes with several improvements and bugfixes for the RPG Maker:

  • Improvement: More pictures! You can now use 2000 pictures instead of 50, and pictures #1001 to #2000 are not erased when the player goes to a new map! Please read the About the pictures section below to find out what you need to know about this feature.
  • Improvement: Monsters are now flashed more intensively when they do their turn. Before, it was hard to follow what was going on in battle, especially if a monster used the "Attack" command.
  • Improvement: The skill information window is longer visible in battle. This makes it easier to understand the moves of monsters.
  • Improvement: Picture operations now also work while a message is displayed. (Yes, that's the same thing the UnlockPics Patch does.)
  • Improvement: The game doesn't completely close when an error occurs. Instead it goes back to the title screen.
  • Improvement: You can now press F11 to go to the save menu at any time (in test play only).
  • Improvement: The "Input Number" event command will now use the existing value in the variable as initial value. Before, it always started with zero.
  • Improvement: When you press ESC at a "Show Choice" command where the cancel behavior is set to "Ignore", now the buzzer sound is played.
  • Improvement: Transparent message windows will now also work with the "Traditional" battle layout (at least out of the battle). You have to change the battle layout so that the "Transparent" checkbox becomes enabled, check or uncheck it and then change the battle layout back.
  • Bugfix: The game would crash when you removed an actor in battle when this actor was the last do to his turn.
  • Bugfix: The "Enemy Attack" sound was never played.
  • Bugfix: The game would crash if a skill was reflected on an actor with an ID higher than the number of actors in the party.
  • Bugfix: The battle status window was gone while the skill selection window was open.
  • Bugfix: If you had selected "Small Window" in the "Battle Layout" tab of the database, the action selection window would only display 3 lines plus an ugly empty one at the bottom.
  • Bugfix: The "Order" menu (used for rearranging party members) didn't play the cancel sound when you exited.
  • Bugfix: When the shop system was used, the events weren't updated, which means that if you bought an item in the shop, events which used this item as start condition wouldn't execute immediately.

About the pictures

The DynRPG patch increases the picture limit to 2000. You might have heard that Hyper Patcher 2 is able to increase this limit to a crazy 9999, but this is not so healthy in this case. Using that many pictures takes several seconds to load on starting or loading a game or going to title screen, plus you would have very bad performance with DynRPG because the DynRPG SDK allows plugins to intercept picture drawing. Each plugin is called once before and once after the picture is to draw, so you can imagine that 9999 pictures would mean 5 times more plugin calls than 2000 pictures, so I decided that 2000 pictures would be the best compromise.

You can still use Hyper Patcher 2 to change this limit, but only pictures #1 to #1000 will be erased on map change!

The fact that pictures with an ID greater than 1000 won't be erased automatically allows you to use pictures for cross-map purposes more easily.

However, there is one thing you need to do (unless you are already using PicPointerPatch): You need to modify the RPG Maker editor itself too, otherwise you won't be able to select picture IDs greater than 50 in the event editor. There are two ways to do this:

  • The easy way: You need to use RPG Maker 2009 Ultimate. You then just need to create a file called morepictures.ini (or whatever name you like) in RPG Maker 2009 Ultimate's uimod folder and put the following text into it:
    [FormEvCmd11110]
DialEdit1.MaxValue=100000

[FormEvCmd11120]
DialEdit1.MaxValue=100000

[FormEvCmd11130]
DialEdit1.MaxValue=100000
    Then you need to edit the ultimate.ini file: Open it in a text editor, go to the section [UIMod] and add your file at the end of the section.
  • The hard way: If you do not want to use RPG Maker 2009 Ultimate, you need to directly edit your RPG2003.exe file:
    1. Download Resource Hacker.
    2. Open your RPG2003.exe file in it.
    3. Navigate to RCDATA > TFORMEVCMD11110 > 0.
    4. In the script on the right side, look for the following line:
      MaxValue = 50
      If you have an older RPG Maker version, it might be 40 instead of 50. Increase this value, for example, to 100000. The reason we use such a high value is that higher values might be used for extra features (for example, with the PicPointerPatch).
    5. Click Compile Script.
    6. Repeat steps 4 and 5 for the pages RCDATA > TFORMEVCMD11120 > 0 and RCDATA > TFORMEVCMD11130 > 0.
    7. Save your changes and exit Resource Hacker.
Generated on Mon Feb 6 2012 22:24:55 for DynRPG by doxygen 1.7.6.1


DynRPG: Rules and guidelines for plugin developers

Rules and guidelines for plugin developers

Rules

The RPG Maker is written in Delphi (and I didn't have access to the source code of its classes, etc.), while my SDK uses C++. Thus, many things are not working the way you might expect.

There is a set of rules which you must follow under all circumstances when you are developing a DynRPG Plugin:

  • Do not try to use members which are not documented. They are either unknown or used internally and dangerous. (Of course, if you know what a member does, it's a different story.)
  • Do not instantiate RPG classes. Always use pointers to existing instances you get from DynRPG. It is especially dangerous to use these "home-made" objects with functions from the RPG namespace. It might seem to work, but will most likely corrupt data. This will cause the game to behave strangely or suddenly crash some minutes later. An exception to this rule are the RPG::Music and RPG::Sound classes.
  • Do not assign RPG objects. The result is mostly undefined. An exception are pointers to RPG::Image objects, as long as you don't forget to destroy the old object using RPG::Image::destroy (unless you want to use it before).
  • Do not randomly return false from a callback function. This will "lock out" all plugins which are called after yours. Only return false if you really want this behavior.
  • Never change the vTable member of a class. This will make the game crash sooner or later (probably sooner).
  • Never assign a char * to an RPG::DString pointer. It will appear to work, but it will cause the game to crash with an "Invalid pointer operation" error when the RPG Maker tries to free the string. Also, do not store RPG::DStringPtr objects or RPG::DString pointers inside your plugin, but copy their content to a std::string instead, since RPG::DString objects may suddenly vanish.
  • Do not change the current directory.
  • Do not do stuff every frame which takes longer than one millisecond. This is alredy the very maximum. The less time you use, the better. If you need to do something which takes longer, do it in another thread. An exception are things which happen only rarely, like when a game is loaded or saved, or once when a battle starts, etc. If something should intentionally take longer than one frame, you could use the RPG::Screen::update or RPG::updateBattle function, respectively.

Guidelines

There is also a set of guidelines which you are strongly advised to follow, but there might be cases in which there is a better solution.

Event comments

Comments in event scripts are a great way to let events scripts invoke functions of your plugin. Please follow the following guidelines:

  • Use the following pattern for "special comments":
    @command parameter1, parameter2, parameter3, ...
  • New-line characters should be generally ignored.
  • The comment has to start with an @ sign, immediately followed by the command name.
  • The command name is case-insensitive.
  • There should be three possible types of parameters:
    • Number: A simple number. Can also use the decimal point and the scientific notation (e.g. 5.5e+6 for 5.5 million).
    • String: A simple string. Must be put between doublequotes. To use a doublequote in a string, it is written twice (e.g. He said ""hello"" and smiled)
    • Token: Some identifier. Tokens are not put between quotes, and they may not contain spaces (spaces are removed). Tokens are case-insensitive. They may be used for keywords.
    There are special tokens for referencing variables and actor names:
    • Variables: To reference a variable, the user should be able to write a V character prior to the variable ID. This should also work with multiple levels of dereferencing.
    • Actor names: To reference an actor's name, the user should be able to write a N character prior the the actor ID. This should also work together with V.
  • The command name and tokens should be case-insensitive.
  • Always return false from onComment when you found a known command, regardless whether the parameters were valid or not.
  • Always return true from onComment when you didn't find a known command, even though you may have found an @ sign at the beginning of the comment.

Use the parsedData parameter of your onComment handler to get the comment data in an already nicely parsed form!

Note:
The maximum number of parameters is 100. The maximum number of characters per parameter (or command name) is 200. You have to parse the comment yourself if you need more.

Example for a "special" comment:

@FooBar 123, "abc", V55, VV66, N7, NV8, Nothing

The command name is foobar.
The first parameter is numerical.
The second parameter is a string.
The third parameter is a numerical value read from variable #55.
The fourth parameter is a numerical value read from the variable whose ID is stored in variable #66.
The fifth parameter is a string, read from the name of actor #7.
The sixth parameter is a string, read from the name of the actor whose ID is stored in variable #8.
The seventh parameter is a token named nothing.

You might advise users to download RPG Maker 2009 Ultimate if they need to enter comments longer than 4 lines.

Configuration

Many plugins need some kind of configuration. An important rule is: Make as many things configurable as possible.

If possible, store configuration in a DynRPG.ini file. Also, you should use your plugin's name which you get as parameter to the onStartup function as section name. If you need several sections, you can append an underscore and an additional identifier to the name and use it as section name. This will prevent conflicts with other plugins while still combining all relevant configuration of a game in one file.

You may use the RPG::loadConfiguration function as a convenient way to load configuration data to a std::map<std::string, std::string> in the onStartup function.

If you need more or more complex configuration, like XML data, use a filename containing your plugin's name.

In-game data

Your plugin may also use data which is changed in-game and needs to be preserved. Savestate-independent data (like a highscore) should be stored in the DynRPG.ini file together with configuration (use the WinAPI function WritePrivateProfileString).

Savestate-related data (data which should be saved when the user saves the game and loaded when the use loads a saved game) should be saved using the function passed as savePluginData parameter to the onSaveGame function. When the user loads the savestate again, you will get the same data back, in the parameters to the onLoadGame function. Internally, this data is saved in a file called SaveXX.dyn where XX is the savestate ID.

An example usage of savestate-related plugin data is shown here:

// Plugin-related data
int score;
int level;

// ...

void onLoadGame(int id, char *data, int length) {
               if(length == sizeof(int) * 2) { // make sure it is valid data
                              int *dataArray = (int *)data;
                              score = dataArray[0];
                              level = dataArray[1];
               }
}

void onSaveGame(int id, void __cdecl (*savePluginData)(char *data, int length)) {
               int[2] dataArray;
               dataArray[0] = score;
               dataArray[1] = level;
               savePluginData((char *)dataArray, sizeof(dataArray));
}

(Of course, the same result could have been achieved by saving score and level in in-game variables which are automatically saved.)

Optimization

Time is a very important factor. Especially with many plugins, it is important to use as little time as possible in your callback handlers, otherwise the game will eventually start lagging. Thus, try to optimize your code where you can. If possible, always test your plugin with several other plugins in a "real-life situation" to see whether your plugin slows the game down too much. Remember that most of your code will be executed a minimum of 60 times per second (many parts more often than that, for example onCheckEventVisibility will be called 900 times per second if there are 150 events on the map).

Here is a bit of advice how to optimize your plugin code:

  • Do not allocate and deallocate memory or objects over and over again. Try to use static variables wherever possible.
  • Try to use functions in the RPG::Image and RPG::Canvas classes as little as possible. The slowest functions are RPG::Image::drawText and RPG::Canvas::draw.
  • Try to cache text in an RPG::Image if possible, only update it if necessary.
  • Try to cache as much with the same palette as possible on the same RPG::Image so that you don't have to call RPG::Canvas::draw too often.
  • If possible, don't use a transparent color in RPG::Image::draw (set maskColor to RPG::MASK_NONE). The same rule applies for RPG::Canvas::draw, see also RPG::Image::useMaskColor.
  • Try to skip frames if possible. This means: Try to update some things only every 2 or 3 frames if possible.
  • If you are "WinAPI-literate", you can use the RPG::Canvas::bitmap member and the RPG::DBitmap::getHBITMAP and RPG::DBitmap::getHDC functions to get handles to the corresponding GDI objects and manipulate them directly.
  • If you need to calculate something more complex (like a 3D image, etc.) you better do this in a new thread, cache its graphics and draw them to the screen only after calculation was finished, without letting the main thread wait.
Generated on Mon Feb 6 2012 22:24:55 for DynRPG by doxygen 1.7.6.1


DynRPG: Changelog

Changelog

Version 0.11 (2012/02/06)

Only the SDK was updated. The patch still shows version 0.10.

  • RPG::BattleSettings class and RPG::battleSettings object added.

Version 0.10 (2012/02/05)

This is the first release. I started this project on 2012/01/23, by the way. Just in case somebody wants to know.

Generated on Mon Feb 6 2012 22:24:55 for DynRPG by doxygen 1.7.6.1


DynRPG: Getting Started

Getting Started
Note:
This page describes how to get started with the SDK. If you want to know how to get started with the Patch, see The Patch.

The right C++ Compiler

The DynRPG SDK works on a very low level. This means, small differences between compilers can break everything. The DynRPG was developed and tested using GCC, thus it is recommended that you use GCC too. You might use the Bloodshed Dev-C++ IDE, for example.

Installation

Installing the SDK is easy - all you need to do is copying the files from the include and lib directories of the download archive into the corresponding folders of your compiler environment.

If you use Dev-C++, for example, you just need to copy the two folders, go to C:\Program Files\Dev-Cpp, paste them, and confirm merging the folders.

Header and library

In order to use the DynRPG in your C++ project, you need to include DynRPG/DynRPG.h:

#include <DynRPG/DynRPG.h>
Warning:
If you use more than one code module, you need to put the following line before the include statement in all modules except one:
#define NOT_MAIN_MODULE

If you want DynRPG to automatically create an empty DllMain function for you, you can define AUTO_DLLMAIN before including the header file:

#define AUTO_DLLMAIN
#include <DynRPG/DynRPG.h>

The header file automatically includes the headers string, map and windows.h because they are needed for the declarations.

Warning:
Since the RPG Maker is Non-Unicode, your plugin should be Non-Unicode too!

You also need to add the library dynrpg (libdynrpg.a) to your project. See your IDE's help file if you don't know how to do this. (Normally you need to add the parameter -ldynrpg to the linker's command line.)

Callbacks

Together with the Game objects, callbacks are important ways to interface your plugin with the game. Callbacks are functions which you can define in your plugin. On certain events in the game (for example, a picture is drawn - see onDrawPicture) certain callbacks will be called by DynRPG. Callbacks either return void or bool. If you return false in bool callbacks, this will prevent other plugins from receiveing the same notification and sometimes it will also prevent some event from happening in the game. For example, if you return false from your onDrawPicture callback, the picture won't be drawn and other plugins (after yours) won't receive onDrawPicture for that picture.

You only need to define those callback functions which you actually use.

For a list of available callbacks, click here: Callbacks

Game objects

The game objects are the second important way to interface your plugin with the game. Most of the RPG classes are tied to a game object and should only be used through it. For example, the game object tied to RPG::Actor is called RPG::actors.

Game objects represent certain "things" in the game. For example, the RPG::map object (the corresponding class is called RPG::Map) represents the current map. So, to get the width of the current map, you may call the RPG::Map::getWidth function like this:

int mapWidth = RPG::map->getWidth();

For a list of available game objects, click here: Game objects

Hello World - Our first plugin

It's time to create our first plugin. It's going to be really simple - all it is going to do is displaying a message box asking whether we really want to play before actually starting the game.

First, create an RPG Maker 2003 project to test the plugin and apply The Patch to it. Then, create a new C++ project in your favorite IDE and select DLL as project type. It would be convinient to store the source code in the DynPlugins directory of your test project, or in case you put it somewhere else you might at least set the compiler output directory to the DynPlugins directory.

Okay, let's call our first plugin are_you_sure, so we need a file called are_you_sure.cpp in which we write the following code:

#define AUTO_DLLMAIN
#include <DynRPG/DynRPG.h>

// Handler called on startup
bool onStartup(char *pluginName) {
               if(MessageBox(
                              NULL, // We don't need a window handle
                              "This is such a haaaaard game. Are you SURE you want to play it now?", // Text
                              "The Are You Sure Plugin", // Title
                              MB_YESNO | MB_ICONQUESTION // Flags (yes/no buttons and question icon)
               ) == IDYES) {
                              // The user clicked "Yes", we may continue
                              return true;
               } else {
                              // The user clicked "No", so we need to abort
                              return false;
               }
}

Okay, that's really simple. It uses Windows' MessageBox function to display a message. If the user clicked "Yes", the game will continue, otherwise it will not start.

This simple plugin uses the onStartup callback. This callback is called before the game starts. If you return false in this callback, the game won't start. (You only need to define those callbacks which you want to use.)

So, if you compile this plugin, make sure the DLL file was put into the DynPlugins directory and your test project was successfully patched using The Patch, you should see the DynRPG logo when you start the game, followed by our message box.

By the way, the DynRPG logo cannot be removed. Yes, that's intentional.

Condition Icons - More Advanced

Enough of nonsense. Now we are going to create something useful. We are going to create a plugin which displays the conditions of actors and monsters over their head, as icons.

These are its features:

  • It will read the filenames of the icons from the configuration file.
  • It will load the files on demand (when they are needed the first time).
  • It will display them over the head of the battlers, horizontally centered, vertically aligned at the bottom (in case the images don't have the same height).
  • It will disable the default info window which is shown on target selection so that we don't show the conditions twice.

First, in the onStartup handler, we will load the configuration and store it in a global variable called configuration.

Then, in the onBattlerDrawn handler, we will iterate through all conditions the battler has, check if the images we need are loaded, if not, load them. We will also calculate the total width of all icons for that battler here. Then we will draw all the icons and finally clear the RPG::Battler::displayedConditions array so that no info window is displayed when the target selection is active.

Finally, in the onExit handler, we will unload all images.

This is the content of our condition_icons.cpp file:

#define AUTO_DLLMAIN
#include <DynRPG/DynRPG.h>
#include <sstream> // For std::stringstream

// We store the configuration here
std::map<std::string, std::string> configuration;

// We store the images of the conditions here
std::map<int, RPG::Image *> images;

// This handler is called on startup
bool onStartup(char *pluginName) {
               // We load the configuration from the DynRPG.ini file here
               configuration = RPG::loadConfiguration(pluginName);
               return true; // Don't forget to return true so that the start of the game will continue!
}

// This handler is called after a battler is drawn
bool onBattlerDrawn(RPG::Battler *battler, bool isMonster, int id) {
               int totalWidth = 0; // We store the total width of the condition icons here

               // We loop through all the elements of the battler's "conditions" array here
               // Note that the "condition" array is one-based, thus we start at index 1
               for(int i = 1; i <= battler->conditions.size; i++) {
                              // If the battler has the condition (see documentation)...
                              if(battler->conditions[i] > 0) {
                                             // If the image isn't loaded yet...
                                             if(!images[i]) {
                                                            // First, we create an RPG::Image object
                                                            images[i] = RPG::Image::create();

                                                            // Yes, we want to use the transparent color
                                                            images[i]->useMaskColor = true;

                                                            // Now, we put the key name for the configuration entry together
                                                            // It should be "Condition12" for condition 12, for example
                                                            std::stringstream keyName;
                                                            keyName << "Condition" << i;

                                                            // Now, we try to load the image. If loading the image fails,
                                                            // nothing special will happen (because of the "false" at the
                                                            // "showErrors" parameter), the image will just be empty.
                                                            images[i]->loadFromFile(configuration[keyName.str()], false);
                                             }

                                             // We add the image's width to the total width
                                             totalWidth += images[i]->width;
                              }
               }

               // Now we need to know the Y coordinate of the top of the battler
               int topY;
               if(isMonster) {
                              // It is a monster. We just use the monster's image to find out
                              // its size.
                              RPG::Monster *monster = (RPG::Monster *)battler; // First, we cast the "battler" to a "Monster"
                              topY = monster->y - monster->image->height / 2; // Now we calculate the top position
               } else {
                              // Okay, since we don't have a way to find out the size of an actor's
                              // battle graphic, we will just "guess" that it's a normal BattleCharSet
                              // which is 48 pixels tall.
                              // In a "good" plugin, there would be a way to set the actual height
                              // for each actor in the configuration, but this would be too much
                              // for this tutorial.
                              topY = battler->y - 48 / 2;
               }

               // We will use this variable to store the current X coordinate while we
               // draw the images. We will increase this variable every time we draw an
               // image.
               int currentX = battler->x - totalWidth / 2;

               // Okay, let's loop again through the conditions. This is necessary
               // because we first had to find out the total width before we could
               // start drawing the images. Now we will draw them.
               for(int i = 1; i <= battler->conditions.size; i++) {
                              // If the battler has the condition (see documentation)...
                              if(battler->conditions[i] > 0) {
                                             // Okay, here we actually draw the image on the screen!
                                             RPG::screen->canvas->draw(currentX, topY - images[i]->height, images[i]);

                                             // And we increase the current X coordinate.
                                             currentX += images[i]->width;
                              }
               }

               // Clear the condition cache which is normally used to determine which
               // conditions should be shown in the "info window" on top of the screen
               // during target selection (we don't need to display the conditions twice!)
               for(int i = 0; i < 5; i++) {
                              battler->displayedConditions[i] = 0;
               }

               return true; // It's okay that the battler is drawn, so we return true. Don't forget that!
}

// This handler is called when the game exits
void onExit() {
               // We will unload all images here.
               // If you are not familiar with C++ iterators: This "for" loop just iterates
               // through all items in "images".
               for(std::map<int, RPG::Image *>::const_iterator iter = images.begin(); iter != images.end(); ++iter ) {
                              // The reason we don't use images[iter->first] instead of iter->second
                              // is that RPG::Image::destroy also takes a reference and sets the
                              // parameter to zero at the end.
                              RPG::Image::destroy(images[iter->first]);
               }
}

To try it, we just need to put the compiled DLL into the DynPlugins folder (if it isn't already there). Then we need to get some icons. For testing, I made some very simple 16x16 icons and put them into the Picture folder.

Then we need to open our DynRPG.ini and put the filenames in it, like this:

[condition_icons]
Condition2=Picture\poison.png
Condition3=Picture\blind.png
Condition5=Picture\berserk.png
Condition6=Picture\confused.png
Condition7=Picture\sleep.png

And hey presto, this is what we get:

You can download the source code as well as the finished plugin here.

What next?

You may now start developing your own plugins. You may first take a look at the Callbacks, the Game objects, and the members of the RPG namespace, to get an overview of what is possible and how to get to the result you want. Then, you might start with something easy (like a DynRPG-based version of the PicPointerPatch - hint: take a look at onEventCommand, RPG::EventScriptLine and RPG::variables), then expand your knowledge until you can do nearly everything you want... or something like that. :-)

Yes, I know, I am just throwing you out into the wilderness. Sorry for not providing you more examples how to use all the features. I just had no time for it yet. If you are clever, you will probably be able to create something useful with what you got in this documentation anyway. If not, more examples will come. I will create nice plugins and publish them with source code, etc.

Oh, and don't forget to read and follow the Rules and guidelines for plugin developers!

By the way: If you want to publish your plugin, it would be nice if you would publish the source code too.

Have fun!
Best regards, Cherry

Generated on Mon Feb 6 2012 22:24:55 for DynRPG by doxygen 1.7.6.1


DynRPG: Modules

Modules
Here is a list of all modules:
  • Game objects
  • Callbacks


DynRPG: Game objects

Variables
Game objects

Variables

static RPG::NamedCatalogPtr
< RPG::Actor * > & 		RPG::actors = (**reinterpret_cast<RPG::NamedCatalogPtr<RPG::Actor *> **>(0x4CDDC8))
Array of actors from the database, used for properties which can change in-game.
static RPG::BattleSettings *& | RPG::battleSettings = (**reinterpret_cast<RPG::BattleSettings ***>(0x4CDD60))
Battle settings.
static RPG::Hero *& | RPG::hero = (**reinterpret_cast<RPG::Hero ***>(0x4CDE54))
The hero (which moves around on the map, similar to an event)
static RPG::NamedCatalogPtr
< RPG::DBActor * > & 		RPG::dbActors = (**reinterpret_cast<RPG::NamedCatalogPtr<RPG::DBActor *> **>(0x4CDD54))
Array of actors from the database, used for default values and properties which are not supposed to be changed in-game.
static RPG::DBSystem *& | RPG::dbSystem = (**reinterpret_cast<RPG::DBSystem ***>(0x4CDC0C))
Object of "system" data, used for default values and properties which are not supposed to be changed in-game.
static RPG::Input *& | RPG::input = (**reinterpret_cast<RPG::Input ***>(0x4CDAEC))
Object used for key assignments and key input checking.
static RPG::Map *& | RPG::map = (**reinterpret_cast<RPG::Map ***>(0x4CDD74))
The current map environment (camera, events, etc.)
static RPG::CatalogPtr
< RPG::Monster * > & 		RPG::monsters = (**reinterpret_cast<RPG::CatalogPtr<RPG::Monster *> **>(0x4CDE64))
Array of monsters in the current monster group.
static RPG::NamedCatalogPtr
< RPG::Picture * > & 		RPG::pictures = (**reinterpret_cast<RPG::NamedCatalogPtr<RPG::Picture *> **>(0x4CDF3C))
Array of pictures.
static RPG::Screen *& | RPG::screen = (**reinterpret_cast<RPG::Screen ***>(0x4CDB24))
The screen, including window properties, FPS and the drawing canvas.
static RPG::Switches | RPG::switches
Switches array
static RPG::System *& | RPG::system = (**reinterpret_cast<RPG::System ***>(0x4CDC7C))
Object of "system" data, used for values which can be changed in-game.
static RPG::Variables | RPG::variables
Variables array

Variable Documentation

RPG::NamedCatalogPtr<RPG::Actor *>& RPG::actors = (**reinterpret_cast<RPG::NamedCatalogPtr<RPG::Actor *> **>(0x4CDDC8)) [static]

Array of actors from the database, used for properties which can change in-game.

Use the database ID as index for accessing an actor.

Example:

int zackHp = RPG::actors[1]->hp;
See also:
RPG::dbActors
RPG::BattleSettings*& RPG::battleSettings = (**reinterpret_cast<RPG::BattleSettings ***>(0x4CDD60)) [static]

Battle settings.

Please mind that this object is not saved and loaded automatically, but only initialized once at startup.

RPG::NamedCatalogPtr<RPG::DBActor *>& RPG::dbActors = (**reinterpret_cast<RPG::NamedCatalogPtr<RPG::DBActor *> **>(0x4CDD54)) [static]

Array of actors from the database, used for default values and properties which are not supposed to be changed in-game.

Use the database ID as index for accessing an actor.

Example:

int zackUnarmedAnimation = RPG::dbActors[1]->unarmedBattleAnimationId;
See also:
RPG::actors
RPG::DBSystem*& RPG::dbSystem = (**reinterpret_cast<RPG::DBSystem ***>(0x4CDC0C)) [static]

Object of "system" data, used for default values and properties which are not supposed to be changed in-game.

See also:
RPG::system
RPG::Hero*& RPG::hero = (**reinterpret_cast<RPG::Hero ***>(0x4CDE54)) [static]

The hero (which moves around on the map, similar to an event)

RPG::Input*& RPG::input = (**reinterpret_cast<RPG::Input ***>(0x4CDAEC)) [static]

Object used for key assignments and key input checking.

RPG::Map*& RPG::map = (**reinterpret_cast<RPG::Map ***>(0x4CDD74)) [static]

The current map environment (camera, events, etc.)

For accessing events, use RPG::map->events[event ID].

RPG::CatalogPtr<RPG::Monster *>& RPG::monsters = (**reinterpret_cast<RPG::CatalogPtr<RPG::Monster *> **>(0x4CDE64)) [static]

Array of monsters in the current monster group.

Use the zero-based party member ID as index for accessing a monster.

Example:

int slimeHp = RPG::monsters[2]->hp; // read HP of third monster
See also:
RPG::Battler
RPG::actors
RPG::Actor::partyMember
RPG::NamedCatalogPtr<RPG::Picture *>& RPG::pictures = (**reinterpret_cast<RPG::NamedCatalogPtr<RPG::Picture *> **>(0x4CDF3C)) [static]

Array of pictures.

Use the picture ID as index for accessing a picture.

RPG::Screen*& RPG::screen = (**reinterpret_cast<RPG::Screen ***>(0x4CDB24)) [static]

The screen, including window properties, FPS and the drawing canvas.

RPG::Switches RPG::switches [static]

Switches array

RPG::System*& RPG::system = (**reinterpret_cast<RPG::System ***>(0x4CDC7C)) [static]

Object of "system" data, used for values which can be changed in-game.

See also:
RPG::dbSystem
RPG::Variables RPG::variables [static]

Variables array

Generated on Mon Feb 6 2012 22:24:55 for DynRPG by doxygen 1.7.6.1


DynRPG: Callbacks

Functions
Callbacks

Functions

bool __cdecl | onStartup (char *pluginName)
Called when the plugin was loaded.
void __cdecl | onInitFinished ()
Called after the RPG objects were initialized.
void __cdecl | onInitTitleScreen ()
Called before the title screen is initialized.
void __cdecl | onNewGame ()
Called before the player starts a new game.
void __cdecl | onLoadGame (int id, char *data, int length)
Called before the player loads a game from a savestate.
void __cdecl | onSaveGame (int id, void __cdecl(*savePluginData)(char *data, int length))
Called before the player saves a game.
void __cdecl | onExit ()
Called before the game exits.
void __cdecl | onFrame (RPG::Scene scene)
Called every frame, before the screen is refreshed (see details!)
bool __cdecl | onSetVariable (int id, int value)
Called before an in-game variable is set.
bool __cdecl | onSetSwitch (int id, bool value)
Called before an in-game switch is set.
bool __cdecl | onEventCommand (RPG::EventScriptLine *scriptLine, RPG::EventScriptData *scriptData, int eventId, int pageId, int lineId, int *nextLineId)
Called before an event command is executed.
bool __cdecl | onComment (const char *text, const RPG::ParsedCommentData *parsedData, RPG::EventScriptLine *nextScriptLine, RPG::EventScriptData *scriptData, int eventId, int pageId, int lineId, int *nextLineId)
Called when a "Comment" event command is encountered.
void __cdecl | onDrawScreen ()
Called when the screen is drawn on the game window.
bool __cdecl | onDrawPicture (RPG::Picture *picture)
Called before a picture is drawn.
bool __cdecl | onPictureDrawn (RPG::Picture *picture)
Called after a picture was drawn (or was supposed to be drawn)
bool __cdecl | onCheckEventVisibility (RPG::Character *character)
Called every frame to check whether an event should be drawn even though it is out of sight.
bool __cdecl | onDrawEvent (RPG::Character *character, bool isHero)
Called before an event or the hero is drawn.
bool __cdecl | onEventDrawn (RPG::Character *character, bool isHero)
Called after an event or the hero was drawn (or was supposed to be drawn)
bool __cdecl | onDrawBattler (RPG::Battler *battler, bool isMonster, int id)
Called before a battler is drawn.
bool __cdecl | onBattlerDrawn (RPG::Battler *battler, bool isMonster, int id)
Called after a battler was drawn (or supposed to be drawn)
bool __cdecl | onDrawBattleStatusWindow (int x, int selection, bool selActive, bool isTargetSelection, bool isVisible)
Called before the battle status window is drawn.
bool __cdecl | onBattleStatusWindowDrawn (int x, int selection, bool selActive, bool isTargetSelection, bool isVisible)
Called after the battle status window was drawn (or supposed to be drawn)
bool __cdecl | onDrawBattleActionWindow (int *x, int *y, int selection, bool selActive, bool isVisible)
Called before the battle action window is drawn.
bool __cdecl | onDoBattlerAction (RPG::Battler *battler)
Called before a battler's action is executed.
bool __cdecl | onBattlerActionDone (RPG::Battler *battler, bool success)
Called after a battler's action is executed.
bool __cdecl | onSystemBackgroundDrawn (RECT *rect)
Called after the system background was drawn.

Function Documentation

bool __cdecl onBattlerActionDone | ( | RPG::Battler * | battler,
 |  | bool | success
 | ) |  |

Called after a battler's action is executed.

Parameters:
battler | The battler which is executing its action
success | true if the action was successfully executed or false if the action couldn't be executed yet because another action or something else was active
Returns:
false will prevent other plugins from receiving this notification, use true otherwise
Note:
If success if false, the RPG Maker will repeatedly try again to execute the action, until it succeeds, at which point success will be true.
Warning:
You must not modify the battler's action from this function, because it might not be fully completed. For example, "Attack" commands will immediately be finished although the attack animation and damage display haven't been done yet.
See also:
onDoBattlerAction
RPG::Action
bool __cdecl onBattlerDrawn | ( | RPG::Battler * | battler,
 |  | bool | isMonster,
 |  | int | id
 | ) |  |

Called after a battler was drawn (or supposed to be drawn)

You can use this function to draw something above a certain battler.

Parameters:
battler | The battler which was drawn (or supposed to be drawn)
isMonster | true if the battler is a monster
id | Zero-based party member ID of the battler
Returns:
false will prevent other plugins from receiving this notification, use true otherwise
Note:
This function will be called regardless if a plugin returned false from its onDrawBattler handler for this event.

This function is not called for hidden monsters. For dead monsters it is only called while they are still partly visible (i.e. while they are fading out).
See also:
onDrawBattler
bool __cdecl onBattleStatusWindowDrawn | ( | int | x,
 |  | int | selection,
 |  | bool | selActive,
 |  | bool | isTargetSelection,
 |  | bool | isVisible
 | ) |  |

Called after the battle status window was drawn (or supposed to be drawn)

You can use this function to draw something above the battle status window.

Parameters:
x | The current X coordinate of the left side of the window
selection | The zero-based party member ID of the currently selecter actor
selActive | true if the selection parameter contains a valid value and a choice bar is drawn
isTargetSelection | true if it is the target selection window, false if it is the "normal" status window
isVisible | true if the window is visible
Returns:
false will prevent other plugins from receiving this notification, use true otherwise
Note:
This function will be called regardless if a plugin returned false from its onDrawBattleStatusWindow handler for this window.

This function is also called when the window is invisible. In this case, isVisible will be false.

Please see the onDrawBattleStatusWindow documentation to find out more about the isTargetSelection parameter!
See also:
onDrawBattleStatusWindow
bool __cdecl onCheckEventVisibility ( RPG::Character * character )

Called every frame to check whether an event should be drawn even though it is out of sight.

Use this function in case you want to draw larger graphics instead of an event's normal graphic (using onDrawEvent). Normally, events which are out of sight are not drawn at all, thus neither onDrawEvent nor onEventDrawn would be called for this event. Return false from this function to force the drawing of the event.

Parameters:
character The event to be drawn (can also be the hero)
Returns:
false if the event should be drawn even though it is out of sight and also to prevent other plugins from receiving this notification, use true otherwise
Warning:
Do not initiate any actions from this function, only check whether you need to draw this event or not. If a previous plugin returned false, your plugin won't receive this notification, even though it might receive the onDrawEvent and onEventDrawn notifications!
See also:
onDrawEvent
onEventDrawn
bool __cdecl onComment | ( | const char * | text,
 |  | const RPG::ParsedCommentData * | parsedData,
 |  | RPG::EventScriptLine * | nextScriptLine,
 |  | RPG::EventScriptData * | scriptData,
 |  | int | eventId,
 |  | int | pageId,
 |  | int | lineId,
 |  | int * | nextLineId
 | ) |  |

Called when a "Comment" event command is encountered.

You can use this function to provide functions which are executed when a special event comment is encountered. Please stick to the Event comments guidelines! The parsedData parameter brings you the data already parsed according to the guidelines.

You will get all comment lines at once (separated by newline characters) in the text parameter. This way you don't need to do the parsing of the next event script lines (because internally, each comment line is a new event command).

You may use the comment function as "modifier" for event commands, thus there is the nextScriptLine parameter which allows you to modify the parameters of the next script line. For modifying event commands please also read the note at the onEventCommand documentation!

Parameters:
text | The comment's content as simple text
parsedData | The already parsed data
nextScriptLine | The next event script line after the comment
scriptData | Pointer to the RPG::EventScriptData object of the current event script
eventId | The ID of the current event (negative for common events, zero for battle events)
pageId | The ID of the current event page (zero for common and battle events - sorry, no battle event page ID yet)
lineId | The zero-based line number
nextLineId | Pointer to the next executed line number (-1 for default)
Returns:
false will prevent other plugins from receiving this notification, use true otherwise
Note:
For information how to use the nextLineId parameter, please refer to the onEventCommand documentation.
See also:
onEventCommand
bool __cdecl onDoBattlerAction ( RPG::Battler * battler )

Called before a battler's action is executed.

This function can be used to modify a battler's action before it is executed. For example, you might add a "random" skill which randomly executes certain skills and use this function to set the actual skill.

Parameters:
battler The battler which is executing its action
Returns:
false will prevent other plugins from receiving this notification, use true otherwise
Note:
Using this function, you can also use targets for a skill (or the "Attack" and "Double Attack" functions) which are normally not possible.

To prevent an action completely, change it to the basic action RPG::BA_NONE. Do not use RPG::AK_NONE because this can cause errors later in the battle.
See also:
onBattlerActionDone
RPG::Action
bool __cdecl onDrawBattleActionWindow | ( | int * | x,
 |  | int * | y,
 |  | int | selection,
 |  | bool | selActive,
 |  | bool | isVisible
 | ) |  |

Called before the battle action window is drawn.

You can use this function to draw below the battle action window, or to replace it entirely.

You can also use this function to move the window by modifying *x and *y.

Parameters:
x | Pointer to the X coordinate of the upper-left corner of the window
y | Pointer to the Y coordinate of the upper-right corner of the window
selection | Zero-based index of the current selection
selActive | true if the selection parameter contains a valid value and a choice bar is drawn
isVisible | true if the window is visible
Returns:
false will prevent the original window from being drawn and other plugins from receiving this notification, use true otherwise
Note:
The selection parameter does not contain the database ID of the selected battle command, but only a zero-based index based on all choices which are displayed. Use the RPG::Actor object to find out which battle commands are available for an actor. You probably need to store the selection parameter from your onDrawBattleStatusWindow to find out which actor is currently selected. You can then use something like RPG::Actor::partyMember(battleStatusWindowSelection)->getBattleCommand(battleActionWindowSelection) to get the database ID of the currently selected battle command.

This function is also called when the window is invisible. In this case, isVisible will be false.
See also:
onBattleStatusWindowDrawn
bool __cdecl onDrawBattler | ( | RPG::Battler * | battler,
 |  | bool | isMonster,
 |  | int | id
 | ) |  |

Called before a battler is drawn.

You can use this function to draw something below a certain battler, or instead of the battler.

Parameters:
battler | The battler which is about to be drawn
isMonster | true if the battler is a monster
id | Zero-based party member ID of the battler
Returns:
false will prevent the original battler from being drawn and other plugins from receiving this notification, use true otherwise
Note:
If you return false, the onBattlerDrawn handlers will still be called.

This function is not called for hidden monsters. For dead monsters it is only called while they are still partly visible (i.e. while they are fading out).
See also:
onBattlerDrawn
bool __cdecl onDrawBattleStatusWindow | ( | int | x,
 |  | int | selection,
 |  | bool | selActive,
 |  | bool | isTargetSelection,
 |  | bool | isVisible
 | ) |  |

Called before the battle status window is drawn.

You can use this function to draw below the battle status window, or to replace it entirely.

In the "Traditional" and "Alternative" battle layouts, there are two different status windows: One used as actual status window, one used as target selection window for actions with actors as targets. The latter is drawn above the skill/item selection window, while the former is drawn below it. Use the isTargetSelection parameter to find out which window you are dealing with.

You can also use this function (when isTargetSelection is false) to draw something above all battlers and below all windows.

Parameters:
x | The current X coordinate of the left side of the window
selection | The zero-based party member ID of the currently selected actor
selActive | true if the selection parameter contains a valid value and a choice bar is drawn
isTargetSelection | true if it is the target selection window, false if it is the "normal" status window
isVisible | true if the window is visible
Returns:
false will prevent the original window from being drawn and other plugins from receiving this notification, use true otherwise
Note:
If you return false, the onBattleStatusWindowDrawn handlers will still be called. However, the "finger" cursor which points to the selected hero will not be drawn if you return false when the isTargetSelection parameter is true.

This function is also called when the window is invisible. In this case, isVisible will be false.
See also:
onBattleStatusWindowDrawn
bool __cdecl onDrawEvent | ( | RPG::Character * | character,
 |  | bool | isHero
 | ) |  |

Called before an event or the hero is drawn.

You can use this function to draw something below a certain event, or instead of the event.

Parameters:
character | The character which is about to be drawn (can also be the hero)
isHero | true if the character is the hero
Returns:
false will prevent the original event from being drawn and other plugins from receiving this notification, use true otherwise
Note:
If you return false, the onEventDrawn handlers will still be called.

Vehicles are not supported yet.

This function is only called when the event is in sight or an onCheckEventVisibility handler has returned false for this event.
See also:
onEventDrawn
bool __cdecl onDrawPicture ( RPG::Picture * picture )

Called before a picture is drawn.

You can use this function to draw something below a certain picture, or instead of the picture.

Parameters:
picture The picture which is about to be drawn
Returns:
false will prevent the original picture from being drawn and other plugins from receiving this notification, use true otherwise
Note:
If you return false, the onPictureDrawn handlers will still be called.
See also:
onPictureDrawn
void __cdecl onDrawScreen ( )

Called when the screen is drawn on the game window.

Unlike onFrame, this function is called when the screen content is actually drawn on the game window. This means that if a section of the window is invalidated (for example because it was overlapped by another window or minimized), this function will be called again, even though the game screen itself didn't change.

Warning:
The screen might already contain changes done by you in the onDrawScreen handler before. Also, it is possible that only a part of the screen is invalidated and redrawn. Thus, you should only use this callback if you need to draw something during certain screen transitions (where onFrame doesn't work).
See also:
onFrame
bool __cdecl onEventCommand | ( | RPG::EventScriptLine * | scriptLine,
 |  | RPG::EventScriptData * | scriptData,
 |  | int | eventId,
 |  | int | pageId,
 |  | int | lineId,
 |  | int * | nextLineId
 | ) |  |

Called before an event command is executed.

You can use this function to intercept event commands, use them for a different purpose or change their parameters.

By changing the nextLineId, you can decide which line in the script is to be executed next. By default, the value of *nextLineId is -1, which means that the default behavior is executed. You can change it to another line number to jump to a different line. Use *nextLineId = lineId; to repeat the command, this way you can create a "wait until done" behavior by initiating some action the first time and then repeatedly checking whether it is finished.

You can use the scriptData parameter to read other event commands in the current script.

Parameters:
scriptLine | The event script line which is about to be executed
scriptData | Pointer to the RPG::EventScriptData object of the current event script
eventId | The ID of the current event (negative for common events, zero for battle events)
pageId | The ID of the current event page (zero for common and battle events - sorry, no battle event page ID yet)
lineId | The zero-based line number
nextLineId | Pointer to the next executed line number (-1 for default)
Returns:
false will prevent the event script line from being executed and other plugins from receiving this notification, use true otherwise
Note:
You may change the scriptLine object if you want, so that it is executed with different parameters. After the line was executed, all changes will be undone automatically.

The "don't execute if you return \c false" feature works by setting bit 31 in the command member of the scriptLine so that it becomes an invalid (and thus ignored) command. DynRPG automatically clears this bit later.
Warning:
Do not create loops which include several commands without a "Wait 0.0" (and also tell the user not to do so in case you provide an event command which jumps back in the script), otherwise the game will hang. If you loop to the same line using *nextLineId = lineId;, an automatic one-frame wait (equal to a "Wait 0.0") is inserted.

Do not use the nextLineId member if the current event command calls another event or ends the current event (e.g. when the command is RPG::EVCMD_STOP_EVENT).
See also:
onComment
bool __cdecl onEventDrawn | ( | RPG::Character * | character,
 |  | bool | isHero
 | ) |  |

Called after an event or the hero was drawn (or was supposed to be drawn)

You can use this function to draw something above a certain event.

Parameters:
character | The character which was drawn or supposed to be drawn (can also be the hero)
isHero | true if the character is the hero
Returns:
false will prevent other plugins from receiving this notification, use true otherwise
Note:
This function will be called regardless if a plugin returned false from its onDrawEvent handler for this event.

Vehicles are not supported yet.

This function is only called when the event is in sight or an onCheckEventVisibility handler has returned false for this event.
See also:
onDrawEvent
void __cdecl onExit ( )

Called before the game exits.

Note:
It's recommended to wrap your code in a try..catch block because if the game exits after an error (before onInitFinished was called), the state of the memory is undefined. Also, if you want to save data, check whether there is anything to save before you do it. The RPG objects may or may not be initialized, depending on whether this function is called before (early exit) or after onInitFinished.
Warning:
This handler may also be called while another callback handler is active, in case the other handler is pumping messages (for example, it is currently displaying a message box).
void __cdecl onFrame ( RPG::Scene scene )

Called every frame, before the screen is refreshed (see details!)

This function is called after every frame (see details below!), right after the current game scene was drawn, but before it becomes visible to the player. You may draw on the screen in this function and it will appear on top of the normal graphics.

You can even define your own scene and use this callback to draw it.

However: If the game is too slow, frames may be skipped. If this happens, the screen is not refreshed every frame, to save time. In this case, the onFrame handler is called only when the screen is refreshed. You can use RPG::System::frameCounter to find out how many frames were skipped (by comparing it with a value you saved at the last onFrame call), because when the scene is updated (even though the onFrame handler wasn't called), the RPG::System::frameCounter will still be incremented. This way, the game won't be "slower" than normal even when the framerate drops below 60.

Parameters:
scene Game scene which was drawn
Note:
The scene parameter does not necessarily equal to RPG::system->scene, e.g. when a transition from one scene to another is active.
See also:
RPG::System::scene
RPG::System::frameCounter
void __cdecl onInitFinished ( )

Called after the RPG objects were initialized.

Unlike in onStartup, it is safe to access RPG objects from this function.

See also:
onStartup
void __cdecl onInitTitleScreen ( )

Called before the title screen is initialized.

This function is called before the title screen fades in.

void __cdecl onLoadGame | ( | int | id,
 |  | char * | data,
 |  | int | length
 | ) |  |

Called before the player loads a game from a savestate.

DynRPG loads plugin data which was previously saved in the onSaveGame function and passes it to this handler. See In-game data for details.

Parameters:
id | Savestate ID
data | Pointer to plugin data
length | Length of plugin data
Note:
data may be 0 if there is no data.
See also:
onLoadGame
void __cdecl onNewGame ( )

Called before the player starts a new game.

bool __cdecl onPictureDrawn ( RPG::Picture * picture )

Called after a picture was drawn (or was supposed to be drawn)

You can use this function to draw something above a certain picture.

Parameters:
picture The picture which is was drawn (or was supposed to be drawn)
Returns:
false will other plugins from receiving this notification, use true otherwise
Note:
This function will be called regardless if a plugin returned false from its onDrawPicture handler for this picture.
See also:
onDrawPicture
void __cdecl onSaveGame | ( | int | id,
 |  | void __cdecl(*)(char *data, int length) | savePluginData
 | ) |  |

Called before the player saves a game.

Use the function passed in the savePluginData parameter to save custom plugin data which will be passed back to the plugin when the player loads the same savestate. See In-game data for details.

Parameters:
id | Savestate ID
savePluginData | Call this function to save custom plugin data
Note:
If you call savePluginData more than once, only the last call will take effect.
See also:
onLoadGame
bool __cdecl onSetSwitch | ( | int | id,
 |  | bool | value
 | ) |  |

Called before an in-game switch is set.

This function can be used to give "Change Switch" commands a special meaning.

Parameters:
id | ID of the switch to be changed
value | Value to be assigned
Returns:
false will prevent the switch from being changed and other plugins from receiving this notification, use true otherwise
Note:
This callback is not only triggered by the "Change Switch" command, but by any action which writes to a switch.
See also:
onSetVariable
bool __cdecl onSetVariable | ( | int | id,
 |  | int | value
 | ) |  |

Called before an in-game variable is set.

This function can be used to give "Change Variable" commands a special meaning. This might be suitable for applications for which a full onComment implementation would be overkill, like a key check.

Parameters:
id | ID of the variable to be changed
value | Value to be assigned
Returns:
false will prevent the variable from being changed and other plugins from receiving this notification, use true otherwise
Note:
This callback is not only triggered by the "Change Variable" command, but by any action which writes to a variable.
See also:
onSetSwitch
bool __cdecl onStartup ( char * pluginName )

Called when the plugin was loaded.

This callback handler should be used to check for fatal problems, like missing files. You can abort the loading process from this function.

Parameters:
pluginName The name of the plugin. This is the filename with the extension stripped. For its supposed usage, see Configuration.
Returns:
true on success, false on failure. In the latter case, other plugins which were already loaded will receive the onExit call and be unloaded and the game will not be started.
Warning:
Do not try to access RPG objects from this function, since the game hasn't been initialized yet.
See also:
onInitFinished
onExit
bool __cdecl onSystemBackgroundDrawn ( RECT * rect )

Called after the system background was drawn.

This function can be used to draw your custom background in the menu, etc.

Parameters:
rect Area which has been (re)drawn
Note:
In the save/load menu, there is only the smart part at the top drawn, in the other menus, the whole screen is painted. Pay attention to the rect parameter.
Generated on Mon Feb 6 2012 22:24:55 for DynRPG by doxygen 1.7.6.1


DynRPG: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all documented namespaces with brief descriptions:
RPG The one and only namespace in which all DynRPG classes, variables and functions reside, except for callbacks


DynRPG: RPG Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Typedefs | Enumerations | Functions | Variables
RPG Namespace Reference

The one and only namespace in which all DynRPG classes, variables and functions reside, except for callbacks. More...

Classes

class | Action
Action of a battler (normal attack, skill, escape, etc.), including target More...
class | Actor
Used for the data of actors which can be changed in-game. More...
class | ArrayBaseOne
Helper class for arrays with base one. More...
class | Battler
Used for entities participating in battle, i.e. actors and monsters. More...
class | BattleSettings
Used for battle settings (layout, etc.) More...
class | Canvas
Image buffer with 16 bit color depth, used as canvas for multiple 8-bit images More...
class | Catalog
Wrapper class for RPG::DList which doesn't crash if the index is out of bounds. More...
class | CatalogPtr
Wrapper class for RPG::Catalog pointers (syntactic sugar) More...
class | NamedCatalog
Class inherited from RPG::Catalog in which elements with non-consecutive IDs are stored without waste of memory (i.e. events on a map) More...
class | NamedCatalogPtr
Wrapper class for RPG::NamedCatalog pointers (syntactic sugar) More...
class | Character
Used for movable entities on the map, i.e. events, the hero (and vehicles, but they are not supported yet) More...
class | EventData
Class used for storing special event data of a character. More...
class | Event
Used for events as subtype of characters. More...
class | Hero
Used for the hero as subtype of characters. More...
class | DArray
Array class. More...
class | DBActor
Used for the default data of actors which is defined in the database. More...
class | DBitmap
Wrapper class for windows' HBITMAPs. More...
class | DBSystem
Used for the default system data which is defined in the database. More...
class | DList
Class representing Delphi's TList (read-only for the moment) More...
class | DListPtr
Wrapper class for RPG::DList pointers (syntactic sugar) More...
class | DString
Helper class representing a Delphi string. More...
class | DStringPtr
Mighty wrapper class for RPG::DString pointers, the string class for RPG Maker strings. More...
class | EventScriptList
List of event script lines. More...
class | EventScriptData
Class used for the event script data of an event. More...
class | EventScriptLine
Represents an event script line. More...
class | ColorControl
Color effect settings for RPG::Image objects. More...
class | Image
Used for image buffers (8 bit) More...
class | Input
Used for key input. More...
class | Map
Used for accessing and manipulating the current map environment. More...
class | Monster
Used for monsters as subtype of battlers. More...
class | MoveRoute
Used for the move route of an character (also set by the "Move Event" command) More...
class | Music
Used for background music settings. More...
class | ParsedCommentParameter
Used for parameters of parsed event comments (see Event comments guidelines) More...
class | ParsedCommentData
Used for parsed event comments (see Event comments guidelines) More...
class | Picture
Used for in-game pictures. More...
class | Screen
Used for the screen, including window properties and FPS. More...
class | Sound
Used for sound effect settings. More...
class | Switches
Provides easy access to in-game switches. More...
class | SystemGraphic
Used to store the system and "system2" graphics. More...
class | System
Used for system data which can change in-game. More...
class | Variables
Provides easy access to in-game variables. More...

Typedefs

typedef unsigned char | ActionKind_T
One-byte version of RPG::ActionKind.
typedef unsigned char | BasicAction_T
One-byte version of RPG::BasicAction.
typedef unsigned char | Target_T
One-byte version of RPG::Target.
typedef unsigned char | BattleLayout_T
One-byte version of RPG::BattleLayout.
typedef unsigned char | Facing_T
One-byte version of RPG::Facing_T.
typedef unsigned char | Direction_T
One-byte version of RPG::Direction.
typedef unsigned char | AnimationType_T
One-byte version of RPG::AnimationType.
typedef unsigned char | Layer_T
One-byte version of RPG::Layer.
typedef void | ActorLearning
Not implemented yet.
typedef unsigned char | Transition_T
One-byte version of RPG::Transition.
typedef void | Chipset
Not implemented yet.
typedef void | MoveRouteItem
Not implemented yet.
typedef void | AuroraDrawMain
Not implemented yet.
typedef unsigned char | Scene_T
One-byte version of RPG::Scene.
typedef unsigned char | ATBMode_T
One-byte version or RPG::ATBMode.

Enumerations

enum ActionKind {
AK_BASIC, AK_SKILL, AK_TRANSFORM, AK_ITEM,
AK_NONE
}
Possible values for the RPG::Action::kind member. More...
enum BasicAction {
BA_ATTACK, BA_DOUBLE_ATTACK, BA_DEFEND, BA_OBSERVE,
BA_CHARGE, BA_SELF_DESTRUCT, BA_ESCAPE, BA_NONE,
BA_CHANGE_ROW
}
Possible values for the RPG::Action::basicActionId member. More...
enum Target {
TARGET_NONE, TARGET_ACTOR, TARGET_ALL_ACTORS, TARGET_MONSTER,
TARGET_ALL_MONSTERS
}
Possible values for the RPG::Action::target member. More...
enum | Row { ROW_FRONT, ROW_BACK }
Possible values used for the battle row in RPG::Battler. More...
enum | ActionStatus { AS_IDLE, AS_WAITING, AS_FINAL_PHASE }
Possible values for RPG::Battler::actionStatus. More...
enum | BattleLayout { BL_TRADITIONAL, BL_ALTERNATIVE, BL_GAUGE }
Possible values for RPG::BattleSettings::layout. More...
enum | Facing { FACE_UP, FACE_RIGHT, FACE_DOWN, FACE_LEFT }
Possible values for RPG::Character::facing. More...
enum Direction {
DIR_UP, DIR_RIGHT, DIR_DOWN, DIR_LEFT,
DIR_UP_RIGHT, DIR_DOWN_RIGHT, DIR_DOWN_LEFT, DIR_UP_LEFT
}
Possible values for RPG::Character::direction. More...
enum AnimationType {
ANI_NORMAL, ANI_STEPPING, ANI_FIXED_DIR_NORMAL, ANI_FIXED_DIR_STEPPING,
ANI_FIXED_GRAPHIC, ANI_SPIN_AROUND
}
Possible values for RPG::Character::animationType. More...
enum | Layer { LAYER_BELOW_HERO, LAYER_SAME_LEVEL_AS_HERO, LAYER_ABOVE_HERO }
Possible values for RPG::Character::layer. More...
enum | HeroVehicle { HV_NONE, HV_SKIFF, HV_SHIP, HV_AIRSHIP }
Possible values for RPG::Hero::vehicle. More...
enum | HeroControlMode { CONTROL_EVERYTHING, CONTROL_EVERYTHING_EXCEPT_MOVEMENT, CONTROL_NOTHING }
Hero control mode (see RPG::Hero::setControlMode) More...
enum Transition {
TRANS_FADE, TRANS_DISSOLVE, TRANS_DISSOLVE_UP, TRANS_DISSOLVE_DOWN,
TRANS_BLINDS, TRANS_VERTICAL_STRIPES, TRANS_HORIZONTAL_STRIPES, TRANS_RECIDING_SQUARE,
TRANS_EXPANDING_SQUARE, TRANS_SHIFT_UP, TRANS_SHIFT_DOWN, TRANS_SHIFT_LEFT,
TRANS_SHIFT_RIGHT, TRANS_VERTICAL_SPLIT, TRANS_HORIZONTAL_SPLIT, TRANS_4_WAY_SPLIT,
TRANS_ZOOM, TRANS_MOSAIC, TRANS_WAVER_SCREEN, TRANS_INSTANT,
TRANS_NONE, TRANS_DEFAULT = 255
}
Screen transitions. More...
enum | SystemFont { SYSF_MSGOTHIC, SYSF_MSMINCHO }
Possible values for RPG::DBSystem::systemFont. More...
enum | BattleEventUpdateMode { BEUM_BEFORE_ACTION, BEUM_AFTER_ACTION, BEUM_SWITCH_ACTIVATED, BEUM_BATTLE_START }
Possible values of the mode parameter of RPG::updateBattleEvents. More...
enum EventCommand {
EVCMD_END_OF_EVENT = 0, EVCMD_EMPTY_LINE = 10, EVCMD_SHOW_MESSAGE = 10110, EVCMD_ADD_LINE_TO_MESSAGE = 20110,
EVCMD_MESSAGE_OPTIONS = 10120, EVCMD_SELECT_FACE = 10130, EVCMD_SHOW_CHOICE = 10140, EVCMD_CHOICE_CASE = 20140,
EVCMD_CHOICE_END = 20141, EVCMD_INPUT_NUMBER = 10150, EVCMD_CHANGE_SWITCH = 10210, EVCMD_CHANGE_VARIABLE = 10220,
EVCMD_CHANGE_TIMER = 10230, EVCMD_CHANGE_MONEY = 10310, EVCMD_CHANGE_ITEMS = 10320, EVCMD_CHANGE_PARTY = 10330,
EVCMD_CHANGE_EXP = 10410, EVCMD_CHANGE_LEVEL = 10420, EVCMD_CHANGE_STATS = 10430, EVCMD_CHANGE_SKILL = 10440,
EVCMD_CHANGE_EQUIPMENT = 10450, EVCMD_CHANGE_HP = 10460, EVCMD_CHANGE_MP = 10470, EVCMD_CHANGE_CONDITION = 10480,
EVCMD_FULL_RECOVERY = 10490, EVCMD_INFLICT_DAMAGE = 10500, EVCMD_CHANGE_HERO_NAME = 10610, EVCMD_CHANGE_HERO_TITLE = 10620,
EVCMD_CHANGE_HERO_GRAPHIC = 10630, EVCMD_CHANGE_HERO_FACE = 10640, EVCMD_CHANGE_VEHICLE_GRAPHIC = 10650, EVCMD_CHANGE_SYSTEM_BGM = 10660,
EVCMD_CHANGE_SYSTEM_SE = 10670, EVCMD_CHANGE_SYSTEM_GRAPHIC = 10680, EVCMD_CHANGE_TRANSITION = 10690, EVCMD_START_COMBAT = 10710,
EVCMD_BATTLE_VICTORY = 20710, EVCMD_BATTLE_ESCAPE = 20711, EVCMD_BATTLE_DEFEAT = 20712, EVCMD_BATTLE_END = 20713,
EVCMD_CALL_SHOP = 10720, EVCMD_SHOP_TRANSACTION = 20720, EVCMD_SHOP_CANCEL = 20721, EVCMD_SHOP_END = 20722,
EVCMD_CALL_INN = 10730, EVCMD_INN_REST = 20730, EVCMD_INN_CANCEL = 20731, EVCMD_INN_END = 20732,
EVCMD_ENTER_HERO_NAME = 10740, EVCMD_TELEPORT = 10810, EVCMD_MEMORIZE_LOCATION = 10820, EVCMD_GO_TO_MEMORIZED_LOCATION = 10830,
EVCMD_RIDE_VEHICLE = 10840, EVCMD_TELEPORT_VEHICLE = 10850, EVCMD_SET_EVENT_LOCATION = 10860, EVCMD_SWAP_TWO_EVENT_LOCATIONS = 10870,
EVCMD_GET_TERRAIN_ID = 10910, EVCMD_GET_EVENT_ID = 10920, EVCMD_ERASE_SCREEN = 11010, EVCMD_SHOW_SCREEN = 11020,
EVCMD_SET_SCREEN_TONE = 11030, EVCMD_FLASH_SCREEN = 11040, EVCMD_SHAKE_SCREEN = 11050, EVCMD_PAN_SCREEN = 11060,
EVCMD_WEATHER_EFFECTS = 11070, EVCMD_SHOW_PICTURE = 11110, EVCMD_MOVE_PICTURE = 11120, EVCMD_ERASE_PICTURE = 11130,
EVCMD_SHOW_BATTLE_ANIMATION = 11210, EVCMD_SET_HERO_OPACITY = 11310, EVCMD_FLASH_EVENT = 11320, EVCMD_MOVE_EVENT = 11330,
EVCMD_WAIT_UNTIL_MOVED = 11340, EVCMD_STOP_ALL_MOVEMENT = 11350, EVCMD_WAIT = 11410, EVCMD_PLAY_BGM = 11510,
EVCMD_FADE_OUT_BGM = 11520, EVCMD_MEMORIZE_BGM = 11530, EVCMD_PLAY_MEMORIZED_BGM = 11540, EVCMD_PLAY_SOUND_EFFECT = 11550,
EVCMD_PLAY_MOVIE = 11560, EVCMD_KEY_INPUT_PROCESSING = 11610, EVCMD_CHANGE_TILESET = 11710, EVCMD_CHANGE_PANORAMA = 11720,
EVCMD_CHANGE_ENCOUNTER_RATE = 11740, EVCMD_CHANGE_SINGLE_TILE = 11750, EVCMD_CHANGE_TELEPORT_TARGET = 11810, EVCMD_ENABLE_TELEPORT = 11820,
EVCMD_SET_ESCAPE_LOCATION = 11830, EVCMD_ENABLE_ESCAPE = 11840, EVCMD_CALL_SAVE_MENU = 11910, EVCMD_ENABLE_SAVE = 11930,
EVCMD_CALL_MAIN_MENU = 11950, EVCMD_ENABLE_MAIN_MENU = 11960, EVCMD_FORK = 12010, EVCMD_FORK_ELSE_CASE = 22010,
EVCMD_FORK_END = 22011, EVCMD_LABEL = 12110, EVCMD_JUMP_TO_LABEL = 12120, EVCMD_START_LOOP = 12210,
EVCMD_END_LOOP = 22210, EVCMD_BREAK_LOOP = 12220, EVCMD_STOP_EVENT = 12310, EVCMD_DELETE_EVENT = 12320,
EVCMD_CALL_EVENT = 12330, EVCMD_COMMENT = 12410, EVCMD_ADD_LINE_TO_COMMENT = 22410, EVCMD_GAME_OVER = 12420,
EVCMD_GO_TO_TITLE_SCREEN = 12510, EVCMD_CHANGE_CLASS = 1008, EVCMD_CHANGE_BATTLE_COMMANDS = 1009, EVCMD_CHANGE_ENEMY_HP = 13110,
EVCMD_CHANGE_ENEMY_MP = 13120, EVCMD_CHANGE_ENEMY_CONDITION = 13130, EVCMD_REVIVE_ENEMY = 13150, EVCMD_CHANGE_BACKDROP = 13210,
EVCMD_SHOW_BATTLE_ANIMATION_IN_BATTLE = 13260, EVCMD_ENABLE_COMBO = 1007, EVCMD_FORCE_FLEE = 1006, EVCMD_END_BATTLE = 13410,
EVCMD_FORK_IN_BATTLE = 13310, EVCMD_FORK_IN_BATTLE_ELSE_CASE = 23310, EVCMD_FORK_IN_BATTLE_END = 23311, EVCMD_CALL_COMMON_EVENT = 1005
}
Event command type More...
enum | { MASK_NONE = -1 }
enum Key {
KEY_DOWN, KEY_LEFT, KEY_RIGHT, KEY_UP,
KEY_DECISION, KEY_CANCEL, KEY_0, KEY_1,
KEY_2, KEY_3, KEY_4, KEY_5,
KEY_6, KEY_7, KEY_8, KEY_9,
KEY_ADD, KEY_SUBTRACT, KEY_MULTIPLY, KEY_DIVIDE,
KEY_DECIMAL
}
RPG Maker key names More...
enum MoveType {
MT_MOVE_UP, MT_MOVE_RIGHT, MT_MOVE_DOWN, MT_MOVE_LEFT,
MT_MOVE_UP_RIGHT, MT_MOVE_DOWN_RIGHT, MT_MOVE_DOWN_LEFT, MT_MOVE_UP_LEFT,
MT_MOVE_RANDOMLY, MT_MOVE_TOWARD_HERO, MT_MOVE_AWAY_FROM_HERO, MT_MOVE_FORWARD,
MT_FACE_UP, MT_FACE_RIGHT, MT_FACE_DOWN, MT_FACE_LEFT,
MT_TURN_RIGHT, MT_TURN_LEFT, MT_TURN_AROUND, MT_TURN_RANDOMLY,
MT_FACE_RANDOMLY, MT_FACE_TOWARD_HERO, MT_FACE_AWAY_FROM_HERO, MT_WAIT,
MT_BEGIN_JUMP, MT_END_JUMP, MT_LOCK_FACING, MT_UNLOCK_FACING,
MT_INCREASE_SPEED, MT_DECREASE_SPEED, MT_INCREASE_FREQUENCY, MT_DECREASE_FREQUENCY,
MT_SWITCH_ON, MT_SWITCH_OFF, MT_CHANGE_GRAPHIC, MT_PLAY_SE,
MT_PHASING_MODE_ON, MT_PHASING_MODE_OFF, MT_STOP_ANIMATION, MT_RESUME_ANIMATION,
MT_INCREASE_TRANSPARENCY, MT_DECREASE_TRANSPARENCY
}
"Move event" command type More...
enum | ParsedCommentParameterType { PARAM_NUMBER, PARAM_STRING, PARAM_TOKEN }
Type of a parsed comment parameter. More...
enum | PictureEffect { PFX_NONE, PFX_ROTATE, PFX_RIPPLE }
Special effects for pictures. More...
enum Scene {
SCENE_MAP, SCENE_MENU, SCENE_BATTLE, SCENE_SHOP,
SCENE_NAME, SCENE_FILE, SCENE_TITLE, SCENE_GAME_OVER,
SCENE_DEBUG
}
In-game scenes. More...
enum | MessagePosition { MSGPOS_TOP, MSGPOS_MIDDLE, MSGPOS_BOTTOM }
Possible values for RPG::System::messagePosition. More...
enum | FacePosition { FACEPOS_LEFT, FACEPOS_RIGHT }
Possible values for RPG::System::facePosition. More...
enum | ATBMode { ATBM_ACTIVE, ATBM_WAIT }
Possible values for RPG::System::atbMode. More...

Functions

void | updateBattle ()
Updates the battle, including actions, ATB, animations, etc.
void | updateBattleEvents (RPG::BattleEventUpdateMode mode, RPG::Battler *battler)
Processes battle events.
int | getSelectedMonsterIndex ()
Returns the index of the currently selected monster.
std::string | getItemName (int id)
Returns the name of an item.
std::string | getItemDescription (int id)
Returns the description of an item.
std::string | getSkillName (int id)
Returns the name of a skill.
std::string | getSkillDescription (int id)
Returns the description of a skill.
std::string | getConditionName (int id)
Returns the name of a condition.
std::map< std::string,
std::string > 		loadConfiguration (char *sectionName, char *filename=0)
Returns a std::map containing configuration from an INI file.
std::string | encode (int value)
Encodes a numerical value for use with RPG::Character::move.
std::string | encode (std::string value)
Encodes a string for use with RPG::Character::move.

Variables

static RPG::NamedCatalogPtr
< RPG::Actor * > & 		actors = (**reinterpret_cast<RPG::NamedCatalogPtr<RPG::Actor *> **>(0x4CDDC8))
Array of actors from the database, used for properties which can change in-game.
static RPG::BattleSettings *& | battleSettings = (**reinterpret_cast<RPG::BattleSettings ***>(0x4CDD60))
Battle settings.
static RPG::Hero *& | hero = (**reinterpret_cast<RPG::Hero ***>(0x4CDE54))
The hero (which moves around on the map, similar to an event)
static RPG::NamedCatalogPtr
< RPG::DBActor * > & 		dbActors = (**reinterpret_cast<RPG::NamedCatalogPtr<RPG::DBActor *> **>(0x4CDD54))
Array of actors from the database, used for default values and properties which are not supposed to be changed in-game.
static RPG::DBSystem *& | dbSystem = (**reinterpret_cast<RPG::DBSystem ***>(0x4CDC0C))
Object of "system" data, used for default values and properties which are not supposed to be changed in-game.
static bool & | isTestPlay = (**reinterpret_cast<bool **>(0x4CDD50))
static int & | battleSpeed = (*reinterpret_cast<int *>(0x442600))
Speed of the ATB system in percent.
static bool & | transparentWindowsEverywhere = (*reinterpret_cast<bool *>(0x462604))
Allows transparent windows in outside of the map too.
static RPG::Input *& | input = (**reinterpret_cast<RPG::Input ***>(0x4CDAEC))
Object used for key assignments and key input checking.
static RPG::Map *& | map = (**reinterpret_cast<RPG::Map ***>(0x4CDD74))
The current map environment (camera, events, etc.)
static RPG::CatalogPtr
< RPG::Monster * > & 		monsters = (**reinterpret_cast<RPG::CatalogPtr<RPG::Monster *> **>(0x4CDE64))
Array of monsters in the current monster group.
static RPG::NamedCatalogPtr
< RPG::Picture * > & 		pictures = (**reinterpret_cast<RPG::NamedCatalogPtr<RPG::Picture *> **>(0x4CDF3C))
Array of pictures.
static RPG::Screen *& | screen = (**reinterpret_cast<RPG::Screen ***>(0x4CDB24))
The screen, including window properties, FPS and the drawing canvas.
static RPG::Switches | switches
Switches array
static RPG::System *& | system = (**reinterpret_cast<RPG::System ***>(0x4CDC7C))
Object of "system" data, used for values which can be changed in-game.
static RPG::Variables | variables
Variables array

Detailed Description

The one and only namespace in which all DynRPG classes, variables and functions reside, except for callbacks.

Typedef Documentation

typedef unsigned char RPG::ActionKind_T

One-byte version of RPG::ActionKind.

typedef void RPG::ActorLearning

Not implemented yet.

typedef unsigned char RPG::AnimationType_T

One-byte version of RPG::AnimationType.

typedef unsigned char RPG::ATBMode_T

One-byte version or RPG::ATBMode.

typedef void RPG::AuroraDrawMain

Not implemented yet.

typedef unsigned char RPG::BasicAction_T

One-byte version of RPG::BasicAction.

typedef unsigned char RPG::BattleLayout_T

One-byte version of RPG::BattleLayout.

typedef void RPG::Chipset

Not implemented yet.

typedef unsigned char RPG::Direction_T

One-byte version of RPG::Direction.

typedef unsigned char RPG::Facing_T

One-byte version of RPG::Facing_T.

typedef unsigned char RPG::Layer_T

One-byte version of RPG::Layer.

typedef void RPG::MoveRouteItem

Not implemented yet.

typedef unsigned char RPG::Scene_T

One-byte version of RPG::Scene.

typedef unsigned char RPG::Target_T

One-byte version of RPG::Target.

typedef unsigned char RPG::Transition_T

One-byte version of RPG::Transition.

Enumeration Type Documentation

anonymous enum
Enumerator:
MASK_NONE

Used for RPG::Image::draw if no transparent color should be used.

enum RPG::ActionKind

Possible values for the RPG::Action::kind member.

Enumerator:
AK_BASIC

Basic action (attack, defense, escape, etc. - see RPG::BasicAction)

AK_SKILL

Use a skill.

AK_TRANSFORM

Transform into another monster (do not use for actors)

AK_ITEM

Use an item (do not use for monsters)

AK_NONE

No action (last action was already executed)

enum RPG::ActionStatus

Possible values for RPG::Battler::actionStatus.

Enumerator:
AS_IDLE

No action is active.

AS_WAITING

Info window is displayed or action is otherwise waiting.

AS_FINAL_PHASE

Final phase, damage is displayed, etc.

enum RPG::AnimationType

Possible values for RPG::Character::animationType.

Enumerator:
ANI_NORMAL

"Non-continuous"

ANI_STEPPING

"Continuous" (always stepping)

ANI_FIXED_DIR_NORMAL

"Non-continous", fixed direction

ANI_FIXED_DIR_STEPPING

"Continuous", fixed direction

ANI_FIXED_GRAPHIC

Fixed graphic (no stepping, fixed direction)

ANI_SPIN_AROUND

Spinning around.

enum RPG::ATBMode

Possible values for RPG::System::atbMode.

Enumerator:
ATBM_ACTIVE

"Active" mode (enemies also attack in selection menus)

ATBM_WAIT

"Wait" mode

enum RPG::BasicAction

Possible values for the RPG::Action::basicActionId member.

Enumerator:
BA_ATTACK

Attack.

BA_DOUBLE_ATTACK

Double attack.

BA_DEFEND

Defend.

BA_OBSERVE

Observe battle.

BA_CHARGE

Charge up.

BA_SELF_DESTRUCT

Self-destruct.

BA_ESCAPE

Escape (will always succeed)

BA_NONE

No action.

BA_CHANGE_ROW

Change row (has no visible effects if used by monsters)

enum RPG::BattleEventUpdateMode

Possible values of the mode parameter of RPG::updateBattleEvents.

Warning:
I am not completely sure about the effects these modes have.
Enumerator:
BEUM_BEFORE_ACTION

Used before a battler executes its action.

BEUM_AFTER_ACTION

Used after a battler executes its action.

BEUM_SWITCH_ACTIVATED

Used when a skill or an item activates a switch.

BEUM_BATTLE_START

Used to call events with start condition "Turns elapsed [0x+0]".

enum RPG::BattleLayout

Possible values for RPG::BattleSettings::layout.

Enumerator:
BL_TRADITIONAL

"Traditional" layout

BL_ALTERNATIVE

"Alternative" layout

BL_GAUGE

"Gauge" layout

enum RPG::Direction

Possible values for RPG::Character::direction.

Enumerator:
DIR_UP

Character moves down

DIR_RIGHT

Character moves to the right

DIR_DOWN

Character moves down

DIR_LEFT

Character moves to the left

DIR_UP_RIGHT

Character moves diagonally up-right

DIR_DOWN_RIGHT

Character moves diagonally down-right

DIR_DOWN_LEFT

Character moves diagonally down-left

DIR_UP_LEFT

Character moves diagonally up-left

enum RPG::EventCommand

Event command type

Each event command can have a number of parameters. Unfortunately, documenting all of them (nearly 150) is beyond my time resources at the moment. If you need to know how the parameters of a certain command work, you can write a simple plugin which logs event commands and their parameters and try it out yourself.

See also:
RPG::EventScriptLine
onEventCommand
Note:
Not all enumeration values are documented here, scroll to the top to see all possible values (in the general enum overview)!
Enumerator:
EVCMD_END_OF_EVENT

End of the event command list.

EVCMD_EMPTY_LINE

Empty line (<>)

EVCMD_SHOW_MESSAGE

First line of a "Show Message" command.

EVCMD_ADD_LINE_TO_MESSAGE

Additional lines of a "Show Message" command.

EVCMD_SHOW_CHOICE

First line of a "Show Choice" command.

EVCMD_CHOICE_CASE

[XXXX] handler lines of a "Show Choice" command

EVCMD_CHOICE_END

: End line of a "Show Choice" command

EVCMD_START_COMBAT

First line of a "Start Combat" command.

EVCMD_BATTLE_VICTORY

Victory handler line of a "Start Combat" command

EVCMD_BATTLE_ESCAPE

Escape handler line of a "Start Combat" command

EVCMD_BATTLE_DEFEAT

Defeat handler line of a "Start Combat" command

EVCMD_BATTLE_END

: End line of a "Start Combat" command

EVCMD_CALL_SHOP

First line of a "Call Shop" command.

EVCMD_SHOP_TRANSACTION

Transaction handler line of a "Call Shop" command

EVCMD_SHOP_CANCEL

Cancel handler line of a "Call Shop" command

EVCMD_SHOP_END

: End line of "Call Shop" command

EVCMD_CALL_INN

First line of a "Call Inn" command.

EVCMD_INN_REST

Rest handler line of a "Call Inn" command

EVCMD_INN_CANCEL

Cancel handler line of a "Call Inn" command

EVCMD_INN_END

: End line of a "Call Inn" command

EVCMD_SHOW_BATTLE_ANIMATION

"Show Battle Animation" in map/common events

EVCMD_FORK

First line of a "Conditional Branch" in map/common events.

EVCMD_FORK_ELSE_CASE

: Else Case line of a "Conditional Branch" in map/common events

EVCMD_FORK_END

: End Case line of a "Conditional Branch" in map/common events

EVCMD_START_LOOP

"Loop" command

EVCMD_END_LOOP

: End line of a "Loop"

EVCMD_CALL_EVENT

"Call Event" in map/common events

EVCMD_COMMENT

First line of a comment.

EVCMD_ADD_LINE_TO_COMMENT

Additional lines of a comment.

EVCMD_SHOW_BATTLE_ANIMATION_IN_BATTLE

"Show Battle Animation" in battle events

EVCMD_FORK_IN_BATTLE

First line of a "Conditional Branch" in battle events.

EVCMD_FORK_IN_BATTLE_ELSE_CASE

: Else Case line of a "Conditional Branch" in battle events

EVCMD_FORK_IN_BATTLE_END

: End Case line of a "Conditional Branch" in battle events

EVCMD_CALL_COMMON_EVENT

"Call Common Event" in battle events

enum RPG::FacePosition

Possible values for RPG::System::facePosition.

Enumerator:
FACEPOS_LEFT

Left.

FACEPOS_RIGHT

Right.

enum RPG::Facing

Possible values for RPG::Character::facing.

Enumerator:
FACE_UP

Character looks up

FACE_RIGHT

Character looks to the right

FACE_DOWN

Character looks down

FACE_LEFT

Character looks to the left

enum RPG::HeroControlMode

Hero control mode (see RPG::Hero::setControlMode)

Enumerator:
CONTROL_EVERYTHING

Everything works normally.

CONTROL_EVERYTHING_EXCEPT_MOVEMENT

Opening menu and activating events works, but movement is disabled.

CONTROL_NOTHING

No control possible (checking key state still works, of course)

enum RPG::HeroVehicle

Possible values for RPG::Hero::vehicle.

Enumerator:
HV_NONE

Hero is in no vehicle.

HV_SKIFF

Hero is in the skiff.

HV_SHIP

Hero is in the ship.

HV_AIRSHIP

Hero is in the airship.

enum RPG::Key

RPG Maker key names

Note:
The Shift key is handled differently by the RPG Maker, thus it can't be used the way other keys can be used by DynRPG.
See also:
RPG::Input
RPG::Input::pressed
Note:
Not all enumeration values are documented here, scroll to the top to see all possible values (in the general enum overview)!
Enumerator:
KEY_DOWN

Keys which are used for moving down.

KEY_LEFT

Keys which are used for moving left.

KEY_RIGHT

Keys which are used for moving right.

KEY_UP

Keys which are used for moving up.

KEY_DECISION

Keys which are used to confirm an action.

KEY_CANCEL

Keys which are used to cancel an action or open the menu.

enum RPG::Layer

Possible values for RPG::Character::layer.

Enumerator:
LAYER_BELOW_HERO

Below hero.

LAYER_SAME_LEVEL_AS_HERO

Same level as hero.

LAYER_ABOVE_HERO

Above hero.

enum RPG::MessagePosition

Possible values for RPG::System::messagePosition.

Enumerator:
MSGPOS_TOP

Top.

MSGPOS_MIDDLE

Middle.

MSGPOS_BOTTOM

Bottom.

enum RPG::MoveType

"Move event" command type

A few of these commands take parameters, see details. For information how to use these commands, see the RPG::Character::move documentation.

See also:
RPG::Character::move
Note:
Not all enumeration values are documented here, scroll to the top to see all possible values (in the general enum overview)!
Enumerator:
MT_SWITCH_ON

Turns a switch ON.

This command takes one integer parameter: The switch ID.

See also:
RPG::MT_SWITCH_OFF
RPG::Switches
MT_SWITCH_OFF

Turns a switch OFF.

This command takes one integer parameter: The switch ID.

See also:
RPG::MT_SWITCH_ON
RPG::Switches
MT_CHANGE_GRAPHIC

Changes the charset graphic of the character.

This command takes two parameters:

  • The charset filename (string)
  • The charset sprite ID (integer)
MT_PLAY_SE

Plays a sound effect.

This command takes four parameters:

  • The sound filename (string)
  • The sound volume (integer)
  • The sound speed (integer)
  • The sound pan value (integer)
See also:
RPG::Sound
enum RPG::ParsedCommentParameterType

Type of a parsed comment parameter.

See also:
RPG::ParsedCommentParameter
RPG::ParsedCommentData
Enumerator:
PARAM_NUMBER

The parameter is a number.

PARAM_STRING

The parameter is a string.

PARAM_TOKEN

The parameter is a token.

enum RPG::PictureEffect

Special effects for pictures.

Enumerator:
PFX_NONE

No effect.

PFX_ROTATE

Rotation.

PFX_RIPPLE

Ripple effect ("Waver")

enum RPG::Row

Possible values used for the battle row in RPG::Battler.

Enumerator:
ROW_FRONT

Front row.

ROW_BACK

Back row.

enum RPG::Scene

In-game scenes.

Each scene has its own drawing method and its own data. You may also "invent" a new scene and draw its contents using the onFrame callback.

See also:
onFrame
RPG::Screen::update
Enumerator:
SCENE_MAP

Map

SCENE_MENU

Game menu.

SCENE_BATTLE

Battle.

SCENE_SHOP

Shop.

SCENE_NAME

Hero naming screen

SCENE_FILE

Save or load menu.

SCENE_TITLE

Title screen.

SCENE_GAME_OVER

Game over screen.

SCENE_DEBUG

Debug screen (F9 menu)

enum RPG::SystemFont

Possible values for RPG::DBSystem::systemFont.

Enumerator:
SYSF_MSGOTHIC

First font (normally MS Gothic)

SYSF_MSMINCHO

Second font (normally MS Mincho)

enum RPG::Target

Possible values for the RPG::Action::target member.

Enumerator:
TARGET_NONE

No target (the sounds of the battle animation will still be audible)

TARGET_ACTOR

Target is an actor, specified in the RPG::Action::targetId member.

TARGET_ALL_ACTORS

Target are all actors at once.

TARGET_MONSTER

Target is a monster, specified in the RPG::Action::targetId member.

TARGET_ALL_MONSTERS

Target are all mosnters at once.

enum RPG::Transition

Screen transitions.

Enumerator:
TRANS_NONE

Used for "Erase" transitions to indicate that the screen should not be erased.

TRANS_DEFAULT

Default transition from the database.

Function Documentation

std::string RPG::encode ( int value )

Encodes a numerical value for use with RPG::Character::move.

Parameters:
value Value to encode
Returns:
Encoded value as string (may be 1 to 5 characters long)
std::string RPG::encode ( std::string value )

Encodes a string for use with RPG::Character::move.

Parameters:
value String to encode
Returns:
Encoded string (including length information)
std::string RPG::getConditionName ( int id )

Returns the name of a condition.

Parameters:
id Database ID of the condition
Returns:
Name of the condition
std::string RPG::getItemDescription ( int id )

Returns the description of an item.

Parameters:
id Database ID of the item
Returns:
Description of the item
See also:
RPG::getItemName
std::string RPG::getItemName ( int id )

Returns the name of an item.

Parameters:
id Database ID of the item
Returns:
Name of the item
See also:
RPG::getItemDescription
int RPG::getSelectedMonsterIndex ( )

Returns the index of the currently selected monster.

This function can be used to found out which monster is selected when the player is selecting a target for an attack or skill.

Returns:
Zero-based party member index of the selected monster
Precondition:
You must be in battle, otherwise the behavior is undefined.
std::string RPG::getSkillDescription ( int id )

Returns the description of a skill.

Parameters:
id Database ID of the skill
Returns:
Description of the skill
See also:
RPG::getSkillName
std::string RPG::getSkillName ( int id )

Returns the name of a skill.

Parameters:
id Database ID of the skill
Returns:
Name of the skill
See also:
RPG::getSkillDescription
std::map<std::string, std::string> RPG::loadConfiguration | ( | char * | sectionName,
 |  | char * | filename = 0
 | ) |  |

Returns a std::map containing configuration from an INI file.

This function should be used to load configuration for a plugin. See the Configuration guidelines for more information.

Parameters:
sectionName | Name of the section to load from the INI file
filename | Name of the INI file (defaults to DynRPG.ini)
Returns:
All keys and values of the specified section from the INI file
void RPG::updateBattle ( )

Updates the battle, including actions, ATB, animations, etc.

This function can be used if you want to do something which takes longer than one frame, for example displaying some kind of animation or taking and processing user input.

Precondition:
You must be in battle, otherwise the behavior is undefined.
Warning:
This function is experimental.
void RPG::updateBattleEvents | ( | RPG::BattleEventUpdateMode | mode,
 |  | RPG::Battler * | battler
 | ) |  |

Processes battle events.

This function can be used to update battle events and maybe call them at a time where normally no battle event is processed.

Parameters:
mode | Mode of the update (see RPG::BattleEventUpdateMode)
battler | Battler whose action is executed
Note:
battler can be 0 if mode is RPG::BEUM_BATTLE_START.
Precondition:
You must be in battle, otherwise the behavior is undefined.
Warning:
This function is highly experimental!
See also:
RPG::updateBattleEvents

Variable Documentation

int& RPG::battleSpeed = (*reinterpret_cast<int *>(0x442600)) [static]

Speed of the ATB system in percent.

This value can be set to zero to pause the battle.

Note:
This is a special feature of the DynRPG patch.
bool& RPG::isTestPlay = (**reinterpret_cast<bool **>(0x4CDD50)) [static]

The test play flag

This flag may also be changed at runtime.

bool& RPG::transparentWindowsEverywhere = (*reinterpret_cast<bool *>(0x462604)) [static]

Allows transparent windows in outside of the map too.

Set this flag to true to allow transparent windows in the menu, on the title screen, etc.

Note:
This is a special feature of the DynRPG patch.
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::Action Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • RPG
  • Action
Public Attributes
RPG::Action Class Reference

Action of a battler (normal attack, skill, escape, etc.), including target More...

List of all members.

Public Attributes

ActionKind_T kind
Kind of the action (see RPG::ActionKind)
BasicAction_T basicActionId
If kind is RPG::AK_BASIC: Kind of the basic action (see RPG::BasicAction)
char | userData1
You can store custom data here.
char | userData2
You can store custom data here.
int | skillId
If kind is RPG::AK_SKILL: Database ID of the skill.
int | monsterId
If kind is RPG::AK_TRANSFORM: Database ID of the monster to transform into.
int | itemId
If kind is RPG::AK_ITEM: Database ID of the item.
Target_T target
Target of the action (see RPG::Target)
int | targetId
If target is RPG::TARGET_ACTOR or RPG::TARGET_MONSTER: Zero-based party member index of the target.

Detailed Description

Action of a battler (normal attack, skill, escape, etc.), including target

This class is used to describe the action an actor or monster does in battle.

Note:
The action of a battler is always tied to the battler itself.
See also:
RPG::Battler
RPG::ActionKind
RPG::BasicAction
RPG::Target

Member Data Documentation

BasicAction_T RPG::Action::basicActionId

If kind is RPG::AK_BASIC: Kind of the basic action (see RPG::BasicAction)

int RPG::Action::itemId

If kind is RPG::AK_ITEM: Database ID of the item.

ActionKind_T RPG::Action::kind

Kind of the action (see RPG::ActionKind)

int RPG::Action::monsterId

If kind is RPG::AK_TRANSFORM: Database ID of the monster to transform into.

int RPG::Action::skillId

If kind is RPG::AK_SKILL: Database ID of the skill.

Target_T RPG::Action::target

Target of the action (see RPG::Target)

int RPG::Action::targetId

If target is RPG::TARGET_ACTOR or RPG::TARGET_MONSTER: Zero-based party member index of the target.

char RPG::Action::userData1

You can store custom data here.

char RPG::Action::userData2

You can store custom data here.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::Actor Class Reference

  • Class Hierarchy
  • Class Members
  • RPG
  • Actor
Public Member Functions | Static Public Member Functions | Public Attributes
RPG::Actor Class Reference

Used for the data of actors which can be changed in-game. More...

Inherits RPG::Battler.

List of all members.

Public Member Functions

std::string | getDegree ()
Returns the current degree.
std::string | getCharsetFilename ()
Returns the current charset filename.
int | getCharsetId ()
Returns the current charset ID.
int | getCharsetTransparency ()
Returns the current charset transparency.
std::string | getFacesetFilename ()
Returns the current faceset filename.
int | getFacesetId ()
Returns the current faceset ID.
int | getBattleGraphicId ()
Returns the current battle graphic ID.
int | getBattleCommand (int index)
Returns the current battle command on a certain position.
std::string | getName ()
Returns the name of the actor or monster.
int | getMaxHp ()
Returns the maximal HP.
int | getMaxMp ()
Returns the maximal MP.
int | getAttack ()
Returns the attack value.
int | getDefense ()
Returns the defense value.
int | getIntelligence ()
Returns the intelligence value.
int | getAgility ()
Returns the agility value.
void | setRow (Row newRow)
Sets the current row.
void | damagePopup (int number, int color)
Shows a damage popup with a number.
void | damagePopup (std::string text)
Shows a damage popup with a small text.
bool | isMonster ()
Checks whether the battler is a monster or an actor.
void | flash (int r, int g, int b, int intensity, int duration)
Flashes a battler in a certain color.
bool | executeAction (bool skipPluginHandlers=false)
Executes the action of a battler (highly experimental!)

Static Public Member Functions

static RPG::Actor * | partyMember (int index)
Returns a certain party member.

Public Attributes

DStringPtr name
Name ("\x01" means database default)
DStringPtr degree
Degree ("\x01" means database default)
DStringPtr charsetFilename
Filename of the charset (empty means database default)
int | charsetId
ID of the sprite in the charset file (only valid if charsetFilename isn't empty)
int | charsetTransparency
Transparency of the charset (0 to 8, only valid if charsetFilename isn't empty)
DStringPtr facesetFilename
Filename of the faceset (empty means database default)
int | facesetId
ID of the sprite in the faceset file (only valid if facesetFilename isn't empty)
int | level
Current level.
int | exp
Current experience points.
int | maxHpDiff
Difference from the default maximal HP.
int | maxMpDiff
Difference from the default maximal MP.
int | attackDiff
Difference from the default attack value.
int | defenseDiff
Difference from the default defense value.
int | intelligenceDiff
Difference from the default intelligence value.
int | agilityDiff
Difference from the default agility value.
short | weaponId
Database ID of the current weapon (zero for none)
short | shieldId
Database ID of the current shield (or second-hand weapon, zero for none)
short | armorId
Database ID of the current armor (zero for none)
short | helmetId
Database ID of the current helmet (zero for none)
short | accessoryId
Database ID of the current accessory (zero for none)
int | battleGraphicId
Database ID of the battle graphic (zero for database default)
bool | customBattleCommands
true if the battleCommands member is valid, otherwise the database default should be used
int | battleCommands [7]
The current battle commands for this actor (0 and -1 both mean "no command at this position")
int | id
One-based ID of the battler.
bool | notHidden
false if the battler is currently hidden (but not dead)
Action * action
Current action of the battler.
int | hp
Current HP.
int | mp
Current MP.
DArray< short, 1 > | conditions
Turns elapsed in a certain condition (see details)
int | atbValue
Current value of the ATB bar (0 to 300000 - see details)
bool | mirrored
true if the battler's image is mirrored
int | frameCounter
Internally used.
int | animationId
ID of the battle graphic pose (see details)
int | x
Current X coordinate (centered)
int | y
Current Y coordinate (centered)
int | originalX
Original X coordinate (used when an actor moves to attack)
int | originalY
Original Y coordinate (used when an actor moves to attack)
Row rowAlt
Internally used, I do not understand the difference from row yet.
Row row
Current row (no visible effect on monsters)
int | damagePopupTimer
Frames left until damage popup has finished (zero: no damage popup active)
int | flashR
Red value for flashing the battler (0 to 31)
int | flashG
Green value for flashing the battler (0 to 31)
int | flashB
Blue value for flashing the battler (0 to 31)
double | flashIntensity
Intensity for flashing the battler (0 to 31 - will decrease until flashing is done)
int | flashTimer
Frames left until flashing the battler finished (zero: no flashing active)
int | turnsTaken
Turns taken by this battler.
bool | longAction
true if the last action takes longer (info window needed) - I am not completely sure about that
ActionStatus actionStatus
Status of the current action.
int | displayedConditions [5]
Conditions which will be displayed in the info window (see details)

Detailed Description

Used for the data of actors which can be changed in-game.

Note:
Many things are only stored in this class if they were changed and are now different from the default in the database, thus you should use the getter methods to access these things.

The members ending with Diff are "offsets" which are added to the default value (which is calculated from the current level, class and equipment).
See also:
RPG::actors
RPG::DBActor
RPG::dbActors
RPG::Battler

Member Function Documentation

void RPG::Battler::damagePopup | ( | int | number,
 |  | int | color
 | ) |  | [inherited]

Shows a damage popup with a number.

This function will make a number pop up on a battler.

Parameters:
number | The number to show
color | Color to use (0 to 19)
See also:
damagePopup(std::string)
void RPG::Battler::damagePopup ( std::string text ) [inherited]

Shows a damage popup with a small text.

This function will make a small text pop up on a battler.

Parameters:
text Text to show
Note:
It is not possible to show string popups with a color other than 0.
See also:
damagePopup(int, int)
bool RPG::Battler::executeAction ( bool skipPluginHandlers = false ) [inherited]

Executes the action of a battler (highly experimental!)

This function can be used to execute an action. You need to set the content of the action object before.

Parameters:
skipPluginHandlers If true, no onDoBattlerAction and onBattlerActionDone handlers will be called for this action.
Returns:
true if the action was successfully executed, otherwise false (in this case try again next frame)
Warning:
This is a highly experimental function! During testing, it has repeatedly caused strange errors and crashes when executed under the wrong conditions or to the wrong time! It's probably not safe to use it for anything else than experiments, to be honest.
See also:
RPG::Action
void RPG::Battler::flash | ( | int | r,
 |  | int | g,
 |  | int | b,
 |  | int | intensity,
 |  | int | duration
 | ) |  | [inherited]

Flashes a battler in a certain color.

Parameters:
r | Red value (0 to 31)
g | Green value (0 to 31)
b | Blue value (0 to 31)
intensity | Intensity of the flash (0 to 33.5)
duration | Duration in frames
int RPG::Battler::getAgility ( ) [inherited]

Returns the agility value.

Returns:
Agility value
int RPG::Battler::getAttack ( ) [inherited]

Returns the attack value.

Returns:
Attack value
int RPG::Actor::getBattleCommand ( int index )

Returns the current battle command on a certain position.

Parameters:
index Zero-based index of the available commands for this actor (0 to 6)
Returns:
Database ID of the battle command on the given position or either 0 or -1 if there is none
int RPG::Actor::getBattleGraphicId ( )

Returns the current battle graphic ID.

Returns:
Database ID of the current battle graphic
std::string RPG::Actor::getCharsetFilename ( )

Returns the current charset filename.

Returns:
Current charset filename
See also:
getCharsetId
getCharsetTransparency
int RPG::Actor::getCharsetId ( )

Returns the current charset ID.

Returns:
ID of sprite in charsets
See also:
getCharsetFilename
getCharsetTransparency
int RPG::Actor::getCharsetTransparency ( )

Returns the current charset transparency.

Returns:
Transparency value (see RPG::Character::transparency documentation)
See also:
getCharsetFilename
getCharsetId
int RPG::Battler::getDefense ( ) [inherited]

Returns the defense value.

Returns:
Defense value
std::string RPG::Actor::getDegree ( )

Returns the current degree.

Returns:
Current degree
std::string RPG::Actor::getFacesetFilename ( )

Returns the current faceset filename.

Returns:
Current faceset filename
See also:
getFacesetId
int RPG::Actor::getFacesetId ( )

Returns the current faceset ID.

Returns:
ID of sprite in faceset
See also:
getFacesetFilename
int RPG::Battler::getIntelligence ( ) [inherited]

Returns the intelligence value.

Returns:
Intelligence value
int RPG::Battler::getMaxHp ( ) [inherited]

Returns the maximal HP.

Returns:
Maximal HP value
int RPG::Battler::getMaxMp ( ) [inherited]

Returns the maximal MP.

Returns:
Maximal MP value
std::string RPG::Battler::getName ( ) [inherited]

Returns the name of the actor or monster.

Returns:
The name
bool RPG::Battler::isMonster ( ) [inherited]

Checks whether the battler is a monster or an actor.

Returns:
true if the battler is a monster, false if it is an actor
static RPG::Actor* RPG::Actor::partyMember ( int index ) [static]

Returns a certain party member.

Parameters:
index Zero-based party member index (0 to 3)
Returns:
Pointer to the RPG::Actor object of the particular actor
void RPG::Battler::setRow ( Row newRow ) [inherited]

Sets the current row.

Parameters:
newRow New row
Note:
This function has no visible effect on monsters

Member Data Documentation

short RPG::Actor::accessoryId

Database ID of the current accessory (zero for none)

Action* RPG::Battler::action [inherited]

Current action of the battler.

ActionStatus RPG::Battler::actionStatus [inherited]

Status of the current action.

int RPG::Actor::agilityDiff

Difference from the default agility value.

int RPG::Battler::animationId [inherited]

ID of the battle graphic pose (see details)

This member specifies which battle graphic pose is displayed. Look into the "Animations 2" tab of the database to find out what the different values mean (e.g. 6 means "Taking damage").

Note:
This member has no meaning to monsters.
short RPG::Actor::armorId

Database ID of the current armor (zero for none)

int RPG::Battler::atbValue [inherited]

Current value of the ATB bar (0 to 300000 - see details)

Internally, the ATB bar can have a value between 0 and 300000 where 0 means empty and 300000 means full. If you set a battler's ATB value to a value greater than or equal to 300000, this will trigger his next action (in case of a monster) or open the action window (in case of an actor).

int RPG::Actor::attackDiff

Difference from the default attack value.

int RPG::Actor::battleCommands[7]

The current battle commands for this actor (0 and -1 both mean "no command at this position")

int RPG::Actor::battleGraphicId

Database ID of the battle graphic (zero for database default)

DStringPtr RPG::Actor::charsetFilename

Filename of the charset (empty means database default)

int RPG::Actor::charsetId

ID of the sprite in the charset file (only valid if charsetFilename isn't empty)

int RPG::Actor::charsetTransparency

Transparency of the charset (0 to 8, only valid if charsetFilename isn't empty)

DArray<short, 1> RPG::Battler::conditions [inherited]

Turns elapsed in a certain condition (see details)

This is an array which has as much possible members as there are conditions in the database. The values tell you how many turns the battler has taken while being affected by a certain conditions. If a value is zero, the particular condition does not affect this battler.

For example, if conditions[2] were 4, this battler would have been infected by poison (by default, condition #2 is poison) for 4 turns. If it were zero, the battler would not be poisoned at the moment.

bool RPG::Actor::customBattleCommands

true if the battleCommands member is valid, otherwise the database default should be used

int RPG::Battler::damagePopupTimer [inherited]

Frames left until damage popup has finished (zero: no damage popup active)

int RPG::Actor::defenseDiff

Difference from the default defense value.

DStringPtr RPG::Actor::degree

Degree ("\x01" means database default)

int RPG::Battler::displayedConditions[5] [inherited]

Conditions which will be displayed in the info window (see details)

At target selection, there will be an info window displayed if the target is affected by a condition. The info has five columns for condition names. This array contains the database IDs of the conditions which are displayed in this window. The content of this array will be reset on several occasions. You can change this array in your onDrawBattleStatusWindow handler.

int RPG::Actor::exp

Current experience points.

DStringPtr RPG::Actor::facesetFilename

Filename of the faceset (empty means database default)

int RPG::Actor::facesetId

ID of the sprite in the faceset file (only valid if facesetFilename isn't empty)

int RPG::Battler::flashB [inherited]

Blue value for flashing the battler (0 to 31)

int RPG::Battler::flashG [inherited]

Green value for flashing the battler (0 to 31)

double RPG::Battler::flashIntensity [inherited]

Intensity for flashing the battler (0 to 31 - will decrease until flashing is done)

Note:
Values over 31 will cause the palette to go crazy. Of course you can also use this as an intentional effect.
int RPG::Battler::flashR [inherited]

Red value for flashing the battler (0 to 31)

int RPG::Battler::flashTimer [inherited]

Frames left until flashing the battler finished (zero: no flashing active)

int RPG::Battler::frameCounter [inherited]

Internally used.

short RPG::Actor::helmetId

Database ID of the current helmet (zero for none)

int RPG::Battler::hp [inherited]

Current HP.

int RPG::Battler::id [inherited]

One-based ID of the battler.

For actors this value is the database ID, for monsters it is the party member ID plus one (e.g. RPG::monsters[3]->id should always be 4).

If you want to get the database ID of a monster, you have to use RPG::Monster::databaseId.

int RPG::Actor::intelligenceDiff

Difference from the default intelligence value.

int RPG::Actor::level

Current level.

bool RPG::Battler::longAction [inherited]

true if the last action takes longer (info window needed) - I am not completely sure about that

int RPG::Actor::maxHpDiff

Difference from the default maximal HP.

int RPG::Actor::maxMpDiff

Difference from the default maximal MP.

bool RPG::Battler::mirrored [inherited]

true if the battler's image is mirrored

int RPG::Battler::mp [inherited]

Current MP.

DStringPtr RPG::Actor::name

Name ("\x01" means database default)

bool RPG::Battler::notHidden [inherited]

false if the battler is currently hidden (but not dead)

int RPG::Battler::originalX [inherited]

Original X coordinate (used when an actor moves to attack)

int RPG::Battler::originalY [inherited]

Original Y coordinate (used when an actor moves to attack)

Row RPG::Battler::row [inherited]

Current row (no visible effect on monsters)

Row RPG::Battler::rowAlt [inherited]

Internally used, I do not understand the difference from row yet.

short RPG::Actor::shieldId

Database ID of the current shield (or second-hand weapon, zero for none)

int RPG::Battler::turnsTaken [inherited]

Turns taken by this battler.

short RPG::Actor::weaponId

Database ID of the current weapon (zero for none)

int RPG::Battler::x [inherited]

Current X coordinate (centered)

int RPG::Battler::y [inherited]

Current Y coordinate (centered)

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::ArrayBaseOne< T, size > Class Template Reference

  • ArrayBaseOne
Public Member Functions
RPG::ArrayBaseOne< T, size > Class Template Reference

Helper class for arrays with base one. More...

List of all members.

Public Member Functions

T & operator[] (int index)
Simple indexing operator for accessing array elements.

Detailed Description

template<class T, int size>
class RPG::ArrayBaseOne< T, size >

Helper class for arrays with base one.

This class template is used for arrays in classes with should have one as base (unlike normal arrays with base zero).

Member Function Documentation

template<class T, int size>
T& RPG::ArrayBaseOne< T, size >::operator[] ( int index ) [inline]

Simple indexing operator for accessing array elements.

Parameters:
index One-based index
Returns:
Value of the element
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::Battler Class Reference

  • Battler
Public Member Functions | Public Attributes
RPG::Battler Class Reference

Used for entities participating in battle, i.e. actors and monsters. More...

Inherited by RPG::Actor, and RPG::Monster.

List of all members.

Public Member Functions

std::string | getName ()
Returns the name of the actor or monster.
int | getMaxHp ()
Returns the maximal HP.
int | getMaxMp ()
Returns the maximal MP.
int | getAttack ()
Returns the attack value.
int | getDefense ()
Returns the defense value.
int | getIntelligence ()
Returns the intelligence value.
int | getAgility ()
Returns the agility value.
void | setRow (Row newRow)
Sets the current row.
void | damagePopup (int number, int color)
Shows a damage popup with a number.
void | damagePopup (std::string text)
Shows a damage popup with a small text.
bool | isMonster ()
Checks whether the battler is a monster or an actor.
void | flash (int r, int g, int b, int intensity, int duration)
Flashes a battler in a certain color.
bool | executeAction (bool skipPluginHandlers=false)
Executes the action of a battler (highly experimental!)

Public Attributes

int | id
One-based ID of the battler.
bool | notHidden
false if the battler is currently hidden (but not dead)
Action * action
Current action of the battler.
int | hp
Current HP.
int | mp
Current MP.
DArray< short, 1 > | conditions
Turns elapsed in a certain condition (see details)
int | atbValue
Current value of the ATB bar (0 to 300000 - see details)
bool | mirrored
true if the battler's image is mirrored
int | frameCounter
Internally used.
int | animationId
ID of the battle graphic pose (see details)
int | x
Current X coordinate (centered)
int | y
Current Y coordinate (centered)
int | originalX
Original X coordinate (used when an actor moves to attack)
int | originalY
Original Y coordinate (used when an actor moves to attack)
Row rowAlt
Internally used, I do not understand the difference from row yet.
Row row
Current row (no visible effect on monsters)
int | damagePopupTimer
Frames left until damage popup has finished (zero: no damage popup active)
int | flashR
Red value for flashing the battler (0 to 31)
int | flashG
Green value for flashing the battler (0 to 31)
int | flashB
Blue value for flashing the battler (0 to 31)
double | flashIntensity
Intensity for flashing the battler (0 to 31 - will decrease until flashing is done)
int | flashTimer
Frames left until flashing the battler finished (zero: no flashing active)
int | turnsTaken
Turns taken by this battler.
bool | longAction
true if the last action takes longer (info window needed) - I am not completely sure about that
ActionStatus actionStatus
Status of the current action.
int | displayedConditions [5]
Conditions which will be displayed in the info window (see details)

Detailed Description

Used for entities participating in battle, i.e. actors and monsters.

Even though this is the base class of both RPG::Actor and RPG::Monster, some members only apply to one of them.

See also:
RPG::Row
RPG::ActionStatus
RPG::Actor
RPG::Monster

Member Function Documentation

void RPG::Battler::damagePopup | ( | int | number,
 |  | int | color
 | ) |  |

Shows a damage popup with a number.

This function will make a number pop up on a battler.

Parameters:
number | The number to show
color | Color to use (0 to 19)
See also:
damagePopup(std::string)
void RPG::Battler::damagePopup ( std::string text )

Shows a damage popup with a small text.

This function will make a small text pop up on a battler.

Parameters:
text Text to show
Note:
It is not possible to show string popups with a color other than 0.
See also:
damagePopup(int, int)
bool RPG::Battler::executeAction ( bool skipPluginHandlers = false )

Executes the action of a battler (highly experimental!)

This function can be used to execute an action. You need to set the content of the action object before.

Parameters:
skipPluginHandlers If true, no onDoBattlerAction and onBattlerActionDone handlers will be called for this action.
Returns:
true if the action was successfully executed, otherwise false (in this case try again next frame)
Warning:
This is a highly experimental function! During testing, it has repeatedly caused strange errors and crashes when executed under the wrong conditions or to the wrong time! It's probably not safe to use it for anything else than experiments, to be honest.
See also:
RPG::Action
void RPG::Battler::flash | ( | int | r,
 |  | int | g,
 |  | int | b,
 |  | int | intensity,
 |  | int | duration
 | ) |  |

Flashes a battler in a certain color.

Parameters:
r | Red value (0 to 31)
g | Green value (0 to 31)
b | Blue value (0 to 31)
intensity | Intensity of the flash (0 to 33.5)
duration | Duration in frames
int RPG::Battler::getAgility ( )

Returns the agility value.

Returns:
Agility value
int RPG::Battler::getAttack ( )

Returns the attack value.

Returns:
Attack value
int RPG::Battler::getDefense ( )

Returns the defense value.

Returns:
Defense value
int RPG::Battler::getIntelligence ( )

Returns the intelligence value.

Returns:
Intelligence value
int RPG::Battler::getMaxHp ( )

Returns the maximal HP.

Returns:
Maximal HP value
int RPG::Battler::getMaxMp ( )

Returns the maximal MP.

Returns:
Maximal MP value
std::string RPG::Battler::getName ( )

Returns the name of the actor or monster.

Returns:
The name
bool RPG::Battler::isMonster ( )

Checks whether the battler is a monster or an actor.

Returns:
true if the battler is a monster, false if it is an actor
void RPG::Battler::setRow ( Row newRow )

Sets the current row.

Parameters:
newRow New row
Note:
This function has no visible effect on monsters

Member Data Documentation

Action* RPG::Battler::action

Current action of the battler.

ActionStatus RPG::Battler::actionStatus

Status of the current action.

int RPG::Battler::animationId

ID of the battle graphic pose (see details)

This member specifies which battle graphic pose is displayed. Look into the "Animations 2" tab of the database to find out what the different values mean (e.g. 6 means "Taking damage").

Note:
This member has no meaning to monsters.
int RPG::Battler::atbValue

Current value of the ATB bar (0 to 300000 - see details)

Internally, the ATB bar can have a value between 0 and 300000 where 0 means empty and 300000 means full. If you set a battler's ATB value to a value greater than or equal to 300000, this will trigger his next action (in case of a monster) or open the action window (in case of an actor).

DArray<short, 1> RPG::Battler::conditions

Turns elapsed in a certain condition (see details)

This is an array which has as much possible members as there are conditions in the database. The values tell you how many turns the battler has taken while being affected by a certain conditions. If a value is zero, the particular condition does not affect this battler.

For example, if conditions[2] were 4, this battler would have been infected by poison (by default, condition #2 is poison) for 4 turns. If it were zero, the battler would not be poisoned at the moment.

int RPG::Battler::damagePopupTimer

Frames left until damage popup has finished (zero: no damage popup active)

int RPG::Battler::displayedConditions[5]

Conditions which will be displayed in the info window (see details)

At target selection, there will be an info window displayed if the target is affected by a condition. The info has five columns for condition names. This array contains the database IDs of the conditions which are displayed in this window. The content of this array will be reset on several occasions. You can change this array in your onDrawBattleStatusWindow handler.

int RPG::Battler::flashB

Blue value for flashing the battler (0 to 31)

int RPG::Battler::flashG

Green value for flashing the battler (0 to 31)

double RPG::Battler::flashIntensity

Intensity for flashing the battler (0 to 31 - will decrease until flashing is done)

Note:
Values over 31 will cause the palette to go crazy. Of course you can also use this as an intentional effect.
int RPG::Battler::flashR

Red value for flashing the battler (0 to 31)

int RPG::Battler::flashTimer

Frames left until flashing the battler finished (zero: no flashing active)

int RPG::Battler::frameCounter

Internally used.

int RPG::Battler::hp

Current HP.

int RPG::Battler::id

One-based ID of the battler.

For actors this value is the database ID, for monsters it is the party member ID plus one (e.g. RPG::monsters[3]->id should always be 4).

If you want to get the database ID of a monster, you have to use RPG::Monster::databaseId.

bool RPG::Battler::longAction

true if the last action takes longer (info window needed) - I am not completely sure about that

bool RPG::Battler::mirrored

true if the battler's image is mirrored

int RPG::Battler::mp

Current MP.

bool RPG::Battler::notHidden

false if the battler is currently hidden (but not dead)

int RPG::Battler::originalX

Original X coordinate (used when an actor moves to attack)

int RPG::Battler::originalY

Original Y coordinate (used when an actor moves to attack)

Row RPG::Battler::row

Current row (no visible effect on monsters)

Row RPG::Battler::rowAlt

Internally used, I do not understand the difference from row yet.

int RPG::Battler::turnsTaken

Turns taken by this battler.

int RPG::Battler::x

Current X coordinate (centered)

int RPG::Battler::y

Current Y coordinate (centered)

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::BattleSettings Class Reference

  • BattleSettings
Public Attributes
RPG::BattleSettings Class Reference

Used for battle settings (layout, etc.) More...

List of all members.

Public Attributes

BattleLayout_T layout
Battle layout.
bool | largeWindows
Are the "large windows" active?
bool | transparentWindows
Are transparent windows active? (This affects the whole game even though the RPG Maker guys have put it into the battle settings.)

Detailed Description

Used for battle settings (layout, etc.)

See also:
RPG::battleSettings
RPG::System

Member Data Documentation

bool RPG::BattleSettings::largeWindows

Are the "large windows" active?

BattleLayout_T RPG::BattleSettings::layout

Battle layout.

bool RPG::BattleSettings::transparentWindows

Are transparent windows active? (This affects the whole game even though the RPG Maker guys have put it into the battle settings.)

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::Canvas Class Reference

  • Canvas
Public Member Functions | Static Public Member Functions | Public Attributes
RPG::Canvas Class Reference

Image buffer with 16 bit color depth, used as canvas for multiple 8-bit images More...

List of all members.

Public Member Functions

unsigned short & | pixel (int x, int y)
Returns a reference to a pixel.
unsigned short * | getScanline (int y)
Returns a pointer to a row of pixel data.
int | width ()
Returns the width of the bitmap.
int | height ()
Returns the height of the bitmap.
void | draw (int x, int y, RPG::Image *image, int srcX=0, int srcY=0, int srcWidth=-1, int srcHeight=-1)
Draws an RPG::Image or a part of it onto the canvas.

Static Public Member Functions

static unsigned int | convert16To24Bit (unsigned short pixel16)
Converts a 16-bit pixel value to 24 bit.
static unsigned int | convert16To32Bit (unsigned short pixel16)
Converts a 16-bit pixel value to 32 bit with 100% opacity.
static unsigned short | convert24To16Bit (unsigned int pixel24)
Converts a 24-bit pixel value to 16 bit.
static unsigned short | convert32To16Bit (unsigned int pixel32, unsigned short prevPixel16)
Converts a 32-bit pixel value to 16 bit by combining it with an existing pixel.

Public Attributes

DBitmap * bitmap
Underlying 16-bit bitmap.
int | lineSize
Number of bytes you have to add to a pixel address to get the address of the pixel in the same column of the next pixel row (see details)
int | brightness
Brightness of the screen (see details)

Detailed Description

Image buffer with 16 bit color depth, used as canvas for multiple 8-bit images

See also:
RPG::Screen::canvas
RPG::Image

Member Function Documentation

static unsigned int RPG::Canvas::convert16To24Bit ( unsigned short pixel16 ) [inline, static]

Converts a 16-bit pixel value to 24 bit.

Parameters:
pixel16 16-bit pixel value (RRRRRGGGGGGBBBBB)
Returns:
24-bit pixel value (00000000BBBBBBBBGGGGGGGGRRRRRRRR)
static unsigned int RPG::Canvas::convert16To32Bit ( unsigned short pixel16 ) [inline, static]

Converts a 16-bit pixel value to 32 bit with 100% opacity.

Parameters:
pixel16 16-bit pixel value (RRRRRGGGGGGBBBBB)
Returns:
32-bit pixel value (11111111BBBBBBBBGGGGGGGGRRRRRRRR)
static unsigned short RPG::Canvas::convert24To16Bit ( unsigned int pixel24 ) [inline, static]

Converts a 24-bit pixel value to 16 bit.

Parameters:
pixel24 24-bit pixel value (00000000BBBBBBBBGGGGGGGGRRRRRRRR)
Returns:
16-bit pixel value (RRRRRGGGGGGBBBBB)
static unsigned short RPG::Canvas::convert32To16Bit | ( | unsigned int | pixel32,
 |  | unsigned short | prevPixel16
 | ) |  | [inline, static]

Converts a 32-bit pixel value to 16 bit by combining it with an existing pixel.

The result is the 16-bit pixel value which is the result of drawing the pixel32 "on top" of the prevPixel16.

Parameters:
pixel32 | 32-bit pixel value (AAAAAAAABBBBBBBBGGGGGGGGRRRRRRRR)
prevPixel16 | 16-bit pixel value to use as basis for the alpha channel
Returns:
16-bit pixel value (RRRRRGGGGGGBBBBB)
void RPG::Canvas::draw | ( | int | x,
 |  | int | y,
 |  | RPG::Image * | image,
 |  | int | srcX = 0,
 |  | int | srcY = 0,
 |  | int | srcWidth = -1,
 |  | int | srcHeight = -1
 | ) |  |

Draws an RPG::Image or a part of it onto the canvas.

This function will draw a certain part of an RPG::Image onto the canvas. You can omit the last four parameters to draw the whole image.

The image's brightness will automatically be adjusted to match the canvas brightness. To avoid this, you can save the canvas brightness, set it to 100, draw the image and then restore the original brightness of the canvas.

Parameters:
x | X coordinate to draw to (upper-left origin)
y | Y coordinate to draw to (upper-left origin)
image | Image to draw
srcX | X coordinate of the area to use from the source image
srcY | Y coordinate of the area to use from the source image
srcWidth | Width of the area to draw (defaults to the whole image)
srcHeight | Height of the area to draw (defaults to the whole image)
Warning:
This function is quite slow, especially if you draw an image which uses a mask color or an alpha value different from 255. Please also see the Optimization guidelines!
See also:
RPG::Image::draw
unsigned short* RPG::Canvas::getScanline ( int y )

Returns a pointer to a row of pixel data.

Parameters:
y Y coordinate
Returns:
Pointer to the first pixel of the row
Note:
If you loop through rows, it is way faster to use getScanline(0) once and then always add lineSize to get to the next row instead of calling getScanline for every row.
int RPG::Canvas::height ( )

Returns the height of the bitmap.

unsigned short& RPG::Canvas::pixel | ( | int | x,
 |  | int | y
 | ) |  |

Returns a reference to a pixel.

Parameters:
x | X coordinate
y | Y coordinate
Returns:
Reference to the pixel
int RPG::Canvas::width ( )

Returns the width of the bitmap.

Member Data Documentation

DBitmap* RPG::Canvas::bitmap

Underlying 16-bit bitmap.

int RPG::Canvas::brightness

Brightness of the screen (see details)

Supported values are from 0 (completely black) to 200 (completely white). 100 is the normal value. This value is changed during "fading" screen transitions.

Note:
Values higher than 200 will cause the colors to go crazy. Of course, this can also be used as an intentional effect, for example the value 204 will only use the colors blue, white and black.
int RPG::Canvas::lineSize

Number of bytes you have to add to a pixel address to get the address of the pixel in the same column of the next pixel row (see details)

Normally, this number is negative because bitmaps are stored from bottom to top.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::Catalog< T > Class Template Reference

  • Catalog
Public Member Functions | Public Attributes
RPG::Catalog< T > Class Template Reference

Wrapper class for RPG::DList which doesn't crash if the index is out of bounds. More...

Inherited by RPG::NamedCatalog< T >.

List of all members.

Public Member Functions

T | operator[] (int index)
Array access operator.
T | get (int index)
Array access method.
int | count ()
Returns the number of items in the list.

Public Attributes

DListPtr< T > | list

Detailed Description

template<class T = void *>
class RPG::Catalog< T >

Wrapper class for RPG::DList which doesn't crash if the index is out of bounds.

Note:
Please do not ask me why this class is there. I didn't invent it.
Warning:
This class has more members than the one which is documented (the others are used internally), so sizeof(RPG::Catalog<T>) is not equal to sizeof(RPG::DList<T> *)!
See also:
RPG::CatalogPtr
RPG::NamedCatalog
RPG::NamedCatalogPtr
RPG::DList

Member Function Documentation

template<class T = void *>
int RPG::Catalog< T >::count ( ) [inline]

Returns the number of items in the list.

template<class T = void *>
T RPG::Catalog< T >::get ( int index ) [inline]

Array access method.

Reimplemented in RPG::NamedCatalog< T >, and RPG::NamedCatalog< Event * >.

template<class T = void *>
T RPG::Catalog< T >::operator[] ( int index ) [inline]

Array access operator.

Reimplemented in RPG::NamedCatalog< T >, and RPG::NamedCatalog< Event * >.

Member Data Documentation

template<class T = void *>
DListPtr<T> RPG::Catalog< T >::list

Pointer to the actual RPG::DList

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::CatalogPtr< T > Class Template Reference

  • CatalogPtr
Public Member Functions | Public Attributes
RPG::CatalogPtr< T > Class Template Reference

Wrapper class for RPG::Catalog pointers (syntactic sugar) More...

List of all members.

Public Member Functions

T | operator[] (int index)
Array access operator.
T | get (int index)
Array access method.
int | count ()
Returns the number of items in the list.

Public Attributes

Catalog< T > * | ptr
Pointer to the actual RPG::Catalog.

Detailed Description

template<class T = void *>
class RPG::CatalogPtr< T >

Wrapper class for RPG::Catalog pointers (syntactic sugar)

Allows you to write someCatalogPointer[i] instead of (*someCatalogPointer)[i].

Note:
The size of this class equals to sizeof(Catalog<T> *).
See also:
RPG::Catalog
RPG::NamedCatalogPtr

Member Function Documentation

template<class T = void *>
int RPG::CatalogPtr< T >::count ( ) [inline]

Returns the number of items in the list.

template<class T = void *>
T RPG::CatalogPtr< T >::get ( int index ) [inline]

Array access method.

template<class T = void *>
T RPG::CatalogPtr< T >::operator[] ( int index ) [inline]

Array access operator.

Member Data Documentation

template<class T = void *>
Catalog<T>* RPG::CatalogPtr< T >::ptr

Pointer to the actual RPG::Catalog.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::NamedCatalog< T > Class Template Reference

  • NamedCatalog
Public Member Functions | Public Attributes
RPG::NamedCatalog< T > Class Template Reference

Class inherited from RPG::Catalog in which elements with non-consecutive IDs are stored without waste of memory (i.e. events on a map) More...

Inherits RPG::Catalog< T >.

List of all members.

Public Member Functions

T | operator[] (int index)
Array access operator.
T | get (int index)
Array access method.
int | count ()
Returns the number of items in the list.

Public Attributes

DListPtr< T > | list

Detailed Description

template<class T = void *>
class RPG::NamedCatalog< T >

Class inherited from RPG::Catalog in which elements with non-consecutive IDs are stored without waste of memory (i.e. events on a map)

If you need to enumerate all items in an RPG::NamedCatalog, use

for(int i = 0; i < myCatalog.count(); i++) {
               SomeObjectType *item = myCatalog.list[i];
               // Processing here...
}

If you have an RPG::NamedCatalogPtr, it works the same way.

See also:
RPG::Catalog
RPG::NamedCatalogPtr

Member Function Documentation

template<class T = void *>
int RPG::Catalog< T >::count ( ) [inline, inherited]

Returns the number of items in the list.

template<class T = void *>
T RPG::NamedCatalog< T >::get ( int index ) [inline]

Array access method.

Reimplemented from RPG::Catalog< T >.

template<class T = void *>
T RPG::NamedCatalog< T >::operator[] ( int index ) [inline]

Array access operator.

Reimplemented from RPG::Catalog< T >.

Member Data Documentation

template<class T = void *>
DListPtr<T> RPG::Catalog< T >::list [inherited]

Pointer to the actual RPG::DList

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::NamedCatalogPtr< T > Class Template Reference

  • NamedCatalogPtr
Public Member Functions | Public Attributes
RPG::NamedCatalogPtr< T > Class Template Reference

Wrapper class for RPG::NamedCatalog pointers (syntactic sugar) More...

List of all members.

Public Member Functions

T | operator[] (int index)
Array access operator.
T | get (int index)
Array access method.
int | count ()
Returns the number of items in the list (not the highest ID!)

Public Attributes

NamedCatalog< T > * | ptr

Detailed Description

template<class T = void *>
class RPG::NamedCatalogPtr< T >

Wrapper class for RPG::NamedCatalog pointers (syntactic sugar)

Allows you to write RPG::actors[1]->hp instead of (*RPG::actors)[1]->hp, for example.

Note:
The size of this class equals to sizeof(NamedCatalog<T> *).
See also:
RPG::NamedCatalog

Member Function Documentation

template<class T = void *>
int RPG::NamedCatalogPtr< T >::count ( ) [inline]

Returns the number of items in the list (not the highest ID!)

template<class T = void *>
T RPG::NamedCatalogPtr< T >::get ( int index ) [inline]

Array access method.

template<class T = void *>
T RPG::NamedCatalogPtr< T >::operator[] ( int index ) [inline]

Array access operator.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::Character Class Reference

  • Character
Public Member Functions | Public Attributes
RPG::Character Class Reference

Used for movable entities on the map, i.e. events, the hero (and vehicles, but they are not supported yet) More...

Inherited by RPG::Event, and RPG::Hero.

List of all members.

Public Member Functions

int | getScreenX ()
Returns the current X screen coordinate.
int | getScreenY ()
Returns the current Y screen coordinate.
void | setFixedStep (int newStep)
Sets a fixed step.
void | setNormalStep ()
Removes a fixed step position and goes back to normal.
void | setAnimationType (RPG::AnimationType type)
Sets the animation type.
bool | isMovePossible (int fromX, int fromY, int toX, int toY)
Checks whether a certain move is possible.
std::string | getName ()
Returns the name of the character.
void | move (char *data, int length, bool repeatPattern=false, bool ignoreImpossible=true, int frequency=8)
Moves a character.
void | stop ()
Stops the current movement.
void | doStep (RPG::Direction direction)
Does one step (moves the character one tile into a certain direction)

Public Attributes

int | id
ID of the event (zero if not an ordinary event)
bool | enabled
Is the event visible and enabled?
int | mapID
Map ID (only relevant for vehicles which are not supported yet)
int | x
X coordinate (tiles)
int | y
Y coordinate (tiles)
Direction_T direction
Direction for moving (see RPG::Direction)
Facing_T facing
Direction for facing (see RPG::Facing)
int | step
Current step value (see details)
int | transparency
Transparency value, between 0 (completely visible) to 8 (completely invisible)
int | movementFramesLeft
Frames left until movement is completed (see details)
int | frequency
Current movement frequency (1 to 8)
int | originalFrequency
Original movement frequency (use for "Move event" commands with a frequency different from the current one)
Layer_T layer
Layer (below/same level as/above hero, see RPG::Layer)
bool | forbidEventOverlap
true if the event cannot move onto a tile occupied by another event
AnimationType_T animationType
Animation type of the event (see details and RPG::AnimationType)
bool | fixedDirection
Is the facing direction (facing) fixed?
int | speed
Current speed of the character (1 to 6, see also customExactSpeed)
MoveRoute * moveRoute
Current move route (can also be set by "Move Event" commands)
bool | moving
Is the character currently moving?
char | offsetX
Horizontal offset for drawing the event graphic (see details)
char | offsetY
Vertical offset for drawing the event graphic (see offsetX)
char | customExactSpeed
Custom exact speed (see details)
bool | phasing
Is the "phasing mode" on?
int | stepFrameCounter
Internally used, for stepping.
int | stepTimer
Internally used, for stepping (-1 if a fixed step is used, see setFixedStep)
int | frequencyTimer
Internall used, for movement frequency.
DStringPtr charsetFilename
Filename of the current charset.
int | charsetId
ID of the current charset.

Detailed Description

Used for movable entities on the map, i.e. events, the hero (and vehicles, but they are not supported yet)

See also:
RPG::Event
RPG::Map::events
RPG::Hero
RPG::hero
RPG::Direction
RPG::Facing
RPG::Layer
RPG::AnimationType
RPG::MoveRoute

Member Function Documentation

void RPG::Character::doStep ( RPG::Direction direction )

Does one step (moves the character one tile into a certain direction)

Parameters:
direction Direction to move into
Warning:
This is an experimental function.
See also:
move
std::string RPG::Character::getName ( )

Returns the name of the character.

This function returns the event name which was set in the event editor or the name of the first actor in the party in case the character is the hero.

Returns:
The name of the character (event or hero name)
int RPG::Character::getScreenX ( )

Returns the current X screen coordinate.

int RPG::Character::getScreenY ( )

Returns the current Y screen coordinate.

bool RPG::Character::isMovePossible | ( | int | fromX,
 |  | int | fromY,
 |  | int | toX,
 |  | int | toY
 | ) |  |

Checks whether a certain move is possible.

This function if the character will be able to complete a certain move, taking event layer, forbidEventOverlap, other blocking events and the tileset attributes into account.

Parameters:
fromX | X coordinate (tiles) of the source position
fromY | Y coordinate (tiles) of the source position
toX | X coordinate (tiles) of the destination position
toY | Y coordinate (tiles) of the destination position
Returns:
true if the move is possible, otherwise false
Warning:
This is an experimental function.
void RPG::Character::move | ( | char * | data,
 |  | int | length,
 |  | bool | repeatPattern = false,
 |  | bool | ignoreImpossible = true,
 |  | int | frequency = 8
 | ) |  |

Moves a character.

This function will move a character (event or hero) the same way the "Move event" command does.

The data member is a pointer to a char array containing the encoded data. You can find a list of possible movement commands at the RPG::MoveType documentation. For most movement commands, you will just use one byte containing the move type.

Example:

char[] moves = {RPG::MT_MOVE_UP, RPG::MT_MOVE_RIGHT, RPG::MT_MOVE_RIGHT, RPG::MT_TURN_RANDOMLY, RPG::MT_MOVE_FORWARD};
RPG::hero->move(moves, sizeof(moves));

There are, however, a few commands which take parameters: RPG::MT_SWITCH_ON, RPG::MT_SWITCH_OFF, RPG::MT_CHANGE_GRAPHIC and RPG::MT_PLAY_SE. If you want to use these commands, you better use a std::string. You need to add the parameters to the string right after the command byte, using the functions encode(int) for numerical parameters and encode(std::string) for string parameters.

Example:

std::string moves = "";
moves += (char)RPG::MT_MOVE_UP;
moves += (char)RPG::MT_FACE_DOWN;
moves += (char)RPG::MT_PLAY_SE;
moves += RPG::encode("chicken"); // filename
moves += RPG::encode(100); // volume
moves += RPG::encode(100); // speed
moves += RPG::encode(50); // pan
moves += (char)RPG::MT_TURN_AROUND;
RPG::hero->move(moves.c_str(), moves.length());
Parameters:
data | Pointer to the movement data
length | Length of the movement data
repeatPattern | true if the pattern should be repeated until stop is called
ignoreImpossible | Should impossible movements be ignored?
frequency | Frequency of the movement
Note:
RPG::MT_INCREASE_FREQUENCY and RPG::MT_DECREASE_FREQUENCY commands will not take permanent effect after the movement ended unless the movement was started with the same frequency as in the frequency member of the character.
Warning:
This is an experimental function.
See also:
RPG::MoveType
stop
doStep
void RPG::Character::setAnimationType ( RPG::AnimationType type )

Sets the animation type.

This function sets the animationType and fixedDirection members to the correct values.

Parameters:
type New animation type
See also:
animationType
RPG::AnimationType
void RPG::Character::setFixedStep ( int newStep )

Sets a fixed step.

You can use this function to set a fixed step position and keep it until setNormalStep is called.

Parameters:
newStep New step position, for possible values see step
Note:
This is a special feature of the DynRPG Patch.
See also:
setNormalStep
step
void RPG::Character::setNormalStep ( )

Removes a fixed step position and goes back to normal.

See also:
setFixedStep
void RPG::Character::stop ( )

Stops the current movement.

Warning:
This is an experimental function.
See also:
move

Member Data Documentation

AnimationType_T RPG::Character::animationType

Animation type of the event (see details and RPG::AnimationType)

This member is used for the animation type as defined in the event editor. However, it does not control whether the facing is locked or not, i.e. if you set it to RPG::ANI_FIXED_GRAPHIC, the event may still not have locked facing. Thus, you should use the setAnimationType function which automatically sets the fixedDirection member to the correct value.

See also:
setAnimationType
RPG::AnimationType
DStringPtr RPG::Character::charsetFilename

Filename of the current charset.

int RPG::Character::charsetId

ID of the current charset.

char RPG::Character::customExactSpeed

Custom exact speed (see details)

You can the speed of a character in a finer way than the normal six speed values provide. One speed unit means 3.75 pixels per second (or 1/16 pixel per frame). For example customExactSpeed = 20 will set the speed to 75 pixels per second (1.25 pixels per frame).

If you set customExactSpeed to 0, the speed which is set in speed will be used.

Note:
This is a special feature of the DynRPG patch.
Direction_T RPG::Character::direction

Direction for moving (see RPG::Direction)

bool RPG::Character::enabled

Is the event visible and enabled?

Facing_T RPG::Character::facing

Direction for facing (see RPG::Facing)

bool RPG::Character::fixedDirection

Is the facing direction (facing) fixed?

bool RPG::Character::forbidEventOverlap

true if the event cannot move onto a tile occupied by another event

int RPG::Character::frequency

Current movement frequency (1 to 8)

int RPG::Character::frequencyTimer

Internall used, for movement frequency.

int RPG::Character::id

ID of the event (zero if not an ordinary event)

Layer_T RPG::Character::layer

Layer (below/same level as/above hero, see RPG::Layer)

int RPG::Character::mapID

Map ID (only relevant for vehicles which are not supported yet)

int RPG::Character::movementFramesLeft

Frames left until movement is completed (see details)

This value is zero if the movement is completed. Otherwise it means the frames left until it is completed. This value, together with direction, is used to calculate the current screen coordinates.

MoveRoute* RPG::Character::moveRoute

Current move route (can also be set by "Move Event" commands)

bool RPG::Character::moving

Is the character currently moving?

char RPG::Character::offsetX

Horizontal offset for drawing the event graphic (see details)

The offsetX and offsetY members can be used to control the screen coordinates on which the event is drawn. You specify an offset value which will be added to the normal value.

For example, you might set offsetX = 8 and offsetY = -16 - and then the event will always be drawn 8 pixels to the right and 16 pixels higher than it would normally be. This way, you can do a finer movement and even do a "fake" pixel movement.

Note:
This is a special feature of the DynRPG patch.
char RPG::Character::offsetY

Vertical offset for drawing the event graphic (see offsetX)

int RPG::Character::originalFrequency

Original movement frequency (use for "Move event" commands with a frequency different from the current one)

bool RPG::Character::phasing

Is the "phasing mode" on?

int RPG::Character::speed

Current speed of the character (1 to 6, see also customExactSpeed)

int RPG::Character::step

Current step value (see details)

Possible values:

  • 0: Left
  • 1: Middle
  • 2: Right
  • 3: Middle
int RPG::Character::stepFrameCounter

Internally used, for stepping.

int RPG::Character::stepTimer

Internally used, for stepping (-1 if a fixed step is used, see setFixedStep)

int RPG::Character::transparency

Transparency value, between 0 (completely visible) to 8 (completely invisible)

int RPG::Character::x

X coordinate (tiles)

int RPG::Character::y

Y coordinate (tiles)

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::EventData Class Reference

  • EventData
Public Attributes
RPG::EventData Class Reference

Class used for storing special event data of a character. More...

List of all members.

Public Attributes

DStringPtr name
Name of the event, as set in the event editor.

Detailed Description

Class used for storing special event data of a character.

Note:
At the moment, only the event name can be accessed.

Member Data Documentation

DStringPtr RPG::EventData::name

Name of the event, as set in the event editor.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::Event Class Reference

  • Event
Public Member Functions | Public Attributes
RPG::Event Class Reference

Used for events as subtype of characters. More...

Inherits RPG::Character.

List of all members.

Public Member Functions

bool | doesEventPageExist (int id)
Checks whether a certain event page exists.
int | getScreenX ()
Returns the current X screen coordinate.
int | getScreenY ()
Returns the current Y screen coordinate.
void | setFixedStep (int newStep)
Sets a fixed step.
void | setNormalStep ()
Removes a fixed step position and goes back to normal.
void | setAnimationType (RPG::AnimationType type)
Sets the animation type.
bool | isMovePossible (int fromX, int fromY, int toX, int toY)
Checks whether a certain move is possible.
std::string | getName ()
Returns the name of the character.
void | move (char *data, int length, bool repeatPattern=false, bool ignoreImpossible=true, int frequency=8)
Moves a character.
void | stop ()
Stops the current movement.
void | doStep (RPG::Direction direction)
Does one step (moves the character one tile into a certain direction)

Public Attributes

EventData * eventData
Pointer to the RPG::EventData of this event.
int | id
ID of the event (zero if not an ordinary event)
bool | enabled
Is the event visible and enabled?
int | mapID
Map ID (only relevant for vehicles which are not supported yet)
int | x
X coordinate (tiles)
int | y
Y coordinate (tiles)
Direction_T direction
Direction for moving (see RPG::Direction)
Facing_T facing
Direction for facing (see RPG::Facing)
int | step
Current step value (see details)
int | transparency
Transparency value, between 0 (completely visible) to 8 (completely invisible)
int | movementFramesLeft
Frames left until movement is completed (see details)
int | frequency
Current movement frequency (1 to 8)
int | originalFrequency
Original movement frequency (use for "Move event" commands with a frequency different from the current one)
Layer_T layer
Layer (below/same level as/above hero, see RPG::Layer)
bool | forbidEventOverlap
true if the event cannot move onto a tile occupied by another event
AnimationType_T animationType
Animation type of the event (see details and RPG::AnimationType)
bool | fixedDirection
Is the facing direction (facing) fixed?
int | speed
Current speed of the character (1 to 6, see also customExactSpeed)
MoveRoute * moveRoute
Current move route (can also be set by "Move Event" commands)
bool | moving
Is the character currently moving?
char | offsetX
Horizontal offset for drawing the event graphic (see details)
char | offsetY
Vertical offset for drawing the event graphic (see offsetX)
char | customExactSpeed
Custom exact speed (see details)
bool | phasing
Is the "phasing mode" on?
int | stepFrameCounter
Internally used, for stepping.
int | stepTimer
Internally used, for stepping (-1 if a fixed step is used, see setFixedStep)
int | frequencyTimer
Internall used, for movement frequency.
DStringPtr charsetFilename
Filename of the current charset.
int | charsetId
ID of the current charset.

Detailed Description

Used for events as subtype of characters.

See also:
RPG::Map::events

Member Function Documentation

bool RPG::Event::doesEventPageExist ( int id )

Checks whether a certain event page exists.

This function may be used to check for a certain event page prior to calling it.

Parameters:
id Event page to check
Returns:
true if the event page exists, false otherwise
void RPG::Character::doStep ( RPG::Direction direction ) [inherited]

Does one step (moves the character one tile into a certain direction)

Parameters:
direction Direction to move into
Warning:
This is an experimental function.
See also:
move
std::string RPG::Character::getName ( ) [inherited]

Returns the name of the character.

This function returns the event name which was set in the event editor or the name of the first actor in the party in case the character is the hero.

Returns:
The name of the character (event or hero name)
int RPG::Character::getScreenX ( ) [inherited]

Returns the current X screen coordinate.

int RPG::Character::getScreenY ( ) [inherited]

Returns the current Y screen coordinate.

bool RPG::Character::isMovePossible | ( | int | fromX,
 |  | int | fromY,
 |  | int | toX,
 |  | int | toY
 | ) |  | [inherited]

Checks whether a certain move is possible.

This function if the character will be able to complete a certain move, taking event layer, forbidEventOverlap, other blocking events and the tileset attributes into account.

Parameters:
fromX | X coordinate (tiles) of the source position
fromY | Y coordinate (tiles) of the source position
toX | X coordinate (tiles) of the destination position
toY | Y coordinate (tiles) of the destination position
Returns:
true if the move is possible, otherwise false
Warning:
This is an experimental function.
void RPG::Character::move | ( | char * | data,
 |  | int | length,
 |  | bool | repeatPattern = false,
 |  | bool | ignoreImpossible = true,
 |  | int | frequency = 8
 | ) |  | [inherited]

Moves a character.

This function will move a character (event or hero) the same way the "Move event" command does.

The data member is a pointer to a char array containing the encoded data. You can find a list of possible movement commands at the RPG::MoveType documentation. For most movement commands, you will just use one byte containing the move type.

Example:

char[] moves = {RPG::MT_MOVE_UP, RPG::MT_MOVE_RIGHT, RPG::MT_MOVE_RIGHT, RPG::MT_TURN_RANDOMLY, RPG::MT_MOVE_FORWARD};
RPG::hero->move(moves, sizeof(moves));

There are, however, a few commands which take parameters: RPG::MT_SWITCH_ON, RPG::MT_SWITCH_OFF, RPG::MT_CHANGE_GRAPHIC and RPG::MT_PLAY_SE. If you want to use these commands, you better use a std::string. You need to add the parameters to the string right after the command byte, using the functions encode(int) for numerical parameters and encode(std::string) for string parameters.

Example:

std::string moves = "";
moves += (char)RPG::MT_MOVE_UP;
moves += (char)RPG::MT_FACE_DOWN;
moves += (char)RPG::MT_PLAY_SE;
moves += RPG::encode("chicken"); // filename
moves += RPG::encode(100); // volume
moves += RPG::encode(100); // speed
moves += RPG::encode(50); // pan
moves += (char)RPG::MT_TURN_AROUND;
RPG::hero->move(moves.c_str(), moves.length());
Parameters:
data | Pointer to the movement data
length | Length of the movement data
repeatPattern | true if the pattern should be repeated until stop is called
ignoreImpossible | Should impossible movements be ignored?
frequency | Frequency of the movement
Note:
RPG::MT_INCREASE_FREQUENCY and RPG::MT_DECREASE_FREQUENCY commands will not take permanent effect after the movement ended unless the movement was started with the same frequency as in the frequency member of the character.
Warning:
This is an experimental function.
See also:
RPG::MoveType
stop
doStep
void RPG::Character::setAnimationType ( RPG::AnimationType type ) [inherited]

Sets the animation type.

This function sets the animationType and fixedDirection members to the correct values.

Parameters:
type New animation type
See also:
animationType
RPG::AnimationType
void RPG::Character::setFixedStep ( int newStep ) [inherited]

Sets a fixed step.

You can use this function to set a fixed step position and keep it until setNormalStep is called.

Parameters:
newStep New step position, for possible values see step
Note:
This is a special feature of the DynRPG Patch.
See also:
setNormalStep
step
void RPG::Character::setNormalStep ( ) [inherited]

Removes a fixed step position and goes back to normal.

See also:
setFixedStep
void RPG::Character::stop ( ) [inherited]

Stops the current movement.

Warning:
This is an experimental function.
See also:
move

Member Data Documentation

AnimationType_T RPG::Character::animationType [inherited]

Animation type of the event (see details and RPG::AnimationType)

This member is used for the animation type as defined in the event editor. However, it does not control whether the facing is locked or not, i.e. if you set it to RPG::ANI_FIXED_GRAPHIC, the event may still not have locked facing. Thus, you should use the setAnimationType function which automatically sets the fixedDirection member to the correct value.

See also:
setAnimationType
RPG::AnimationType
DStringPtr RPG::Character::charsetFilename [inherited]

Filename of the current charset.

int RPG::Character::charsetId [inherited]

ID of the current charset.

char RPG::Character::customExactSpeed [inherited]

Custom exact speed (see details)

You can the speed of a character in a finer way than the normal six speed values provide. One speed unit means 3.75 pixels per second (or 1/16 pixel per frame). For example customExactSpeed = 20 will set the speed to 75 pixels per second (1.25 pixels per frame).

If you set customExactSpeed to 0, the speed which is set in speed will be used.

Note:
This is a special feature of the DynRPG patch.
Direction_T RPG::Character::direction [inherited]

Direction for moving (see RPG::Direction)

bool RPG::Character::enabled [inherited]

Is the event visible and enabled?

EventData* RPG::Event::eventData

Pointer to the RPG::EventData of this event.

Facing_T RPG::Character::facing [inherited]

Direction for facing (see RPG::Facing)

bool RPG::Character::fixedDirection [inherited]

Is the facing direction (facing) fixed?

bool RPG::Character::forbidEventOverlap [inherited]

true if the event cannot move onto a tile occupied by another event

int RPG::Character::frequency [inherited]

Current movement frequency (1 to 8)

int RPG::Character::frequencyTimer [inherited]

Internall used, for movement frequency.

int RPG::Character::id [inherited]

ID of the event (zero if not an ordinary event)

Layer_T RPG::Character::layer [inherited]

Layer (below/same level as/above hero, see RPG::Layer)

int RPG::Character::mapID [inherited]

Map ID (only relevant for vehicles which are not supported yet)

int RPG::Character::movementFramesLeft [inherited]

Frames left until movement is completed (see details)

This value is zero if the movement is completed. Otherwise it means the frames left until it is completed. This value, together with direction, is used to calculate the current screen coordinates.

MoveRoute* RPG::Character::moveRoute [inherited]

Current move route (can also be set by "Move Event" commands)

bool RPG::Character::moving [inherited]

Is the character currently moving?

char RPG::Character::offsetX [inherited]

Horizontal offset for drawing the event graphic (see details)

The offsetX and offsetY members can be used to control the screen coordinates on which the event is drawn. You specify an offset value which will be added to the normal value.

For example, you might set offsetX = 8 and offsetY = -16 - and then the event will always be drawn 8 pixels to the right and 16 pixels higher than it would normally be. This way, you can do a finer movement and even do a "fake" pixel movement.

Note:
This is a special feature of the DynRPG patch.
char RPG::Character::offsetY [inherited]

Vertical offset for drawing the event graphic (see offsetX)

int RPG::Character::originalFrequency [inherited]

Original movement frequency (use for "Move event" commands with a frequency different from the current one)

bool RPG::Character::phasing [inherited]

Is the "phasing mode" on?

int RPG::Character::speed [inherited]

Current speed of the character (1 to 6, see also customExactSpeed)

int RPG::Character::step [inherited]

Current step value (see details)

Possible values:

  • 0: Left
  • 1: Middle
  • 2: Right
  • 3: Middle
int RPG::Character::stepFrameCounter [inherited]

Internally used, for stepping.

int RPG::Character::stepTimer [inherited]

Internally used, for stepping (-1 if a fixed step is used, see setFixedStep)

int RPG::Character::transparency [inherited]

Transparency value, between 0 (completely visible) to 8 (completely invisible)

int RPG::Character::x [inherited]

X coordinate (tiles)

int RPG::Character::y [inherited]

Y coordinate (tiles)

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::Hero Class Reference

  • Hero
Public Member Functions | Public Attributes
RPG::Hero Class Reference

Used for the hero as subtype of characters. More...

Inherits RPG::Character.

List of all members.

Public Member Functions

RPG::HeroControlMode getControlMode ()
Returns the current hero control mode.
void | setControlMode (RPG::HeroControlMode controlMode)
Sets the hero control mode.
int | getScreenX ()
Returns the current X screen coordinate.
int | getScreenY ()
Returns the current Y screen coordinate.
void | setFixedStep (int newStep)
Sets a fixed step.
void | setNormalStep ()
Removes a fixed step position and goes back to normal.
void | setAnimationType (RPG::AnimationType type)
Sets the animation type.
bool | isMovePossible (int fromX, int fromY, int toX, int toY)
Checks whether a certain move is possible.
std::string | getName ()
Returns the name of the character.
void | move (char *data, int length, bool repeatPattern=false, bool ignoreImpossible=true, int frequency=8)
Moves a character.
void | stop ()
Stops the current movement.
void | doStep (RPG::Direction direction)
Does one step (moves the character one tile into a certain direction)

Public Attributes

HeroVehicle vehicle
Tells you whether the hero is in a vehicle at the moment.
int | id
ID of the event (zero if not an ordinary event)
bool | enabled
Is the event visible and enabled?
int | mapID
Map ID (only relevant for vehicles which are not supported yet)
int | x
X coordinate (tiles)
int | y
Y coordinate (tiles)
Direction_T direction
Direction for moving (see RPG::Direction)
Facing_T facing
Direction for facing (see RPG::Facing)
int | step
Current step value (see details)
int | transparency
Transparency value, between 0 (completely visible) to 8 (completely invisible)
int | movementFramesLeft
Frames left until movement is completed (see details)
int | frequency
Current movement frequency (1 to 8)
int | originalFrequency
Original movement frequency (use for "Move event" commands with a frequency different from the current one)
Layer_T layer
Layer (below/same level as/above hero, see RPG::Layer)
bool | forbidEventOverlap
true if the event cannot move onto a tile occupied by another event
AnimationType_T animationType
Animation type of the event (see details and RPG::AnimationType)
bool | fixedDirection
Is the facing direction (facing) fixed?
int | speed
Current speed of the character (1 to 6, see also customExactSpeed)
MoveRoute * moveRoute
Current move route (can also be set by "Move Event" commands)
bool | moving
Is the character currently moving?
char | offsetX
Horizontal offset for drawing the event graphic (see details)
char | offsetY
Vertical offset for drawing the event graphic (see offsetX)
char | customExactSpeed
Custom exact speed (see details)
bool | phasing
Is the "phasing mode" on?
int | stepFrameCounter
Internally used, for stepping.
int | stepTimer
Internally used, for stepping (-1 if a fixed step is used, see setFixedStep)
int | frequencyTimer
Internall used, for movement frequency.
DStringPtr charsetFilename
Filename of the current charset.
int | charsetId
ID of the current charset.

Detailed Description

Used for the hero as subtype of characters.

See also:
RPG::hero

Member Function Documentation

void RPG::Character::doStep ( RPG::Direction direction ) [inherited]

Does one step (moves the character one tile into a certain direction)

Parameters:
direction Direction to move into
Warning:
This is an experimental function.
See also:
move
RPG::HeroControlMode RPG::Hero::getControlMode ( )

Returns the current hero control mode.

Note:
This is a special feature of the DynRPG patch.
Returns:
Current control mode
See also:
setControlMode
std::string RPG::Character::getName ( ) [inherited]

Returns the name of the character.

This function returns the event name which was set in the event editor or the name of the first actor in the party in case the character is the hero.

Returns:
The name of the character (event or hero name)
int RPG::Character::getScreenX ( ) [inherited]

Returns the current X screen coordinate.

int RPG::Character::getScreenY ( ) [inherited]

Returns the current Y screen coordinate.

bool RPG::Character::isMovePossible | ( | int | fromX,
 |  | int | fromY,
 |  | int | toX,
 |  | int | toY
 | ) |  | [inherited]

Checks whether a certain move is possible.

This function if the character will be able to complete a certain move, taking event layer, forbidEventOverlap, other blocking events and the tileset attributes into account.

Parameters:
fromX | X coordinate (tiles) of the source position
fromY | Y coordinate (tiles) of the source position
toX | X coordinate (tiles) of the destination position
toY | Y coordinate (tiles) of the destination position
Returns:
true if the move is possible, otherwise false
Warning:
This is an experimental function.
void RPG::Character::move | ( | char * | data,
 |  | int | length,
 |  | bool | repeatPattern = false,
 |  | bool | ignoreImpossible = true,
 |  | int | frequency = 8
 | ) |  | [inherited]

Moves a character.

This function will move a character (event or hero) the same way the "Move event" command does.

The data member is a pointer to a char array containing the encoded data. You can find a list of possible movement commands at the RPG::MoveType documentation. For most movement commands, you will just use one byte containing the move type.

Example:

char[] moves = {RPG::MT_MOVE_UP, RPG::MT_MOVE_RIGHT, RPG::MT_MOVE_RIGHT, RPG::MT_TURN_RANDOMLY, RPG::MT_MOVE_FORWARD};
RPG::hero->move(moves, sizeof(moves));

There are, however, a few commands which take parameters: RPG::MT_SWITCH_ON, RPG::MT_SWITCH_OFF, RPG::MT_CHANGE_GRAPHIC and RPG::MT_PLAY_SE. If you want to use these commands, you better use a std::string. You need to add the parameters to the string right after the command byte, using the functions encode(int) for numerical parameters and encode(std::string) for string parameters.

Example:

std::string moves = "";
moves += (char)RPG::MT_MOVE_UP;
moves += (char)RPG::MT_FACE_DOWN;
moves += (char)RPG::MT_PLAY_SE;
moves += RPG::encode("chicken"); // filename
moves += RPG::encode(100); // volume
moves += RPG::encode(100); // speed
moves += RPG::encode(50); // pan
moves += (char)RPG::MT_TURN_AROUND;
RPG::hero->move(moves.c_str(), moves.length());
Parameters:
data | Pointer to the movement data
length | Length of the movement data
repeatPattern | true if the pattern should be repeated until stop is called
ignoreImpossible | Should impossible movements be ignored?
frequency | Frequency of the movement
Note:
RPG::MT_INCREASE_FREQUENCY and RPG::MT_DECREASE_FREQUENCY commands will not take permanent effect after the movement ended unless the movement was started with the same frequency as in the frequency member of the character.
Warning:
This is an experimental function.
See also:
RPG::MoveType
stop
doStep
void RPG::Character::setAnimationType ( RPG::AnimationType type ) [inherited]

Sets the animation type.

This function sets the animationType and fixedDirection members to the correct values.

Parameters:
type New animation type
See also:
animationType
RPG::AnimationType
void RPG::Hero::setControlMode ( RPG::HeroControlMode controlMode )

Sets the hero control mode.

Note:
This is a special feature of the DynRPG patch.
Parameters:
controlMode The new control mode
See also:
getControlMode
void RPG::Character::setFixedStep ( int newStep ) [inherited]

Sets a fixed step.

You can use this function to set a fixed step position and keep it until setNormalStep is called.

Parameters:
newStep New step position, for possible values see step
Note:
This is a special feature of the DynRPG Patch.
See also:
setNormalStep
step
void RPG::Character::setNormalStep ( ) [inherited]

Removes a fixed step position and goes back to normal.

See also:
setFixedStep
void RPG::Character::stop ( ) [inherited]

Stops the current movement.

Warning:
This is an experimental function.
See also:
move

Member Data Documentation

AnimationType_T RPG::Character::animationType [inherited]

Animation type of the event (see details and RPG::AnimationType)

This member is used for the animation type as defined in the event editor. However, it does not control whether the facing is locked or not, i.e. if you set it to RPG::ANI_FIXED_GRAPHIC, the event may still not have locked facing. Thus, you should use the setAnimationType function which automatically sets the fixedDirection member to the correct value.

See also:
setAnimationType
RPG::AnimationType
DStringPtr RPG::Character::charsetFilename [inherited]

Filename of the current charset.

int RPG::Character::charsetId [inherited]

ID of the current charset.

char RPG::Character::customExactSpeed [inherited]

Custom exact speed (see details)

You can the speed of a character in a finer way than the normal six speed values provide. One speed unit means 3.75 pixels per second (or 1/16 pixel per frame). For example customExactSpeed = 20 will set the speed to 75 pixels per second (1.25 pixels per frame).

If you set customExactSpeed to 0, the speed which is set in speed will be used.

Note:
This is a special feature of the DynRPG patch.
Direction_T RPG::Character::direction [inherited]

Direction for moving (see RPG::Direction)

bool RPG::Character::enabled [inherited]

Is the event visible and enabled?

Facing_T RPG::Character::facing [inherited]

Direction for facing (see RPG::Facing)

bool RPG::Character::fixedDirection [inherited]

Is the facing direction (facing) fixed?

bool RPG::Character::forbidEventOverlap [inherited]

true if the event cannot move onto a tile occupied by another event

int RPG::Character::frequency [inherited]

Current movement frequency (1 to 8)

int RPG::Character::frequencyTimer [inherited]

Internall used, for movement frequency.

int RPG::Character::id [inherited]

ID of the event (zero if not an ordinary event)

Layer_T RPG::Character::layer [inherited]

Layer (below/same level as/above hero, see RPG::Layer)

int RPG::Character::mapID [inherited]

Map ID (only relevant for vehicles which are not supported yet)

int RPG::Character::movementFramesLeft [inherited]

Frames left until movement is completed (see details)

This value is zero if the movement is completed. Otherwise it means the frames left until it is completed. This value, together with direction, is used to calculate the current screen coordinates.

MoveRoute* RPG::Character::moveRoute [inherited]

Current move route (can also be set by "Move Event" commands)

bool RPG::Character::moving [inherited]

Is the character currently moving?

char RPG::Character::offsetX [inherited]

Horizontal offset for drawing the event graphic (see details)

The offsetX and offsetY members can be used to control the screen coordinates on which the event is drawn. You specify an offset value which will be added to the normal value.

For example, you might set offsetX = 8 and offsetY = -16 - and then the event will always be drawn 8 pixels to the right and 16 pixels higher than it would normally be. This way, you can do a finer movement and even do a "fake" pixel movement.

Note:
This is a special feature of the DynRPG patch.
char RPG::Character::offsetY [inherited]

Vertical offset for drawing the event graphic (see offsetX)

int RPG::Character::originalFrequency [inherited]

Original movement frequency (use for "Move event" commands with a frequency different from the current one)

bool RPG::Character::phasing [inherited]

Is the "phasing mode" on?

int RPG::Character::speed [inherited]

Current speed of the character (1 to 6, see also customExactSpeed)

int RPG::Character::step [inherited]

Current step value (see details)

Possible values:

  • 0: Left
  • 1: Middle
  • 2: Right
  • 3: Middle
int RPG::Character::stepFrameCounter [inherited]

Internally used, for stepping.

int RPG::Character::stepTimer [inherited]

Internally used, for stepping (-1 if a fixed step is used, see setFixedStep)

int RPG::Character::transparency [inherited]

Transparency value, between 0 (completely visible) to 8 (completely invisible)

HeroVehicle RPG::Hero::vehicle

Tells you whether the hero is in a vehicle at the moment.

int RPG::Character::x [inherited]

X coordinate (tiles)

int RPG::Character::y [inherited]

Y coordinate (tiles)

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::DArray< T, base_ > Class Template Reference

  • DArray
Public Member Functions | Public Attributes
RPG::DArray< T, base_ > Class Template Reference

Array class. More...

List of all members.

Public Member Functions

int | base ()
Returns the base of the array (zero in most cases)
T & | operator[] (int index)
Array access operator.
void | resize (int newSize)
Resizes the array.

Public Attributes

int | size
Size of the array.
T * | items
Pointer to array items.

Detailed Description

template<class T = void *, int base_ = 0>
class RPG::DArray< T, base_ >

Array class.

Member Function Documentation

template<class T = void *, int base_ = 0>
int RPG::DArray< T, base_ >::base ( ) [inline]

Returns the base of the array (zero in most cases)

template<class T = void *, int base_ = 0>
T& RPG::DArray< T, base_ >::operator[] ( int index ) [inline]

Array access operator.

Note:
This operator will throw an error if you try to access negative indexes. However, if you use an index which is higher than the current maximum, the array is resized.
template<class T = void *, int base_ = 0>
void RPG::DArray< T, base_ >::resize ( int newSize ) [inline]

Resizes the array.

New elements will be initialized with zero.

Parameters:
newSize The new number of elements in the array

Member Data Documentation

template<class T = void *, int base_ = 0>
T* RPG::DArray< T, base_ >::items

Pointer to array items.

template<class T = void *, int base_ = 0>
int RPG::DArray< T, base_ >::size

Size of the array.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::DBActor Class Reference

  • DBActor
Public Attributes
RPG::DBActor Class Reference

Used for the default data of actors which is defined in the database. More...

List of all members.

Public Attributes

int | id
ID of the actor.
DStringPtr name
Default name.
DStringPtr degree
Default degree.
DStringPtr charsetFilename
Default charset filename.
int | charsetId
Default charset ID.
bool | charsetTransparent
Default charset transparency (see details)
int | minLevel
Minimum level.
int | maxLevel
Maximum level.
bool | allowCriticalHit
Critical hits allows?
int | criticalHitProbability
Probability of a critical hit.
DStringPtr facesetFilename
Default faceset filename.
int | facesetId
Default faceset ID.
bool | twoWeapons
Does the actor use a second weapon instead of the shield?
bool | aiControl
Is the actor controlled by the computer in battle?
bool | lockEquipment
Is the equipment locked?
bool | mightyGuard
Does defending reduce the damage more than usual?
ArrayBaseOne< short, 99 > | maxHp
Array of maximum HP values for each level.
ArrayBaseOne< short, 99 > | maxMp
Array of maximum MP values for each level.
ArrayBaseOne< short, 99 > | attack
Array of attack values for each level.
ArrayBaseOne< short, 99 > | defense
Array of defense values for each level.
ArrayBaseOne< short, 99 > | intelligence
Array of intelligence values for each level.
ArrayBaseOne< short, 99 > | agility
Array of agility values for each level.
int | expPrimary
Primary experience curve parameter.
int | expSecondary
Secondary experience curve parameter.
int | expTertiary
Tertiary experience curve parameter.
short | weaponId
Default weapon ID.
short | shieldId
Default shield ID.
short | armorId
Default armor ID.
short | helmetId
Default helmet ID.
short | accessoryId
Default accessory ID.
int | unarmedBattleAnimationId
Battle animation ID for attacks without weapon.
ActorLearning * skillLearning
Skill learning data (not yet implemented)
int | classId
Default class ID.
int | battleGraphicId
Battle graphic ID.
int | battleCommands [7]
Default battle commands (0 and -1 both mean "no command at this position")

Detailed Description

Used for the default data of actors which is defined in the database.

Note:
The members of this class either mean default values of a property or they are used for properties which aren't supposed to be changed in-game, thus the members won't be saved and loaded automatically (as it is the case with RPG::Actor), but only loaded once at startup.

If you want to access data which could be changed in-game, use the members and methods of RPG::Actor instead.
See also:
RPG::dbActors
RPG::Actor
RPG::actors

Member Data Documentation

short RPG::DBActor::accessoryId

Default accessory ID.

ArrayBaseOne<short, 99> RPG::DBActor::agility

Array of agility values for each level.

bool RPG::DBActor::aiControl

Is the actor controlled by the computer in battle?

bool RPG::DBActor::allowCriticalHit

Critical hits allows?

short RPG::DBActor::armorId

Default armor ID.

ArrayBaseOne<short, 99> RPG::DBActor::attack

Array of attack values for each level.

int RPG::DBActor::battleCommands[7]

Default battle commands (0 and -1 both mean "no command at this position")

int RPG::DBActor::battleGraphicId

Battle graphic ID.

DStringPtr RPG::DBActor::charsetFilename

Default charset filename.

int RPG::DBActor::charsetId

Default charset ID.

bool RPG::DBActor::charsetTransparent

Default charset transparency (see details)

Unlike RPG::Actor::charsetTransparency, this member is a simple boolean value. true means a transparency value of 3 while false means a transparency value of 0.

int RPG::DBActor::classId

Default class ID.

int RPG::DBActor::criticalHitProbability

Probability of a critical hit.

ArrayBaseOne<short, 99> RPG::DBActor::defense

Array of defense values for each level.

DStringPtr RPG::DBActor::degree

Default degree.

int RPG::DBActor::expPrimary

Primary experience curve parameter.

int RPG::DBActor::expSecondary

Secondary experience curve parameter.

int RPG::DBActor::expTertiary

Tertiary experience curve parameter.

DStringPtr RPG::DBActor::facesetFilename

Default faceset filename.

int RPG::DBActor::facesetId

Default faceset ID.

short RPG::DBActor::helmetId

Default helmet ID.

int RPG::DBActor::id

ID of the actor.

ArrayBaseOne<short, 99> RPG::DBActor::intelligence

Array of intelligence values for each level.

bool RPG::DBActor::lockEquipment

Is the equipment locked?

ArrayBaseOne<short, 99> RPG::DBActor::maxHp

Array of maximum HP values for each level.

int RPG::DBActor::maxLevel

Maximum level.

ArrayBaseOne<short, 99> RPG::DBActor::maxMp

Array of maximum MP values for each level.

bool RPG::DBActor::mightyGuard

Does defending reduce the damage more than usual?

int RPG::DBActor::minLevel

Minimum level.

DStringPtr RPG::DBActor::name

Default name.

short RPG::DBActor::shieldId

Default shield ID.

ActorLearning* RPG::DBActor::skillLearning

Skill learning data (not yet implemented)

bool RPG::DBActor::twoWeapons

Does the actor use a second weapon instead of the shield?

int RPG::DBActor::unarmedBattleAnimationId

Battle animation ID for attacks without weapon.

short RPG::DBActor::weaponId

Default weapon ID.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::DBitmap Class Reference

  • DBitmap
Public Member Functions
RPG::DBitmap Class Reference

Wrapper class for windows' HBITMAPs. More...

List of all members.

Public Member Functions

HBITMAP | getHBITMAP ()
Returns the HBITMAP.
HDC | getHDC ()
Returns the HDC.

Detailed Description

Wrapper class for windows' HBITMAPs.

Member Function Documentation

HBITMAP RPG::DBitmap::getHBITMAP ( ) [inline]

Returns the HBITMAP.

HDC RPG::DBitmap::getHDC ( ) [inline]

Returns the HDC.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::DBSystem Class Reference

  • DBSystem
Public Attributes
RPG::DBSystem Class Reference

Used for the default system data which is defined in the database. More...

List of all members.

Public Attributes

DStringPtr titleFilename
Filename of the title screen.
DStringPtr gameOverFilename
Filename of the game over screen.
DStringPtr systemGraphicFilename
Default filename of the system graphic.
Music * titleBGM
Default title screen music.
Music * battleBGM
Default battle music.
Music * victoryBGM
Default victory music.
Music * innBGM
Default inn music.
Music * skiffBGM
Default skiff music.
Music * shipBGM
Default ship music.
Music * airshipBGM
Default airship music.
Music * gameOverBGM
Default game over music.
Sound * cursorSE
Default cursor moving sound.
Sound * decisionSE
Default decision sound.
Sound * cancelSE
Default cancel sound.
Sound * buzzerSE
Default buzzer sound.
Sound * battleStartSE
Default sound played at battle start.
Sound * fleeSE
Default sound played when a battler escapes.
Sound * enemyAttackSE
Default sound played when a monster attacks.
Sound * enemyDamageSE
Default sound played when a monster is damaged.
Sound * heroDamageSE
Default sound played when an actor is damaged.
Sound * evasionSE
Default sound played when an attack is evaded.
Sound * enemyDeathSE
Default sound played when a monster is killed.
Sound * itemSE
Default sound played when an item is used.
Transition_T teleportEraseTrans
Default screen erasing transition on teleport (see RPG::Transition)
Transition_T teleportShowTrans
Default screen showing transition on teleport (see RPG::Transition)
Transition_T battleStartEraseTrans
Default screen erasing transition on battle start (see RPG::Transition)
Transition_T battleStartShowTrans
Default screen showing transition on battle start (see RPG::Transition)
Transition_T battleEndEraseTrans
Default screen erasing transition on battle end (see RPG::Transition)
Transition_T battleEndShowTrans
Default screen showing transition on battle end (see RPG::Translation)
bool systemTiled
Is the window background tiled? (Default value)
SystemFont systemFont
Default system font.

Detailed Description

Used for the default system data which is defined in the database.

Note:
The members of this class either mean default values of a property or they are used for properties which aren't supposed to be changed in-game, thus the members won't be saved and loaded automatically (as it is the case with RPG::System), but only loaded once at startup.

If you want to access data which could be changed in-game, use the members and methods of RPG::System instead.

See also:
RPG::dbSystem
RPG::System
RPG::system

Member Data Documentation

Music* RPG::DBSystem::airshipBGM

Default airship music.

Music* RPG::DBSystem::battleBGM

Default battle music.

Transition_T RPG::DBSystem::battleEndEraseTrans

Default screen erasing transition on battle end (see RPG::Transition)

Transition_T RPG::DBSystem::battleEndShowTrans

Default screen showing transition on battle end (see RPG::Translation)

Transition_T RPG::DBSystem::battleStartEraseTrans

Default screen erasing transition on battle start (see RPG::Transition)

Sound* RPG::DBSystem::battleStartSE

Default sound played at battle start.

Transition_T RPG::DBSystem::battleStartShowTrans

Default screen showing transition on battle start (see RPG::Transition)

Sound* RPG::DBSystem::buzzerSE

Default buzzer sound.

Sound* RPG::DBSystem::cancelSE

Default cancel sound.

Sound* RPG::DBSystem::cursorSE

Default cursor moving sound.

Sound* RPG::DBSystem::decisionSE

Default decision sound.

Sound* RPG::DBSystem::enemyAttackSE

Default sound played when a monster attacks.

Sound* RPG::DBSystem::enemyDamageSE

Default sound played when a monster is damaged.

Sound* RPG::DBSystem::enemyDeathSE

Default sound played when a monster is killed.

Sound* RPG::DBSystem::evasionSE

Default sound played when an attack is evaded.

Sound* RPG::DBSystem::fleeSE

Default sound played when a battler escapes.

Music* RPG::DBSystem::gameOverBGM

Default game over music.

DStringPtr RPG::DBSystem::gameOverFilename

Filename of the game over screen.

Sound* RPG::DBSystem::heroDamageSE

Default sound played when an actor is damaged.

Music* RPG::DBSystem::innBGM

Default inn music.

Sound* RPG::DBSystem::itemSE

Default sound played when an item is used.

Music* RPG::DBSystem::shipBGM

Default ship music.

Music* RPG::DBSystem::skiffBGM

Default skiff music.

SystemFont RPG::DBSystem::systemFont

Default system font.

DStringPtr RPG::DBSystem::systemGraphicFilename

Default filename of the system graphic.

bool RPG::DBSystem::systemTiled

Is the window background tiled? (Default value)

Transition_T RPG::DBSystem::teleportEraseTrans

Default screen erasing transition on teleport (see RPG::Transition)

Transition_T RPG::DBSystem::teleportShowTrans

Default screen showing transition on teleport (see RPG::Transition)

Music* RPG::DBSystem::titleBGM

Default title screen music.

DStringPtr RPG::DBSystem::titleFilename

Filename of the title screen.

Music* RPG::DBSystem::victoryBGM

Default victory music.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::DList< T > Class Template Reference

  • DList
Public Member Functions | Public Attributes
RPG::DList< T > Class Template Reference

Class representing Delphi's TList (read-only for the moment) More...

List of all members.

Public Member Functions

T & | operator[] (int index)
Array access operator which will throw an error on invalid indexes.
T | get (int index)
Array access method which will return 0 on invalid indexes.

Public Attributes

int | count
Number of elements in the list.
T * | items
Pointer to the actual array.

Detailed Description

template<class T = void *>
class RPG::DList< T >

Class representing Delphi's TList (read-only for the moment)

See also:
RPG::DListPtr
RPG::Catalog

Member Function Documentation

template<class T = void *>
T RPG::DList< T >::get ( int index ) [inline]

Array access method which will return 0 on invalid indexes.

template<class T = void *>
T& RPG::DList< T >::operator[] ( int index ) [inline]

Array access operator which will throw an error on invalid indexes.

Member Data Documentation

template<class T = void *>
int RPG::DList< T >::count

Number of elements in the list.

template<class T = void *>
T* RPG::DList< T >::items

Pointer to the actual array.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::DListPtr< T > Class Template Reference

  • DListPtr
Public Member Functions | Public Attributes
RPG::DListPtr< T > Class Template Reference

Wrapper class for RPG::DList pointers (syntactic sugar) More...

List of all members.

Public Member Functions

T & | operator[] (int index)
Array access operator which will throw an error on invalid indexes.
T | get (int index)
Array access method which will return 0 on invalid indexes.

Public Attributes

DList< T > * | list
Actual RPG::DList pointer.

Detailed Description

template<class T = void *>
class RPG::DListPtr< T >

Wrapper class for RPG::DList pointers (syntactic sugar)

Note:
The size of this class equals to sizeof(DList<T> *).
See also:
RPG::DList

Member Function Documentation

template<class T = void *>
T RPG::DListPtr< T >::get ( int index ) [inline]

Array access method which will return 0 on invalid indexes.

template<class T = void *>
T& RPG::DListPtr< T >::operator[] ( int index ) [inline]

Array access operator which will throw an error on invalid indexes.

Member Data Documentation

template<class T = void *>
DList<T>* RPG::DListPtr< T >::list

Actual RPG::DList pointer.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::DString Class Reference

  • DString
Public Member Functions
RPG::DString Class Reference

Helper class representing a Delphi string. More...

List of all members.

Public Member Functions

operator std::string () const
Cast operator returning a std::string (recommended)
operator char * () const
Cast operator returning a char *
int length ()
Returns the length of the string.

Detailed Description

Helper class representing a Delphi string.

This class has no members. It is only "virtual", which means an RPG::DString pointer can be used instead of a char * to be able to access the length information of the string and provide a nice automatic cast to std::string even when there are embedded nulls.

Note:
In most cases, the RPG::DStringPtr class is used instead of an RPG::DString pointer.
Warning:
Please mind the Rules about strings!
See also:
RPG::DStringPtr

Member Function Documentation

int RPG::DString::length ( )

Returns the length of the string.

RPG::DString::operator char * ( ) const

Cast operator returning a char *

RPG::DString::operator std::string ( ) const

Cast operator returning a std::string (recommended)

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::DStringPtr Class Reference

  • DStringPtr
Public Member Functions | Public Attributes
RPG::DStringPtr Class Reference

Mighty wrapper class for RPG::DString pointers, the string class for RPG Maker strings. More...

List of all members.

Public Member Functions

DStringPtr ()
Constructor (intializes the pointer to zero)
DStringPtr (RPG::DStringPtr &s)
Copy constructor.
DStringPtr (std::string s)
Constructor (uses a std::string as template)
~DStringPtr ()
Destructor (deallocates the string when the class is destroyed)
operator std::string ()
Cast operator for std::string (recommended)
operator char * ()
Cast operator for char *
const RPG::DStringPtr & | operator= (std::string rhs)
Assignment operator for std::string (recommended)
const RPG::DStringPtr & | operator= (char *rhs)
Assignment operator for char *
const RPG::DStringPtr & | operator= (const char *rhs)
Assignment operator for const char *
const RPG::DStringPtr & | operator= (RPG::DString *rhs)
Can be used to copy a string by writing newString = oldString.str;
bool | operator== (std::string rhs)
Comparison operator for std::string.
bool | operator== (const char *rhs)
Comparison operator for char *.
bool | operator== (RPG::DStringPtr &rhs)
Comparison oeprator for other RPG::DStringPtr classes.
void | clear ()
Clears the string.
void | assign (char *s, int len)
Assigns the string from a char * which may contain null bytes.
std::string | s_str ()
Explicit conversion function to std::string (recommended)
int | length ()
Returns the length of the string.

Public Attributes

DString * str
Pointer to the actual string data.

Detailed Description

Mighty wrapper class for RPG::DString pointers, the string class for RPG Maker strings.

This class can also be used to assign a Delphi string. The string will then automatically be reallocated if necessary.

Warning:
Please mind the Rules about strings!
See also:
DString

Constructor & Destructor Documentation

RPG::DStringPtr::DStringPtr ( )

Constructor (intializes the pointer to zero)

RPG::DStringPtr::DStringPtr ( RPG::DStringPtr & s )

Copy constructor.

RPG::DStringPtr::DStringPtr ( std::string s )

Constructor (uses a std::string as template)

RPG::DStringPtr::~DStringPtr ( )

Destructor (deallocates the string when the class is destroyed)

Member Function Documentation

void RPG::DStringPtr::assign | ( | char * | s,
 |  | int | len
 | ) |  |

Assigns the string from a char * which may contain null bytes.

void RPG::DStringPtr::clear ( )

Clears the string.

int RPG::DStringPtr::length ( )

Returns the length of the string.

RPG::DStringPtr::operator char * ( )

Cast operator for char *

RPG::DStringPtr::operator std::string ( )

Cast operator for std::string (recommended)

const RPG::DStringPtr& RPG::DStringPtr::operator= ( std::string rhs )

Assignment operator for std::string (recommended)

const RPG::DStringPtr& RPG::DStringPtr::operator= ( char * rhs )

Assignment operator for char *

const RPG::DStringPtr& RPG::DStringPtr::operator= ( const char * rhs )

Assignment operator for const char *

const RPG::DStringPtr& RPG::DStringPtr::operator= ( RPG::DString * rhs )

Can be used to copy a string by writing newString = oldString.str;

bool RPG::DStringPtr::operator== ( std::string rhs )

Comparison operator for std::string.

bool RPG::DStringPtr::operator== ( const char * rhs )

Comparison operator for char *.

bool RPG::DStringPtr::operator== ( RPG::DStringPtr & rhs )

Comparison oeprator for other RPG::DStringPtr classes.

std::string RPG::DStringPtr::s_str ( )

Explicit conversion function to std::string (recommended)

Member Data Documentation

DString* RPG::DStringPtr::str

Pointer to the actual string data.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::EventScriptList Class Reference

  • EventScriptList
Public Attributes
RPG::EventScriptList Class Reference

List of event script lines. More...

List of all members.

Public Attributes

DList< EventScriptLine * > * list
The actual RPG::DList.

Detailed Description

List of event script lines.

Note:
Do not ask me why this class is there, I didn't invent it.

Member Data Documentation

DList<EventScriptLine *>* RPG::EventScriptList::list

The actual RPG::DList.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::EventScriptData Class Reference

  • EventScriptData
Public Member Functions | Public Attributes
RPG::EventScriptData Class Reference

Class used for the event script data of an event. More...

List of all members.

Public Member Functions

RPG::EventScriptLine * | line (int index)
Returns a certain RPG::EventScriptLine.

Public Attributes

EventScriptList * lines
Event script lines.
int | currentLineId
Current line number.

Detailed Description

Class used for the event script data of an event.

Member Function Documentation

RPG::EventScriptLine* RPG::EventScriptData::line ( int index )

Returns a certain RPG::EventScriptLine.

Parameters:
index Line number (zero-based)
Returns:
Event script line pointer

Member Data Documentation

int RPG::EventScriptData::currentLineId

Current line number.

EventScriptList* RPG::EventScriptData::lines

Event script lines.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::EventScriptLine Class Reference

  • EventScriptLine
Public Member Functions | Public Attributes
RPG::EventScriptLine Class Reference

Represents an event script line. More...

List of all members.

Public Member Functions

int | parameter (int index)
Returns an integer parameter (0 if the parameter doesn't exist)

Public Attributes

EventCommand command
The command type.
int | treeDepth
The level of indention (0 for none)
DStringPtr stringParameter
The string parameter.
DArray< int > | parameters
The integer parameters.

Detailed Description

Represents an event script line.

Event script lines can have one string parameter and unlimited integer parameters.

Member Function Documentation

int RPG::EventScriptLine::parameter ( int index )

Returns an integer parameter (0 if the parameter doesn't exist)

Parameters:
index Parameter index (zero-based)
Returns:
The parameter's value or 0 if the parameter doesn't exist

Member Data Documentation

EventCommand RPG::EventScriptLine::command

The command type.

DArray<int> RPG::EventScriptLine::parameters

The integer parameters.

DStringPtr RPG::EventScriptLine::stringParameter

The string parameter.

int RPG::EventScriptLine::treeDepth

The level of indention (0 for none)

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::ColorControl Class Reference

  • ColorControl
Public Attributes
RPG::ColorControl Class Reference

Color effect settings for RPG::Image objects. More...

List of all members.

Public Attributes

Image * parentImage
Pointer to the image to which the color effect belongs.
int | red
Red value (0 to 255)
int | green
Green value (0 to 255)
int | blue
Blue value (0 to 255)
int | chroma
Chroma value (0 to 255)

Detailed Description

Color effect settings for RPG::Image objects.

See also:
RPG::Image

Member Data Documentation

int RPG::ColorControl::blue

Blue value (0 to 255)

int RPG::ColorControl::chroma

Chroma value (0 to 255)

int RPG::ColorControl::green

Green value (0 to 255)

Image* RPG::ColorControl::parentImage

Pointer to the image to which the color effect belongs.

int RPG::ColorControl::red

Red value (0 to 255)

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::Image Class Reference

  • Image
Public Member Functions | Static Public Member Functions | Public Attributes
RPG::Image Class Reference

Used for image buffers (8 bit) More...

List of all members.

Public Member Functions

void | applyPalette ()
Applies palette changes.
unsigned char & | pixel (int x, int y)
Returns a reference to a certain pixel.
void | free ()
Frees the image and sets its size to zero.
void | init (int newWidth, int newHeight)
Clears the image and initializes it to a new size.
void | setPalette (int *newPalette)
Copies a palette to the image and applies it.
void | copy (RPG::Image *image)
Copies an RPG::Image with all its attributes to another.
void | loadFromFile (std::string filename, bool throwErrors=true, bool autoResize=true)
Loads an image from a file.
void | draw (int x, int y, unsigned char *newPixels, int srcWidth, int srcHeight, int srcLineWidth, int maskColor=0)
Copies pixels into the image.
void | draw (int x, int y, RPG::Image *image, int srcX=0, int srcY=0, int srcWidth=-1, int srcHeight=-1, int maskColor=0)
Draws another image (or a part of it) onto the image.
void | clear ()
Clears the image without resizing or freeing it.
void | setSystemPalette ()
Copies the palette from the system (necessary for drawText)
void | drawText (int x, int y, std::string text, int color)
Draws text onto the image.

Static Public Member Functions

static RPG::Image * | create ()
Creates an empty image.
static RPG::Image * | create (int newWidth, int newHeight)
Creates an image with a certain width and height.
static RPG::Image * | create (RPG::Image *templateImage)
Creates a copy of an image.
static void | destroy (RPG::Image *&image)
Destroys an image.

Public Attributes

unsigned char * | pixels
Pointer to direct pixel data (stored from top to bottom)
int | palette [256]
Palette array (24 bit)
short | appliedPalette [256]
Processed palette array (16 bit - do not use directly)
int | width
Width of the image.
int | height
Height of the image.
bool | useMaskColor
If true, color 0 will be used as transparent color.
int | alpha
Alpha value (0 is invisible, 255 is fully visible)
bool | autoResize
If true, the image will automatically resize when loaded from a file.
ColorControl * colorControl1
First color effect.
ColorControl * colorControl2
Second color effect.
int | appliedPaletteBrightness
Brightness for which the appliedPalette was calculated.

Detailed Description

Used for image buffers (8 bit)

This class is the only class of which instances may be created by the plugin developer, using the create and destroy methods. It is used for all kinds of images (8 bit). There are two palette arrays: The palette array is used to store the actual 24-bit colors, and the appliedPalette array is used to store special calculated values corresponding to the current screen brightness. It uses 16-bit colors. The applyPalette method is used to recalculate the appliedPalette values. The appliedPaletteBrightness member stores the brightness value for which the appliedPalette was created. If it doesn't equal to the current screen brightness, the RPG Maker will automatically call applyPalette when the image is drawn.

I know that this is overkill and it would have been easier to draw the images to the screen first and then reduce the brightness of the pixels on the screen, but the RPG Maker decided to do it this way.

Note:
Drawing images to a RPG::Canvas is very slow, as well as the drawText method. Please see the Optimization section!
See also:
RPG::ColorControl
RPG::Canvas
RPG::Canvas::brightness

Member Function Documentation

void RPG::Image::applyPalette ( )

Applies palette changes.

void RPG::Image::clear ( )

Clears the image without resizing or freeing it.

See also:
free
destroy
void RPG::Image::copy ( RPG::Image * image )

Copies an RPG::Image with all its attributes to another.

Instead of *image2 = *image1;, you must use image2->copy(image1);.

Parameters:
image The image to copy (source)
See also:
draw(int, int, Image *, int, int, int, int, int)
create(RPG::Image *)
static RPG::Image* RPG::Image::create ( ) [static]

Creates an empty image.

Returns:
Pointer to the image
See also:
create(int, int)
create(RPG::Image *)
destroy
static RPG::Image* RPG::Image::create | ( | int | newWidth,
 |  | int | newHeight
 | ) |  | [static]

Creates an image with a certain width and height.

Parameters:
newWidth | Width of the new image
newHeight | Height of the new image
Returns:
Pointer to the image
See also:
create()
create(RPG::Image *)
destroy
init
static RPG::Image* RPG::Image::create ( RPG::Image * templateImage ) [static]

Creates a copy of an image.

Parameters:
templateImage Image to copy
Returns:
Pointer to the new image
See also:
create()
create(int, int)
destroy
copy
static void RPG::Image::destroy ( RPG::Image *& image ) [static]

Destroys an image.

Parameters:
image Pointer to the image which should be destroyed
Note:
This function automatically sets the pointer to zero after destroying the image.
See also:
create
free
clear
void RPG::Image::draw | ( | int | x,
 |  | int | y,
 |  | unsigned char * | newPixels,
 |  | int | srcWidth,
 |  | int | srcHeight,
 |  | int | srcLineWidth,
 |  | int | maskColor = 0
 | ) |  |

Copies pixels into the image.

Parameters:
x | X coordinate to start drawing to
y | Y coordinate to start drawing to
newPixels | Pointer to the pixel data to copy
srcWidth | Width of area to copy
srcHeight | Height of the area to copy
srcLineWidth | Width of a pixel row in the source image
maskColor | Color which should be transparent (can also be RPG::MASK_NONE)
Note:
Please also see the Optimization section!
See also:
draw(int, int, RPG::Image *, int, int, int, int, int)
void RPG::Image::draw | ( | int | x,
 |  | int | y,
 |  | RPG::Image * | image,
 |  | int | srcX = 0,
 |  | int | srcY = 0,
 |  | int | srcWidth = -1,
 |  | int | srcHeight = -1,
 |  | int | maskColor = 0
 | ) |  |

Draws another image (or a part of it) onto the image.

This part can be used to blit another image, or a certain part of it. Please keep in mind that this will produce strange results if the other image has a different palette.

Parameters:
x | Upper-left X coordinate at the destination image
y | Upper-left Y coordinate at the destination image
image | Image to draw
srcX | Upper-left X coordinate at the source image
srcY | Upper-left Y coordinate at the source image
srcWidth | Width of the area to copy (defaults to the whole image)
srcHeight | Height of the area to copy (defaults to the whole image)
maskColor | Color which should be transparent (can also be RPG::MASK_NONE)
Note:
Please also see the Optimization section!
See also:
draw(int, int, unsigned char *, int, int, int, int)
void RPG::Image::drawText | ( | int | x,
 |  | int | y,
 |  | std::string | text,
 |  | int | color
 | ) |  |

Draws text onto the image.

This method will draw text onto the image, using the current system font and system graphic. Glyphs (like $A) work too.

Parameters:
x | Upper-left X position
y | Upper-left Y position
text | Text to draw
color | Text color to use (0 to 19)
Precondition:
The image should have the same palette as the system graphic (use setSystemPalette).
Warning:
This method is quite slow. Do not use it too often. Please also read the Optimization section!

In the image, there must be at least 8 pixels of extra space to the right, otherwise it will corrupt memory! The text itself needs 16 pixels vertically and 6 pixels horizontally (per character).
See also:
setSystemPalette
void RPG::Image::free ( )

Frees the image and sets its size to zero.

See also:
init
clear
destroy
void RPG::Image::init | ( | int | newWidth,
 |  | int | newHeight
 | ) |  |

Clears the image and initializes it to a new size.

Parameters:
newWidth | New image width
newHeight | New image height
See also:
free
void RPG::Image::loadFromFile | ( | std::string | filename,
 |  | bool | throwErrors = true,
 |  | bool | autoResize = true
 | ) |  |

Loads an image from a file.

This function will load an image from a BMP, PNG or XYZ file.

Parameters:
filename | Path and filename of the file to load, including folder name and file extension.
throwErrors | If true, an error will be shown when the image doesn't exist, otherwise the image will just be empty.
autoResize | If true, the image will automatically resize to the size of the image in the file.
unsigned char& RPG::Image::pixel | ( | int | x,
 |  | int | y
 | ) |  |

Returns a reference to a certain pixel.

Parameters:
x | X coordinate of the pixel
y | Y coordinate of the pixel
Returns:
Reference to the pixel
void RPG::Image::setPalette ( int * newPalette )

Copies a palette to the image and applies it.

Parameters:
newPalette Pointer to the palette array to copy
See also:
setSystemPalette
copy
void RPG::Image::setSystemPalette ( )

Copies the palette from the system (necessary for drawText)

See also:
drawText
setPalette

Member Data Documentation

int RPG::Image::alpha

Alpha value (0 is invisible, 255 is fully visible)

short RPG::Image::appliedPalette[256]

Processed palette array (16 bit - do not use directly)

int RPG::Image::appliedPaletteBrightness

Brightness for which the appliedPalette was calculated.

bool RPG::Image::autoResize

If true, the image will automatically resize when loaded from a file.

ColorControl* RPG::Image::colorControl1

First color effect.

ColorControl* RPG::Image::colorControl2

Second color effect.

int RPG::Image::height

Height of the image.

int RPG::Image::palette[256]

Palette array (24 bit)

unsigned char* RPG::Image::pixels

Pointer to direct pixel data (stored from top to bottom)

bool RPG::Image::useMaskColor

If true, color 0 will be used as transparent color.

int RPG::Image::width

Width of the image.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::Input Class Reference

  • Input
Public Member Functions | Public Attributes
RPG::Input Class Reference

Used for key input. More...

List of all members.

Public Member Functions

int * | key (RPG::Key keyId)
Provides easy access to the key assignments.
bool | pressed (RPG::Key keyId)
Checks whether a RPG::Key is pressed.
void | update ()
Updates the RPG Maker's internal key cache.

Public Attributes

int | keys [48]
Array of key codes assigned to the different RPG::Key values (part 1)
int | keys2k3 [120]
Array of key codes assigned to the different RPG::Key values (part 2)

Detailed Description

Used for key input.

See also:
RPG::input

Member Function Documentation

int* RPG::Input::key ( RPG::Key keyId )

Provides easy access to the key assignments.

This function returns a pointer to the "block" of 8 key codes in the keys or keys2k3 array which corresponds to the given RPG::Key value. The result should be used with the [] syntax with an index from 0 to 7.

Example:

RPG::input->key(RPG::KEY_DECISION)[3] = VK_TAB;

This example would assign the TAB key as a new decision key (the default decision keys are Enter, Space and Z, indexes 3 to 7 are not assigned by default).

The values used for key assignments are virtual key codes, zero meaning "not assigned".

Parameters:
keyId RPG::Key for which the key codes should be read or changed
Returns:
Pointer to the first key code used for this RPG::Key
See also:
RPG::Key
bool RPG::Input::pressed ( RPG::Key keyId )

Checks whether a RPG::Key is pressed.

This function checks if one of the physical keys asiigned to a RPG::Key is currently held down. This function does not use the RPG Maker's internal key cache.

Parameters:
keyId RPG::Key to check
Returns:
true if the key is pressed, false otherwise
void RPG::Input::update ( )

Updates the RPG Maker's internal key cache.

The RPG Maker uses an internal key cache which is normally updated every frame. This function updates the key cache.

Member Data Documentation

int RPG::Input::keys[48]

Array of key codes assigned to the different RPG::Key values (part 1)

This array contains the key assignments for those key functions which exist both in RPG Maker 2000 and RPG Maker 2003. Use the key method for easy access.

See also:
keys2k3
RPG::Key
key
int RPG::Input::keys2k3[120]

Array of key codes assigned to the different RPG::Key values (part 2)

This array contains the key assignments for those key functions which exist only in RPG Maker 2003. Use the key method for easy access.

See also:
keys
RPG::Key
key
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::Map Class Reference

  • Map
Public Member Functions | Public Attributes
RPG::Map Class Reference

Used for accessing and manipulating the current map environment. More...

List of all members.

Public Member Functions

int | getCameraX ()
Returns the current X position of the camera in pixels (this value means the position of the upper-left screen pixel of the screen on the map)
int | getCameraY ()
Returns the current Y position of the camera in pixels (this value means the position of the upper-left screen pixel of the screen on the map)
void | setCamera (int x, int y)
Sets a new camera position.
void | moveCamera (int offsetX, int offsetY, int speed)
Moves the camera (pixel-exact)
int | getWidth ()
Returns the width of the current map.
int | getHeight ()
Returns the height of the current map.
void | updateEvents ()
Updates the start conditions of events after a change.

Public Attributes

int | cameraSubX
X position of the camera in units of 1/16th of a pixel
int | cameraSubY
Y position of the camera in units of 1/16th of a pixel
Chipset * chipset
Pointer to the map's chipset (not yet implemented)
NamedCatalogPtr< Event * > events
Array of events (use event ID as index)

Detailed Description

Used for accessing and manipulating the current map environment.

See also:
RPG::map

Member Function Documentation

int RPG::Map::getCameraX ( )

Returns the current X position of the camera in pixels (this value means the position of the upper-left screen pixel of the screen on the map)

int RPG::Map::getCameraY ( )

Returns the current Y position of the camera in pixels (this value means the position of the upper-left screen pixel of the screen on the map)

int RPG::Map::getHeight ( )

Returns the height of the current map.

int RPG::Map::getWidth ( )

Returns the width of the current map.

void RPG::Map::moveCamera | ( | int | offsetX,
 |  | int | offsetY,
 |  | int | speed
 | ) |  |

Moves the camera (pixel-exact)

This function can move the camera the specified amount of pixels in the specified speed.

Parameters:
offsetX | Amount of pixels to move horizontally (may also be negative)
offsetY | Amount of pixels to move vertically (may also be negative)
speed | Exact speed, in units of 3.75 pixels per second (1/16 tile per frame)
See also:
RPG::Character::customExactSpeed
void RPG::Map::setCamera | ( | int | x,
 |  | int | y
 | ) |  |

Sets a new camera position.

Parameters:
x | New X position (pixels)
y | New Y position (pixels)
Note:
This method also updates the camera "memory", so that the "Return to origin" function works
void RPG::Map::updateEvents ( )

Updates the start conditions of events after a change.

This function can be used to re-check the start conditions of all events. This is necessary if you modify a switch from DynRPG which is start condition of an event, for example.

Member Data Documentation

int RPG::Map::cameraSubX

X position of the camera in units of 1/16th of a pixel

int RPG::Map::cameraSubY

Y position of the camera in units of 1/16th of a pixel

Chipset* RPG::Map::chipset

Pointer to the map's chipset (not yet implemented)

NamedCatalogPtr<Event *> RPG::Map::events

Array of events (use event ID as index)

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::Monster Class Reference

  • Monster
Public Member Functions | Public Attributes
RPG::Monster Class Reference

Used for monsters as subtype of battlers. More...

Inherits RPG::Battler.

List of all members.

Public Member Functions

std::string | getName ()
Returns the name of the actor or monster.
int | getMaxHp ()
Returns the maximal HP.
int | getMaxMp ()
Returns the maximal MP.
int | getAttack ()
Returns the attack value.
int | getDefense ()
Returns the defense value.
int | getIntelligence ()
Returns the intelligence value.
int | getAgility ()
Returns the agility value.
void | setRow (Row newRow)
Sets the current row.
void | damagePopup (int number, int color)
Shows a damage popup with a number.
void | damagePopup (std::string text)
Shows a damage popup with a small text.
bool | isMonster ()
Checks whether the battler is a monster or an actor.
void | flash (int r, int g, int b, int intensity, int duration)
Flashes a battler in a certain color.
bool | executeAction (bool skipPluginHandlers=false)
Executes the action of a battler (highly experimental!)

Public Attributes

int | databaseId
The database ID of the monster.
Image * image
The image of the monster's graphic.
Image * imageMirrored
The mirrored image of the monster's graphic (used when RPG::Battler::mirrored is true)
int | blinkTimer
Frames left until damage blinking is done.
int | id
One-based ID of the battler.
bool | notHidden
false if the battler is currently hidden (but not dead)
Action * action
Current action of the battler.
int | hp
Current HP.
int | mp
Current MP.
DArray< short, 1 > | conditions
Turns elapsed in a certain condition (see details)
int | atbValue
Current value of the ATB bar (0 to 300000 - see details)
bool | mirrored
true if the battler's image is mirrored
int | frameCounter
Internally used.
int | animationId
ID of the battle graphic pose (see details)
int | x
Current X coordinate (centered)
int | y
Current Y coordinate (centered)
int | originalX
Original X coordinate (used when an actor moves to attack)
int | originalY
Original Y coordinate (used when an actor moves to attack)
Row rowAlt
Internally used, I do not understand the difference from row yet.
Row row
Current row (no visible effect on monsters)
int | damagePopupTimer
Frames left until damage popup has finished (zero: no damage popup active)
int | flashR
Red value for flashing the battler (0 to 31)
int | flashG
Green value for flashing the battler (0 to 31)
int | flashB
Blue value for flashing the battler (0 to 31)
double | flashIntensity
Intensity for flashing the battler (0 to 31 - will decrease until flashing is done)
int | flashTimer
Frames left until flashing the battler finished (zero: no flashing active)
int | turnsTaken
Turns taken by this battler.
bool | longAction
true if the last action takes longer (info window needed) - I am not completely sure about that
ActionStatus actionStatus
Status of the current action.
int | displayedConditions [5]
Conditions which will be displayed in the info window (see details)

Detailed Description

Used for monsters as subtype of battlers.

See also:
RPG::monsters
RPG::Battler
RPG::Actor

Member Function Documentation

void RPG::Battler::damagePopup | ( | int | number,
 |  | int | color
 | ) |  | [inherited]

Shows a damage popup with a number.

This function will make a number pop up on a battler.

Parameters:
number | The number to show
color | Color to use (0 to 19)
See also:
damagePopup(std::string)
void RPG::Battler::damagePopup ( std::string text ) [inherited]

Shows a damage popup with a small text.

This function will make a small text pop up on a battler.

Parameters:
text Text to show
Note:
It is not possible to show string popups with a color other than 0.
See also:
damagePopup(int, int)
bool RPG::Battler::executeAction ( bool skipPluginHandlers = false ) [inherited]

Executes the action of a battler (highly experimental!)

This function can be used to execute an action. You need to set the content of the action object before.

Parameters:
skipPluginHandlers If true, no onDoBattlerAction and onBattlerActionDone handlers will be called for this action.
Returns:
true if the action was successfully executed, otherwise false (in this case try again next frame)
Warning:
This is a highly experimental function! During testing, it has repeatedly caused strange errors and crashes when executed under the wrong conditions or to the wrong time! It's probably not safe to use it for anything else than experiments, to be honest.
See also:
RPG::Action
void RPG::Battler::flash | ( | int | r,
 |  | int | g,
 |  | int | b,
 |  | int | intensity,
 |  | int | duration
 | ) |  | [inherited]

Flashes a battler in a certain color.

Parameters:
r | Red value (0 to 31)
g | Green value (0 to 31)
b | Blue value (0 to 31)
intensity | Intensity of the flash (0 to 33.5)
duration | Duration in frames
int RPG::Battler::getAgility ( ) [inherited]

Returns the agility value.

Returns:
Agility value
int RPG::Battler::getAttack ( ) [inherited]

Returns the attack value.

Returns:
Attack value
int RPG::Battler::getDefense ( ) [inherited]

Returns the defense value.

Returns:
Defense value
int RPG::Battler::getIntelligence ( ) [inherited]

Returns the intelligence value.

Returns:
Intelligence value
int RPG::Battler::getMaxHp ( ) [inherited]

Returns the maximal HP.

Returns:
Maximal HP value
int RPG::Battler::getMaxMp ( ) [inherited]

Returns the maximal MP.

Returns:
Maximal MP value
std::string RPG::Battler::getName ( ) [inherited]

Returns the name of the actor or monster.

Returns:
The name
bool RPG::Battler::isMonster ( ) [inherited]

Checks whether the battler is a monster or an actor.

Returns:
true if the battler is a monster, false if it is an actor
void RPG::Battler::setRow ( Row newRow ) [inherited]

Sets the current row.

Parameters:
newRow New row
Note:
This function has no visible effect on monsters

Member Data Documentation

Action* RPG::Battler::action [inherited]

Current action of the battler.

ActionStatus RPG::Battler::actionStatus [inherited]

Status of the current action.

int RPG::Battler::animationId [inherited]

ID of the battle graphic pose (see details)

This member specifies which battle graphic pose is displayed. Look into the "Animations 2" tab of the database to find out what the different values mean (e.g. 6 means "Taking damage").

Note:
This member has no meaning to monsters.
int RPG::Battler::atbValue [inherited]

Current value of the ATB bar (0 to 300000 - see details)

Internally, the ATB bar can have a value between 0 and 300000 where 0 means empty and 300000 means full. If you set a battler's ATB value to a value greater than or equal to 300000, this will trigger his next action (in case of a monster) or open the action window (in case of an actor).

int RPG::Monster::blinkTimer

Frames left until damage blinking is done.

If a monster takes damage, it blinks a few time. The blinking is started by setting blinkTimer to the number of frames the blinking should take. The blinkTimer is then increased by one each frame (while the image will be shown and hidden repeatedly), until it reaches zero at which point the blinking will be stopped.

DArray<short, 1> RPG::Battler::conditions [inherited]

Turns elapsed in a certain condition (see details)

This is an array which has as much possible members as there are conditions in the database. The values tell you how many turns the battler has taken while being affected by a certain conditions. If a value is zero, the particular condition does not affect this battler.

For example, if conditions[2] were 4, this battler would have been infected by poison (by default, condition #2 is poison) for 4 turns. If it were zero, the battler would not be poisoned at the moment.

int RPG::Battler::damagePopupTimer [inherited]

Frames left until damage popup has finished (zero: no damage popup active)

int RPG::Monster::databaseId

The database ID of the monster.

int RPG::Battler::displayedConditions[5] [inherited]

Conditions which will be displayed in the info window (see details)

At target selection, there will be an info window displayed if the target is affected by a condition. The info has five columns for condition names. This array contains the database IDs of the conditions which are displayed in this window. The content of this array will be reset on several occasions. You can change this array in your onDrawBattleStatusWindow handler.

int RPG::Battler::flashB [inherited]

Blue value for flashing the battler (0 to 31)

int RPG::Battler::flashG [inherited]

Green value for flashing the battler (0 to 31)

double RPG::Battler::flashIntensity [inherited]

Intensity for flashing the battler (0 to 31 - will decrease until flashing is done)

Note:
Values over 31 will cause the palette to go crazy. Of course you can also use this as an intentional effect.
int RPG::Battler::flashR [inherited]

Red value for flashing the battler (0 to 31)

int RPG::Battler::flashTimer [inherited]

Frames left until flashing the battler finished (zero: no flashing active)

int RPG::Battler::frameCounter [inherited]

Internally used.

int RPG::Battler::hp [inherited]

Current HP.

int RPG::Battler::id [inherited]

One-based ID of the battler.

For actors this value is the database ID, for monsters it is the party member ID plus one (e.g. RPG::monsters[3]->id should always be 4).

If you want to get the database ID of a monster, you have to use RPG::Monster::databaseId.

Image* RPG::Monster::image

The image of the monster's graphic.

Image* RPG::Monster::imageMirrored

The mirrored image of the monster's graphic (used when RPG::Battler::mirrored is true)

bool RPG::Battler::longAction [inherited]

true if the last action takes longer (info window needed) - I am not completely sure about that

bool RPG::Battler::mirrored [inherited]

true if the battler's image is mirrored

int RPG::Battler::mp [inherited]

Current MP.

bool RPG::Battler::notHidden [inherited]

false if the battler is currently hidden (but not dead)

int RPG::Battler::originalX [inherited]

Original X coordinate (used when an actor moves to attack)

int RPG::Battler::originalY [inherited]

Original Y coordinate (used when an actor moves to attack)

Row RPG::Battler::row [inherited]

Current row (no visible effect on monsters)

Row RPG::Battler::rowAlt [inherited]

Internally used, I do not understand the difference from row yet.

int RPG::Battler::turnsTaken [inherited]

Turns taken by this battler.

int RPG::Battler::x [inherited]

Current X coordinate (centered)

int RPG::Battler::y [inherited]

Current Y coordinate (centered)

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::MoveRoute Class Reference

  • MoveRoute
Public Attributes
RPG::MoveRoute Class Reference

Used for the move route of an character (also set by the "Move Event" command) More...

List of all members.

Public Attributes

DListPtr< MoveRouteItem * > moves
List of movement commands (internal storage, not yet implemented)
DArray< char > | encodedMoves
Encoded movement command list (see RPG::Character::move)
bool | repeatPattern
true if the movement should be repeated until RPG::Character::stop (or "Halt all movement") is called
bool | ignoreImpossible
true if impossible movement commands should be skipped

Detailed Description

Used for the move route of an character (also set by the "Move Event" command)

See also:
RPG::MoveType
RPG::Character::move

Member Data Documentation

DArray<char> RPG::MoveRoute::encodedMoves

Encoded movement command list (see RPG::Character::move)

bool RPG::MoveRoute::ignoreImpossible

true if impossible movement commands should be skipped

DListPtr<MoveRouteItem *> RPG::MoveRoute::moves

List of movement commands (internal storage, not yet implemented)

bool RPG::MoveRoute::repeatPattern

true if the movement should be repeated until RPG::Character::stop (or "Halt all movement") is called

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::Music Class Reference

  • Music
Public Member Functions | Static Public Member Functions | Public Attributes
RPG::Music Class Reference

Used for background music settings. More...

List of all members.

Public Member Functions

Music ()
Simple constructor, creates an (OFF) music item which will stop the music when played.
Music (RPG::Music &ref)
Copy constructor.
Music (std::string filename, int fadeInTime, int volume, int speed, int pan)
Extended constructor, creates a music item based on the given settings.
~Music ()
Destructor.
void | set (RPG::Music &ref)
Sets a music item to the settings of another.
void | play ()
Plays the music.

Static Public Member Functions

static void | stop ()
Stops the current music.
static void | fadeOut (int time)
Fades out the current music.

Public Attributes

DStringPtr filename
Filename.
int | fadeInTime
Time to fade in (in milliseconds)
int | volume
Volume (0 to 100)
int | speed
Speed (100 is normal)
int | pan
Pan (0 to 100, 50 is normal)

Detailed Description

Used for background music settings.

This class is used to store the settings of a background music "item". This class is one of the exceptions to the "do not instantiate" rule, because it may be created and destroyed like any other C++ object. However, RPG::Music pointers in RPG classes still shouldn't be assigned, you have to use the set method instead.

See also:
set
RPG::Sound

Constructor & Destructor Documentation

RPG::Music::Music ( )

Simple constructor, creates an (OFF) music item which will stop the music when played.

RPG::Music::Music ( RPG::Music & ref )

Copy constructor.

Parameters:
ref RPG::Music item to copy
See also:
set
RPG::Music::Music | ( | std::string | filename,
 |  | int | fadeInTime,
 |  | int | volume,
 |  | int | speed,
 |  | int | pan
 | ) |  |

Extended constructor, creates a music item based on the given settings.

Parameters:
filename | Filename
fadeInTime | Time to fade in
volume | Volume
speed | Speed
pan | Pan value
RPG::Music::~Music ( )

Destructor.

Member Function Documentation

static void RPG::Music::fadeOut ( int time ) [static]

Fades out the current music.

Parameters:
time Duration (in milliseconds)
void RPG::Music::play ( )

Plays the music.

void RPG::Music::set ( RPG::Music & ref )

Sets a music item to the settings of another.

This method should be used to "assign" a music item to an RPG::Music pointer in an RPG class.

Example:

RPG::Music newMusic("Boss1", 0, 100, 100, 50);
RPG::system->battleBGM->set(newMusic);
See also:
Music(RPG::Music &)
static void RPG::Music::stop ( ) [static]

Stops the current music.

Member Data Documentation

int RPG::Music::fadeInTime

Time to fade in (in milliseconds)

DStringPtr RPG::Music::filename

Filename.

int RPG::Music::pan

Pan (0 to 100, 50 is normal)

int RPG::Music::speed

Speed (100 is normal)

int RPG::Music::volume

Volume (0 to 100)

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::ParsedCommentParameter Class Reference

  • ParsedCommentParameter
Public Attributes
RPG::ParsedCommentParameter Class Reference

Used for parameters of parsed event comments (see Event comments guidelines) More...

List of all members.

Public Attributes

ParsedCommentParameterType type
Type of the parameter.
double | number
Numerical value (if type is RPG::PARAM_NUMBER)
char | text [200]
Text value (if type is RPG::PARAM_STRING or RPG::PARAM_TOKEN)

Detailed Description

Used for parameters of parsed event comments (see Event comments guidelines)

See also:
RPG::ParsedCommentData

Member Data Documentation

double RPG::ParsedCommentParameter::number

Numerical value (if type is RPG::PARAM_NUMBER)

char RPG::ParsedCommentParameter::text[200]

Text value (if type is RPG::PARAM_STRING or RPG::PARAM_TOKEN)

ParsedCommentParameterType RPG::ParsedCommentParameter::type

Type of the parameter.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::ParsedCommentData Class Reference

  • ParsedCommentData
Public Attributes
RPG::ParsedCommentData Class Reference

Used for parsed event comments (see Event comments guidelines) More...

List of all members.

Public Attributes

char | command [200]
Command name (empty if it's no "special" comment at all)
int | parametersCount
Number of parameters.
ParsedCommentParameter | parameters [100]
Parsed parameters.

Detailed Description

Used for parsed event comments (see Event comments guidelines)

See also:
RPG::ParsedCommentParameter

Member Data Documentation

char RPG::ParsedCommentData::command[200]

Command name (empty if it's no "special" comment at all)

ParsedCommentParameter RPG::ParsedCommentData::parameters[100]

Parsed parameters.

int RPG::ParsedCommentData::parametersCount

Number of parameters.

Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::Picture Class Reference

  • Picture
Public Member Functions | Public Attributes
RPG::Picture Class Reference

Used for in-game pictures. More...

List of all members.

Public Member Functions

void | merge ()
Draws the content of the bottom buffer onto the top buffer and clears the bottom buffer afterwards.
void | show (std::string filename, int x, int y, bool moveWithMap, int magnification, int transparency, int transparency2, bool useMaskColor, int red, int green, int blue, int chroma, RPG::PictureEffect effect, int effectStrength)
Loads and shows a picture.
void | move (int x, int y, int magnification, int transparency, int transparency2, int red, int green, int blue, int chroma, RPG::PictureEffect effect, int effectStrength, int duration)
Initiates a picture movement.
void | erase ()
Erases a picture.
void | update ()
Updates picture movement and effects.
void | draw ()
Draws a picture to the screen, even in different game scenes than the map.

Public Attributes

int | id
Picture ID.
Image * image
RPG::Image buffer of the top half (see class description)
Image * image2
RPG::Image buffer of the bottom half (see class description)
DStringPtr filename
Filename of the picture.
double | originX
X coordinate of original position (changes automatically when "Move with map" is used)
double | originY
Y coordinate of original position (changes automatically when "Move with map" is used)
double | x
Current X coordinate on screen (use std::lround to convert to an integer!)
double | y
Current Y coordinate on screen (use std::lround to convert to an integer!)
bool | moveWithMap
Is "Move with map" active?
double | magnification
Current magnification.
double | transparency
Current transparency for top half.
double | transparency2
Current transparency for bottom half.
bool | useMaskColor
Use a transparent color?
double | red
Current red color effect value.
double | green
Current green color effect value.
double | blue
Current blue color effect value.
double | chroma
Current chroma color effect value.
PictureEffect effect
Current picture effect.
double | effectStrength
Strength of picture effect (see details)
double | targetX
Target X coordinate (if moving)
double | targetY
Target Y coordainte (if moving)
int | targetMagnification
Target magnification (if moving)
int | targetTransparency
Target transparency of the top half (if moving)
int | targetTransparency2
Target transparency of the bottom half (if moving)
int | targetRed
Target red color effect value (if moving)
int | targetGreen
Target green color effect value (if moving)
int | targetBlue
Target blue color effect value (if moving)
int | targetChroma
Target chroma color effect value (if moving)
int | targetEffectStrength
Target picture effect strength (if moving)
int | movementTimer
Number of frames left until movement is completed (zero means not moving)
double | angle
Current picture angle (256 units equal to 360 degree!)

Detailed Description

Used for in-game pictures.

Pictures have two image buffers. The first one (image) is used for the top half of the image, the second one (image2) is used for the bottom half of the image. When the picture is drawn, the second buffer is drawn on top of the first buffer. I know that this is crazy, but it's the way the people from Enterbrain decided to do it to allow two different transparency values (a feature which, in my opinion, is also crazy and useless). Because this is impractical for plugin developers, there is a method called merge which will draw the content of the bottom buffer on top of the top buffer and clear the bottom buffer afterwards. You may still put your own stuff into the image2 buffer, it will be shown on top of image, but please remember that when the game is loaded, the RPG Maker splits the picture again. As a "marker" that the image is already merged (so that you don't have to do it every frame), you might change a palette entry of the bottom image.

See also:
RPG::pictures
RPG::Image
RPG::PictureEffect

Member Function Documentation

void RPG::Picture::draw ( )

Draws a picture to the screen, even in different game scenes than the map.

void RPG::Picture::erase ( )

Erases a picture.

Warning:
This is an experimental function.
void RPG::Picture::merge ( )

Draws the content of the bottom buffer onto the top buffer and clears the bottom buffer afterwards.

void RPG::Picture::move | ( | int | x,
 |  | int | y,
 |  | int | magnification,
 |  | int | transparency,
 |  | int | transparency2,
 |  | int | red,
 |  | int | green,
 |  | int | blue,
 |  | int | chroma,
 |  | RPG::PictureEffect | effect,
 |  | int | effectStrength,
 |  | int | duration
 | ) |  |

Initiates a picture movement.

Parameters:
x | Target X position
y | Target Y position
magnification | Target magnification
transparency | Target top half transparency
transparency2 | Target bottom half transparency
red | Target red color effect value
green | Target green color effect value
blue | Target blue color effect value
chroma | Target chroma color effect value
effect | New picture effect
effectStrength | Target picture effect strength
duration | Duration of the movement in frames
Warning:
This is an experimental function.
void RPG::Picture::show | ( | std::string | filename,
 |  | int | x,
 |  | int | y,
 |  | bool | moveWithMap,
 |  | int | magnification,
 |  | int | transparency,
 |  | int | transparency2,
 |  | bool | useMaskColor,
 |  | int | red,
 |  | int | green,
 |  | int | blue,
 |  | int | chroma,
 |  | RPG::PictureEffect | effect,
 |  | int | effectStrength
 | ) |  |

Loads and shows a picture.

Parameters:
filename | Filename
x | X position
y | Y position
moveWithMap | "Move with map" active?
magnification | Magnification
transparency | Top half transparency
transparency2 | Bottom half transparency
useMaskColor | Use a transparent color?
red | Red color effect value
green | Target green color effect value
blue | Blue color effect value
chroma | Chroma color effect value
effect | Picture effect
effectStrength | Picture effect strength
Warning:
This is an experimental function.
void RPG::Picture::update ( )

Updates picture movement and effects.

This function can be used to update picture movement and effects even in different game scenes than the map.

Warning:
If this function is called more than once per frame, the movement or animation will be too fast.

Member Data Documentation

double RPG::Picture::angle

Current picture angle (256 units equal to 360 degree!)

double RPG::Picture::blue

Current blue color effect value.

double RPG::Picture::chroma

Current chroma color effect value.

PictureEffect RPG::Picture::effect

Current picture effect.

double RPG::Picture::effectStrength

Strength of picture effect (see details)

For RPG::PFX_ROTATE, negative values will rotate the picture conter-clockwise, while zero will pause the rotation.

DStringPtr RPG::Picture::filename

Filename of the picture.

double RPG::Picture::green

Current green color effect value.

int RPG::Picture::id

Picture ID.

Image* RPG::Picture::image

RPG::Image buffer of the top half (see class description)

Image* RPG::Picture::image2

RPG::Image buffer of the bottom half (see class description)

double RPG::Picture::magnification

Current magnification.

int RPG::Picture::movementTimer

Number of frames left until movement is completed (zero means not moving)

bool RPG::Picture::moveWithMap

Is "Move with map" active?

double RPG::Picture::originX

X coordinate of original position (changes automatically when "Move with map" is used)

double RPG::Picture::originY

Y coordinate of original position (changes automatically when "Move with map" is used)

double RPG::Picture::red

Current red color effect value.

int RPG::Picture::targetBlue

Target blue color effect value (if moving)

int RPG::Picture::targetChroma

Target chroma color effect value (if moving)

int RPG::Picture::targetEffectStrength

Target picture effect strength (if moving)

int RPG::Picture::targetGreen

Target green color effect value (if moving)

int RPG::Picture::targetMagnification

Target magnification (if moving)

int RPG::Picture::targetRed

Target red color effect value (if moving)

int RPG::Picture::targetTransparency

Target transparency of the top half (if moving)

int RPG::Picture::targetTransparency2

Target transparency of the bottom half (if moving)

double RPG::Picture::targetX

Target X coordinate (if moving)

double RPG::Picture::targetY

Target Y coordainte (if moving)

double RPG::Picture::transparency

Current transparency for top half.

double RPG::Picture::transparency2

Current transparency for bottom half.

bool RPG::Picture::useMaskColor

Use a transparent color?

double RPG::Picture::x

Current X coordinate on screen (use std::lround to convert to an integer!)

double RPG::Picture::y

Current Y coordinate on screen (use std::lround to convert to an integer!)


DynRPG: RPG::Screen Class Reference

  • Screen
Public Member Functions | Public Attributes
RPG::Screen Class Reference

Used for the screen, including window properties and FPS. More...

List of all members.

Public Member Functions

HWND | getCanvasHWND ()
Returns the HWND of the window control on which the screen is drawn.
void | setFPS (int fps)
Changes the framerate (and thus the overall speed of the game)
void | update (RPG::Scene scene)
Redraws the screen for a certain scene.

Public Attributes

AuroraDrawMain * auroraDrawMain
Not implemented yet.
bool | fullScreen
Is fullscreen active?
bool | largeWindow
Is the large window (640x480) active?
Canvas * canvas
RPG::Canvas which should be used for drawing on the screen.
double | millisecondsPerFrame
Milliseconds a frame should take.
int | maxFPS
Maximum FPS.

Detailed Description

Used for the screen, including window properties and FPS.

See also:
RPG::screen

Member Function Documentation

HWND RPG::Screen::getCanvasHWND ( )

Returns the HWND of the window control on which the screen is drawn.

Note:
In windowed mode, this is not the window itself, but a child of it.
void RPG::Screen::setFPS ( int fps )

Changes the framerate (and thus the overall speed of the game)

This function changes the speed of the whole game by changing the number of frames rendered per second. The default is 80.

Parameters:
fps New framerate
void RPG::Screen::update ( RPG::Scene scene )

Redraws the screen for a certain scene.

This function completely redraws the screen and uses the drawing method of the specified scene. Normally, you would use the current scene for that. This function will also wait for the next frame without using 100% CPU, so that you can use this function to do something which takes longer than one frame.

Parameters:
scene Scene to draw

Member Data Documentation

AuroraDrawMain* RPG::Screen::auroraDrawMain

Not implemented yet.

Canvas* RPG::Screen::canvas

RPG::Canvas which should be used for drawing on the screen.

bool RPG::Screen::fullScreen

Is fullscreen active?

bool RPG::Screen::largeWindow

Is the large window (640x480) active?

int RPG::Screen::maxFPS

Maximum FPS.

double RPG::Screen::millisecondsPerFrame

Milliseconds a frame should take.


DynRPG: RPG::Sound Class Reference

  • Sound
Public Member Functions | Static Public Member Functions | Public Attributes
RPG::Sound Class Reference

Used for sound effect settings. More...

List of all members.

Public Member Functions

Sound ()
Simple constructor, creates an (OFF) sound item which will stop all sounds when played.
Sound (RPG::Sound &ref)
Copy constructor.
Sound (std::string filename, int volume, int speed, int pan)
Extended constructor, creates a sound item based on the given settings.
~Sound ()
Destructor.
void | set (RPG::Sound &ref)
Sets a sound item to the settings of another.
void | play ()
Plays the sound.

Static Public Member Functions

static void | stop ()
Stops all sounds.

Public Attributes

DStringPtr filename
Filename.
int | volume
Volume (0 to 100)
int | speed
Speed (100 is normal)
int | pan
Pan (0 to 100, 50 is normal)

Detailed Description

Used for sound effect settings.

This class is used to store the settings of a sound effect "item". This class is one of the exceptions to the "do not instantiate" rule, because it may be created and destroyed like any other C++ object. However, RPG::Sound pointers in RPG classes still shouldn't be assigned, you have to use the set method instead.

See also:
set
RPG::Music

Constructor & Destructor Documentation

RPG::Sound::Sound ( )

Simple constructor, creates an (OFF) sound item which will stop all sounds when played.

RPG::Sound::Sound ( RPG::Sound & ref )

Copy constructor.

Parameters:
ref RPG::Sound item to copy
See also:
set
RPG::Sound::Sound | ( | std::string | filename,
 |  | int | volume,
 |  | int | speed,
 |  | int | pan
 | ) |  |

Extended constructor, creates a sound item based on the given settings.

Parameters:
filename | Filename
volume | Volume
speed | Speed
pan | Pan value
RPG::Sound::~Sound ( )

Destructor.

Member Function Documentation

void RPG::Sound::play ( )

Plays the sound.

void RPG::Sound::set ( RPG::Sound & ref )

Sets a sound item to the settings of another.

This method should be used to "assign" a sound item to an RPG::Sound pointer in an RPG class.

Example:

RPG::Sound newSound("Cursor2", 100, 100, 50);
RPG::system->cursorSE->set(newSound);
See also:
Sound(RPG::Sound &)
static void RPG::Sound::stop ( ) [static]

Stops all sounds.

Member Data Documentation

DStringPtr RPG::Sound::filename

Filename.

int RPG::Sound::pan

Pan (0 to 100, 50 is normal)

int RPG::Sound::speed

Speed (100 is normal)

int RPG::Sound::volume

Volume (0 to 100)


DynRPG: RPG::Switches Class Reference

  • Switches
Public Member Functions
RPG::Switches Class Reference

Provides easy access to in-game switches. More...

List of all members.

Public Member Functions

bool & operator[] (int index)
Array access operator.

Detailed Description

Provides easy access to in-game switches.

You may also use RPG::System::switches, but the RPG::Switches class will also tolerate negative indexes and is less to type.

See also:
RPG::switches

Member Function Documentation

bool& RPG::Switches::operator[] ( int index ) [inline]

Array access operator.


DynRPG: RPG::SystemGraphic Class Reference

  • SystemGraphic
Public Member Functions | Public Attributes
RPG::SystemGraphic Class Reference

Used to store the system and "system2" graphics. More...

List of all members.

Public Member Functions

void loadFont (std::string fontName)
Loads the font used for text drawing.

Public Attributes

Image * systemImage
System image
Image * system2Image
System2 image

Detailed Description

Used to store the system and "system2" graphics.

See also:
RPG::System
RPG::Image::setSystemPalette

Member Function Documentation

void RPG::SystemGraphic::loadFont ( std::string fontName )

Loads the font used for text drawing.

Parameters:
fontName Name of the font
Warning:
This is an experimental function.

Member Data Documentation

Image* RPG::SystemGraphic::system2Image

System2 image

Image* RPG::SystemGraphic::systemImage

System image

Generated on Mon Feb 6 2012 22:24:57 for DynRPG by doxygen 1.7.6.1


DynRPG: RPG::System Class Reference

  • System
Public Member Functions | Public Attributes
RPG::System Class Reference

Used for system data which can change in-game. More...

List of all members.

Public Member Functions

RPG::Music * getTitleBGM ()
Returns the current title screen music.
RPG::Music * getBattleBGM ()
Returns the current battle music.
RPG::Music * getVictoryBGM ()
Returns the current victory music.
RPG::Music * getInnBGM ()
Returns the current inn music.
RPG::Music * getSkiffBGM ()
Returns the current skiff music.
RPG::Music * getShipBGM ()
Returns the current ship music.
RPG::Music * getAirshipBGM ()
Returns the current airship music.
RPG::Music * getGameOverBGM ()
Returns the current game over music.
RPG::Sound * getCursorSE ()
Returns the current cursor sound.
RPG::Sound * getDecisionSE ()
Returns the current decision sound.
RPG::Sound * getCancelSE ()
Returns the current cancel sound.
RPG::Sound * getBuzzerSE ()
Returns the current buzzer sound.
RPG::Sound * getBattleStartSE ()
Returns the current battle start sound.
RPG::Sound * getFleeSE ()
Returns the current escape sound.
RPG::Sound * getEnemyAttackSE ()
Returns the current monster attack sound.
RPG::Sound * getEnemyDamageSE ()
Returns the current monster damage sound.
RPG::Sound * getHeroDamageSE ()
Returns the current actor damage sound.
RPG::Sound * getEvasionSE ()
Returns the current evasion sound.
RPG::Sound * getEnemyDeathSE ()
Returns the current monster death sound.
RPG::Sound * getItemSE ()
Returns the current item sound.
RPG::Transition getTeleportEraseTrans ()
Returns the current teleport screen erasing transition.
RPG::Transition getTeleportShowTrans ()
Returns the current teleport screen showing transition.
RPG::Transition getBattleStartEraseTrans ()
Returns the current battle start screen erasing transition.
RPG::Transition getBattleStartShowTrans ()
Returns the current battle start screen showing transition.
RPG::Transition getBattleEndEraseTrans ()
Returns the current battle end screen erasing transition.
RPG::Transition getBattleEndShowTrans ()
Returns the current battle end screen showing transition.

Public Attributes

Scene_T scene
Current game scene (see RPG::Scene)
int | frameCounter
Internal frame counter (see details!)
DStringPtr systemGraphicFilename
Filename of the system graphic (empty for default)
bool | systemTiled
Is the window background tiled?
SystemFont systemFont
Current system font.
SystemGraphic * systemGraphic
Current system and system2 graphic.
DArray< bool, 1 > | switches
Switches (see also RPG::Switches!)
DArray< int, 1 > | variables
Variables (see also RPG::Variables!)
bool | messageTransparent
Is the message background invisible? (see also RPG::BattleSettings::transparentWindows)
MessagePosition messagePosition
Position of the message.
bool | messageAutoPos
Prevent hero from being overlapped by a message?
bool | messageModal
Should messages pause other event activites?
DStringPtr faceFilename
Filename of the current face.
int | faceID
ID of the sprite in the faceset.
FacePosition facePosition
Position of the face.
bool | faceMirrored
Is the face mirrored?
Image * faceImage
RPG::Image of the face.
bool | messageActive
Is a message active?
bool | musicFade
Is the music fading?
Music * currentBGM
Current background music.
Music * mapBGM
Background music on the map (used to restore music after battle)
Music * memorizedBGM
Memorized music.
Music * titleBGM
Current title screen music (empty for default)
Music * battleBGM
Current battle music (empty for default)
Music * victoryBGM
Current victory music (empty for default)
Music * innBGM
Current inn music (empty for default)
Music * skiffBGM
Current skiff music (empty for default)
Music * shipBGM
Current ship music (empty for default)
Music * airshipBGM
Current airship music (empty for default)
Music * gameOverBGM
Current game over music (empty for default)
Sound * cursorSE
Current cursor sound (empty for default)
Sound * decisionSE
Current decision sound (empty for default)
Sound * cancelSE
Current cancel sound (empty for default)
Sound * buzzerSE
Current buzzer sound (empty for default)
Sound * battleStartSE
Current sound played at battle start (empty for default)
Sound * fleeSE
Current sound played when a battler escapes (empty for default)
Sound * enemyAttackSE
Current sound played when a monster attacks (empty for default)
Sound * enemyDamageSE
Current sound played when a monster is damaged (empty for default)
Sound * heroDamageSE
Current sound played when an actor is damaged (empty for default)
Sound * evasionSE
Current sound played when an attack is evaded (empty for default)
Sound * enemyDeathSE
Current sound played when a monster is killed (empty for default)
Sound * itemSE
Current sound played when an item is used (empty for default)
Transition_T teleportEraseTrans
Current screen erasing transition on teleport (see RPG::Transition)
Transition_T teleportShowTrans
Current screen showing transition on teleport (see RPG::Transition)
Transition_T battleStartEraseTrans
Current screen erasing transition on battle start (see RPG::Transition)
Transition_T battleStartShowTrans
Current screen showing transition on battle start (see RPG::Transition)
Transition_T battleEndEraseTrans
Current screen erasing transition on battle end (see RPG::Transition)
Transition_T battleEndShowTrans
Current screen showing transition on battle end (see RPG::Translation)
bool | teleportAllowed
Are teleport skills allowed?
bool | escapeAllowed
Are escaped skills allowed?
bool | saveAllowed
Is saving allows?
bool | menuAllowed
Is the game menu allowed?
DStringPtr defaultBackdrop
Filename of default backdrop.
int | saveCount
Number of times saved.
ATBMode_T atbMode
ATB mode.

Detailed Description

Used for system data which can change in-game.

Note:
Many things are only stored in this class if they were changed and are now different from the default in the database, thus you should use the getter methods to access these things.
See also:
RPG::system
RPG::DBSystem
RPG::dbSystem

Member Function Documentation

RPG::Music* RPG::System::getAirshipBGM ( )

Returns the current airship music.

RPG::Music* RPG::System::getBattleBGM ( )

Returns the current battle music.

RPG::Transition RPG::System::getBattleEndEraseTrans ( )

Returns the current battle end screen erasing transition.

RPG::Transition RPG::System::getBattleEndShowTrans ( )

Returns the current battle end screen showing transition.

RPG::Transition RPG::System::getBattleStartEraseTrans ( )

Returns the current battle start screen erasing transition.

RPG::Sound* RPG::System::getBattleStartSE ( )

Returns the current battle start sound.

RPG::Transition RPG::System::getBattleStartShowTrans ( )

Returns the current battle start screen showing transition.

RPG::Sound* RPG::System::getBuzzerSE ( )

Returns the current buzzer sound.

RPG::Sound* RPG::System::getCancelSE ( )

Returns the current cancel sound.

RPG::Sound* RPG::System::getCursorSE ( )

Returns the current cursor sound.

RPG::Sound* RPG::System::getDecisionSE ( )

Returns the current decision sound.

RPG::Sound* RPG::System::getEnemyAttackSE ( )

Returns the current monster attack sound.

RPG::Sound* RPG::System::getEnemyDamageSE ( )

Returns the current monster damage sound.

RPG::Sound* RPG::System::getEnemyDeathSE ( )

Returns the current monster death sound.

RPG::Sound* RPG::System::getEvasionSE ( )

Returns the current evasion sound.

RPG::Sound* RPG::System::getFleeSE ( )

Returns the current escape sound.

RPG::Music* RPG::System::getGameOverBGM ( )

Returns the current game over music.

RPG::Sound* RPG::System::getHeroDamageSE ( )

Returns the current actor damage sound.

RPG::Music* RPG::System::getInnBGM ( )

Returns the current inn music.

RPG::Sound* RPG::System::getItemSE ( )

Returns the current item sound.

RPG::Music* RPG::System::getShipBGM ( )

Returns the current ship music.

RPG::Music* RPG::System::getSkiffBGM ( )

Returns the current skiff music.

RPG::Transition RPG::System::getTeleportEraseTrans ( )

Returns the current teleport screen erasing transition.

RPG::Transition RPG::System::getTeleportShowTrans ( )

Returns the current teleport screen showing transition.

RPG::Music* RPG::System::getTitleBGM ( )

Returns the current title screen music.

RPG::Music* RPG::System::getVictoryBGM ( )

Returns the current victory music.

Member Data Documentation

Music* RPG::System::airshipBGM

Current airship music (empty for default)

ATBMode_T RPG::System::atbMode

ATB mode.

Music* RPG::System::battleBGM

Current battle music (empty for default)

Transition_T RPG::System::battleEndEraseTrans

Current screen erasing transition on battle end (see RPG::Transition)

Transition_T RPG::System::battleEndShowTrans

Current screen showing transition on battle end (see RPG::Translation)

Transition_T RPG::System::battleStartEraseTrans

Current screen erasing transition on battle start (see RPG::Transition)

Sound* RPG::System::battleStartSE

Current sound played at battle start (empty for default)

Transition_T RPG::System::battleStartShowTrans

Current screen showing transition on battle start (see RPG::Transition)

Sound* RPG::System::buzzerSE

Current buzzer sound (empty for default)

Sound* RPG::System::cancelSE

Current cancel sound (empty for default)

Music* RPG::System::currentBGM

Current background music.

Sound* RPG::System::cursorSE

Current cursor sound (empty for default)

Sound* RPG::System::decisionSE

Current decision sound (empty for default)

DStringPtr RPG::System::defaultBackdrop

Filename of default backdrop.

Sound* RPG::System::enemyAttackSE

Current sound played when a monster attacks (empty for default)

Sound* RPG::System::enemyDamageSE

Current sound played when a monster is damaged (empty for default)

Sound* RPG::System::enemyDeathSE

Current sound played when a monster is killed (empty for default)

bool RPG::System::escapeAllowed

Are escaped skills allowed?

Sound* RPG::System::evasionSE

Current sound played when an attack is evaded (empty for default)

DStringPtr RPG::System::faceFilename

Filename of the current face.

int RPG::System::faceID

ID of the sprite in the faceset.

Image* RPG::System::faceImage

RPG::Image of the face.

bool RPG::System::faceMirrored

Is the face mirrored?

FacePosition RPG::System::facePosition

Position of the face.

Sound* RPG::System::fleeSE

Current sound played when a battler escapes (empty for default)

int RPG::System::frameCounter

Internal frame counter (see details!)

This frame counter will count every update of the game scene. Please read the onFrame documentation too!

See also:
onFrame
Music* RPG::System::gameOverBGM

Current game over music (empty for default)

Sound* RPG::System::heroDamageSE

Current sound played when an actor is damaged (empty for default)

Music* RPG::System::innBGM

Current inn music (empty for default)

Sound* RPG::System::itemSE

Current sound played when an item is used (empty for default)

Music* RPG::System::mapBGM

Background music on the map (used to restore music after battle)

Music* RPG::System::memorizedBGM

Memorized music.

bool RPG::System::menuAllowed

Is the game menu allowed?

bool RPG::System::messageActive

Is a message active?

bool RPG::System::messageAutoPos

Prevent hero from being overlapped by a message?

bool RPG::System::messageModal

Should messages pause other event activites?

MessagePosition RPG::System::messagePosition

Position of the message.

bool RPG::System::messageTransparent

Is the message background invisible? (see also RPG::BattleSettings::transparentWindows)

bool RPG::System::musicFade

Is the music fading?

bool RPG::System::saveAllowed

Is saving allows?

int RPG::System::saveCount

Number of times saved.

Scene_T RPG::System::scene

Current game scene (see RPG::Scene)

Music* RPG::System::shipBGM

Current ship music (empty for default)

Music* RPG::System::skiffBGM

Current skiff music (empty for default)

DArray<bool, 1> RPG::System::switches

Switches (see also RPG::Switches!)

SystemFont RPG::System::systemFont

Current system font.

SystemGraphic* RPG::System::systemGraphic

Current system and system2 graphic.

DStringPtr RPG::System::systemGraphicFilename

Filename of the system graphic (empty for default)

bool RPG::System::systemTiled

Is the window background tiled?

bool RPG::System::teleportAllowed

Are teleport skills allowed?

Transition_T RPG::System::teleportEraseTrans

Current screen erasing transition on teleport (see RPG::Transition)

Transition_T RPG::System::teleportShowTrans

Current screen showing transition on teleport (see RPG::Transition)

Music* RPG::System::titleBGM

Current title screen music (empty for default)

DArray<int, 1> RPG::System::variables

Variables (see also RPG::Variables!)

Music* RPG::System::victoryBGM

Current victory music (empty for default)


DynRPG: RPG::Variables Class Reference

  • Variables
Public Member Functions | Public Attributes
RPG::Variables Class Reference

Provides easy access to in-game variables. More...

List of all members.

Public Member Functions

int & | operator[] (int index)
Array access operator.

Public Attributes

int | dummy

Detailed Description

Provides easy access to in-game variables.

You may also use RPG::System::variables, but the RPG::Variables class will also tolerate negative indexes and is less to type.

See also:
RPG::variables

Member Function Documentation

int& RPG::Variables::operator[] ( int index ) [inline]

Array access operator.


DynRPG: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
Here is a list of all documented namespace members with links to the namespaces they belong to:

- a -

  • ActionKind : RPG
  • ActionKind_T : RPG
  • ActionStatus : RPG
  • ActorLearning : RPG
  • actors : RPG
  • AK_BASIC : RPG
  • AK_ITEM : RPG
  • AK_NONE : RPG
  • AK_SKILL : RPG
  • AK_TRANSFORM : RPG
  • ANI_FIXED_DIR_NORMAL : RPG
  • ANI_FIXED_DIR_STEPPING : RPG
  • ANI_FIXED_GRAPHIC : RPG
  • ANI_NORMAL : RPG
  • ANI_SPIN_AROUND : RPG
  • ANI_STEPPING : RPG
  • AnimationType : RPG
  • AnimationType_T : RPG
  • AS_FINAL_PHASE : RPG
  • AS_IDLE : RPG
  • AS_WAITING : RPG
  • ATBM_ACTIVE : RPG
  • ATBM_WAIT : RPG
  • ATBMode : RPG
  • ATBMode_T : RPG
  • AuroraDrawMain : RPG

- b -

  • BA_ATTACK : RPG
  • BA_CHANGE_ROW : RPG
  • BA_CHARGE : RPG
  • BA_DEFEND : RPG
  • BA_DOUBLE_ATTACK : RPG
  • BA_ESCAPE : RPG
  • BA_NONE : RPG
  • BA_OBSERVE : RPG
  • BA_SELF_DESTRUCT : RPG
  • BasicAction : RPG
  • BasicAction_T : RPG
  • BattleEventUpdateMode : RPG
  • BattleLayout : RPG
  • BattleLayout_T : RPG
  • battleSettings : RPG
  • battleSpeed : RPG
  • BEUM_AFTER_ACTION : RPG
  • BEUM_BATTLE_START : RPG
  • BEUM_BEFORE_ACTION : RPG
  • BEUM_SWITCH_ACTIVATED : RPG
  • BL_ALTERNATIVE : RPG
  • BL_GAUGE : RPG
  • BL_TRADITIONAL : RPG

- c -

  • Chipset : RPG
  • CONTROL_EVERYTHING : RPG
  • CONTROL_EVERYTHING_EXCEPT_MOVEMENT : RPG
  • CONTROL_NOTHING : RPG

- d -

  • dbActors : RPG
  • dbSystem : RPG
  • DIR_DOWN : RPG
  • DIR_DOWN_LEFT : RPG
  • DIR_DOWN_RIGHT : RPG
  • DIR_LEFT : RPG
  • DIR_RIGHT : RPG
  • DIR_UP : RPG
  • DIR_UP_LEFT : RPG
  • DIR_UP_RIGHT : RPG
  • Direction : RPG
  • Direction_T : RPG

- e -

  • encode() : RPG
  • EVCMD_ADD_LINE_TO_COMMENT : RPG
  • EVCMD_ADD_LINE_TO_MESSAGE : RPG
  • EVCMD_BATTLE_DEFEAT : RPG
  • EVCMD_BATTLE_END : RPG
  • EVCMD_BATTLE_ESCAPE : RPG
  • EVCMD_BATTLE_VICTORY : RPG
  • EVCMD_CALL_COMMON_EVENT : RPG
  • EVCMD_CALL_EVENT : RPG
  • EVCMD_CALL_INN : RPG
  • EVCMD_CALL_SHOP : RPG
  • EVCMD_CHOICE_CASE : RPG
  • EVCMD_CHOICE_END : RPG
  • EVCMD_COMMENT : RPG
  • EVCMD_EMPTY_LINE : RPG
  • EVCMD_END_LOOP : RPG
  • EVCMD_END_OF_EVENT : RPG
  • EVCMD_FORK : RPG
  • EVCMD_FORK_ELSE_CASE : RPG
  • EVCMD_FORK_END : RPG
  • EVCMD_FORK_IN_BATTLE : RPG
  • EVCMD_FORK_IN_BATTLE_ELSE_CASE : RPG
  • EVCMD_FORK_IN_BATTLE_END : RPG
  • EVCMD_INN_CANCEL : RPG
  • EVCMD_INN_END : RPG
  • EVCMD_INN_REST : RPG
  • EVCMD_SHOP_CANCEL : RPG
  • EVCMD_SHOP_END : RPG
  • EVCMD_SHOP_TRANSACTION : RPG
  • EVCMD_SHOW_BATTLE_ANIMATION : RPG
  • EVCMD_SHOW_BATTLE_ANIMATION_IN_BATTLE : RPG
  • EVCMD_SHOW_CHOICE : RPG
  • EVCMD_SHOW_MESSAGE : RPG
  • EVCMD_START_COMBAT : RPG
  • EVCMD_START_LOOP : RPG
  • EventCommand : RPG

- f -

  • FACE_DOWN : RPG
  • FACE_LEFT : RPG
  • FACE_RIGHT : RPG
  • FACE_UP : RPG
  • FACEPOS_LEFT : RPG
  • FACEPOS_RIGHT : RPG
  • FacePosition : RPG
  • Facing : RPG
  • Facing_T : RPG

- g -

  • getConditionName() : RPG
  • getItemDescription() : RPG
  • getItemName() : RPG
  • getSelectedMonsterIndex() : RPG
  • getSkillDescription() : RPG
  • getSkillName() : RPG

- h -

  • hero : RPG
  • HeroControlMode : RPG
  • HeroVehicle : RPG
  • HV_AIRSHIP : RPG
  • HV_NONE : RPG
  • HV_SHIP : RPG
  • HV_SKIFF : RPG

- i -

  • input : RPG
  • isTestPlay : RPG

- k -

  • Key : RPG
  • KEY_CANCEL : RPG
  • KEY_DECISION : RPG
  • KEY_DOWN : RPG
  • KEY_LEFT : RPG
  • KEY_RIGHT : RPG
  • KEY_UP : RPG

- l -

  • Layer : RPG
  • LAYER_ABOVE_HERO : RPG
  • LAYER_BELOW_HERO : RPG
  • LAYER_SAME_LEVEL_AS_HERO : RPG
  • Layer_T : RPG
  • loadConfiguration() : RPG

- m -

  • map : RPG
  • MASK_NONE : RPG
  • MessagePosition : RPG
  • monsters : RPG
  • MoveRouteItem : RPG
  • MoveType : RPG
  • MSGPOS_BOTTOM : RPG
  • MSGPOS_MIDDLE : RPG
  • MSGPOS_TOP : RPG
  • MT_CHANGE_GRAPHIC : RPG
  • MT_PLAY_SE : RPG
  • MT_SWITCH_OFF : RPG
  • MT_SWITCH_ON : RPG

- p -

  • PARAM_NUMBER : RPG
  • PARAM_STRING : RPG
  • PARAM_TOKEN : RPG
  • ParsedCommentParameterType : RPG
  • PFX_NONE : RPG
  • PFX_RIPPLE : RPG
  • PFX_ROTATE : RPG
  • PictureEffect : RPG
  • pictures : RPG

- r -

  • Row : RPG
  • ROW_BACK : RPG
  • ROW_FRONT : RPG

- s -

  • Scene : RPG
  • SCENE_BATTLE : RPG
  • SCENE_DEBUG : RPG
  • SCENE_FILE : RPG
  • SCENE_GAME_OVER : RPG
  • SCENE_MAP : RPG
  • SCENE_MENU : RPG
  • SCENE_NAME : RPG
  • SCENE_SHOP : RPG
  • Scene_T : RPG
  • SCENE_TITLE : RPG
  • screen : RPG
  • switches : RPG
  • SYSF_MSGOTHIC : RPG
  • SYSF_MSMINCHO : RPG
  • system : RPG
  • SystemFont : RPG

- t -

  • Target : RPG
  • TARGET_ACTOR : RPG
  • TARGET_ALL_ACTORS : RPG
  • TARGET_ALL_MONSTERS : RPG
  • TARGET_MONSTER : RPG
  • TARGET_NONE : RPG
  • Target_T : RPG
  • TRANS_DEFAULT : RPG
  • TRANS_NONE : RPG
  • Transition : RPG
  • Transition_T : RPG
  • transparentWindowsEverywhere : RPG

- u -

  • updateBattle() : RPG
  • updateBattleEvents() : RPG

- v -

  • variables : RPG


DynRPG: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • encode() : RPG
  • getConditionName() : RPG
  • getItemDescription() : RPG
  • getItemName() : RPG
  • getSelectedMonsterIndex() : RPG
  • getSkillDescription() : RPG
  • getSkillName() : RPG
  • loadConfiguration() : RPG
  • updateBattle() : RPG
  • updateBattleEvents() : RPG


DynRPG: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • actors : RPG
  • battleSettings : RPG
  • battleSpeed : RPG
  • dbActors : RPG
  • dbSystem : RPG
  • hero : RPG
  • input : RPG
  • isTestPlay : RPG
  • map : RPG
  • monsters : RPG
  • pictures : RPG
  • screen : RPG
  • switches : RPG
  • system : RPG
  • transparentWindowsEverywhere : RPG
  • variables : RPG


DynRPG: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • ActionKind_T : RPG
  • ActorLearning : RPG
  • AnimationType_T : RPG
  • ATBMode_T : RPG
  • AuroraDrawMain : RPG
  • BasicAction_T : RPG
  • BattleLayout_T : RPG
  • Chipset : RPG
  • Direction_T : RPG
  • Facing_T : RPG
  • Layer_T : RPG
  • MoveRouteItem : RPG
  • Scene_T : RPG
  • Target_T : RPG
  • Transition_T : RPG


DynRPG: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • ActionKind : RPG
  • ActionStatus : RPG
  • AnimationType : RPG
  • ATBMode : RPG
  • BasicAction : RPG
  • BattleEventUpdateMode : RPG
  • BattleLayout : RPG
  • Direction : RPG
  • EventCommand : RPG
  • FacePosition : RPG
  • Facing : RPG
  • HeroControlMode : RPG
  • HeroVehicle : RPG
  • Key : RPG
  • Layer : RPG
  • MessagePosition : RPG
  • MoveType : RPG
  • ParsedCommentParameterType : RPG
  • PictureEffect : RPG
  • Row : RPG
  • Scene : RPG
  • SystemFont : RPG
  • Target : RPG
  • Transition : RPG


DynRPG: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • k
  • l
  • m
  • p
  • r
  • s
  • t

- a -

  • AK_BASIC : RPG
  • AK_ITEM : RPG
  • AK_NONE : RPG
  • AK_SKILL : RPG
  • AK_TRANSFORM : RPG
  • ANI_FIXED_DIR_NORMAL : RPG
  • ANI_FIXED_DIR_STEPPING : RPG
  • ANI_FIXED_GRAPHIC : RPG
  • ANI_NORMAL : RPG
  • ANI_SPIN_AROUND : RPG
  • ANI_STEPPING : RPG
  • AS_FINAL_PHASE : RPG
  • AS_IDLE : RPG
  • AS_WAITING : RPG
  • ATBM_ACTIVE : RPG
  • ATBM_WAIT : RPG

- b -

  • BA_ATTACK : RPG
  • BA_CHANGE_ROW : RPG
  • BA_CHARGE : RPG
  • BA_DEFEND : RPG
  • BA_DOUBLE_ATTACK : RPG
  • BA_ESCAPE : RPG
  • BA_NONE : RPG
  • BA_OBSERVE : RPG
  • BA_SELF_DESTRUCT : RPG
  • BEUM_AFTER_ACTION : RPG
  • BEUM_BATTLE_START : RPG
  • BEUM_BEFORE_ACTION : RPG
  • BEUM_SWITCH_ACTIVATED : RPG
  • BL_ALTERNATIVE : RPG
  • BL_GAUGE : RPG
  • BL_TRADITIONAL : RPG

- c -

  • CONTROL_EVERYTHING : RPG
  • CONTROL_EVERYTHING_EXCEPT_MOVEMENT : RPG
  • CONTROL_NOTHING : RPG

- d -

  • DIR_DOWN : RPG
  • DIR_DOWN_LEFT : RPG
  • DIR_DOWN_RIGHT : RPG
  • DIR_LEFT : RPG
  • DIR_RIGHT : RPG
  • DIR_UP : RPG
  • DIR_UP_LEFT : RPG
  • DIR_UP_RIGHT : RPG

- e -

  • EVCMD_ADD_LINE_TO_COMMENT : RPG
  • EVCMD_ADD_LINE_TO_MESSAGE : RPG
  • EVCMD_BATTLE_DEFEAT : RPG
  • EVCMD_BATTLE_END : RPG
  • EVCMD_BATTLE_ESCAPE : RPG
  • EVCMD_BATTLE_VICTORY : RPG
  • EVCMD_CALL_COMMON_EVENT : RPG
  • EVCMD_CALL_EVENT : RPG
  • EVCMD_CALL_INN : RPG
  • EVCMD_CALL_SHOP : RPG
  • EVCMD_CHOICE_CASE : RPG
  • EVCMD_CHOICE_END : RPG
  • EVCMD_COMMENT : RPG
  • EVCMD_EMPTY_LINE : RPG
  • EVCMD_END_LOOP : RPG
  • EVCMD_END_OF_EVENT : RPG
  • EVCMD_FORK : RPG
  • EVCMD_FORK_ELSE_CASE : RPG
  • EVCMD_FORK_END : RPG
  • EVCMD_FORK_IN_BATTLE : RPG
  • EVCMD_FORK_IN_BATTLE_ELSE_CASE : RPG
  • EVCMD_FORK_IN_BATTLE_END : RPG
  • EVCMD_INN_CANCEL : RPG
  • EVCMD_INN_END : RPG
  • EVCMD_INN_REST : RPG
  • EVCMD_SHOP_CANCEL : RPG
  • EVCMD_SHOP_END : RPG
  • EVCMD_SHOP_TRANSACTION : RPG
  • EVCMD_SHOW_BATTLE_ANIMATION : RPG
  • EVCMD_SHOW_BATTLE_ANIMATION_IN_BATTLE : RPG
  • EVCMD_SHOW_CHOICE : RPG
  • EVCMD_SHOW_MESSAGE : RPG
  • EVCMD_START_COMBAT : RPG
  • EVCMD_START_LOOP : RPG

- f -

  • FACE_DOWN : RPG
  • FACE_LEFT : RPG
  • FACE_RIGHT : RPG
  • FACE_UP : RPG
  • FACEPOS_LEFT : RPG
  • FACEPOS_RIGHT : RPG

- h -

  • HV_AIRSHIP : RPG
  • HV_NONE : RPG
  • HV_SHIP : RPG
  • HV_SKIFF : RPG

- k -

  • KEY_CANCEL : RPG
  • KEY_DECISION : RPG
  • KEY_DOWN : RPG
  • KEY_LEFT : RPG
  • KEY_RIGHT : RPG
  • KEY_UP : RPG

- l -

  • LAYER_ABOVE_HERO : RPG
  • LAYER_BELOW_HERO : RPG
  • LAYER_SAME_LEVEL_AS_HERO : RPG

- m -

  • MASK_NONE : RPG
  • MSGPOS_BOTTOM : RPG
  • MSGPOS_MIDDLE : RPG
  • MSGPOS_TOP : RPG
  • MT_CHANGE_GRAPHIC : RPG
  • MT_PLAY_SE : RPG
  • MT_SWITCH_OFF : RPG
  • MT_SWITCH_ON : RPG

- p -

  • PARAM_NUMBER : RPG
  • PARAM_STRING : RPG
  • PARAM_TOKEN : RPG
  • PFX_NONE : RPG
  • PFX_RIPPLE : RPG
  • PFX_ROTATE : RPG

- r -

  • ROW_BACK : RPG
  • ROW_FRONT : RPG

- s -

  • SCENE_BATTLE : RPG
  • SCENE_DEBUG : RPG
  • SCENE_FILE : RPG
  • SCENE_GAME_OVER : RPG
  • SCENE_MAP : RPG
  • SCENE_MENU : RPG
  • SCENE_NAME : RPG
  • SCENE_SHOP : RPG
  • SCENE_TITLE : RPG
  • SYSF_MSGOTHIC : RPG
  • SYSF_MSMINCHO : RPG

- t -

  • TARGET_ACTOR : RPG
  • TARGET_ALL_ACTORS : RPG
  • TARGET_ALL_MONSTERS : RPG
  • TARGET_MONSTER : RPG
  • TARGET_NONE : RPG
  • TRANS_DEFAULT : RPG
  • TRANS_NONE : RPG


DynRPG: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
RPG::Action | Action of a battler (normal attack, skill, escape, etc.), including target
RPG::Actor | Used for the data of actors which can be changed in-game
RPG::ArrayBaseOne< T, size > | Helper class for arrays with base one
RPG::Battler | Used for entities participating in battle, i.e. actors and monsters
RPG::BattleSettings | Used for battle settings (layout, etc.)
RPG::Canvas | Image buffer with 16 bit color depth, used as canvas for multiple 8-bit images
RPG::Catalog< T > | Wrapper class for RPG::DList which doesn't crash if the index is out of bounds
RPG::CatalogPtr< T > | Wrapper class for RPG::Catalog pointers (syntactic sugar)
RPG::Character | Used for movable entities on the map, i.e. events, the hero (and vehicles, but they are not supported yet)
RPG::ColorControl | Color effect settings for RPG::Image objects
RPG::DArray< T, base_ > | Array class
RPG::DBActor | Used for the default data of actors which is defined in the database
RPG::DBitmap | Wrapper class for windows' HBITMAPs
RPG::DBSystem | Used for the default system data which is defined in the database
RPG::DList< T > | Class representing Delphi's TList (read-only for the moment)
RPG::DListPtr< T > | Wrapper class for RPG::DList pointers (syntactic sugar)
RPG::DString | Helper class representing a Delphi string
RPG::DStringPtr | Mighty wrapper class for RPG::DString pointers, the string class for RPG Maker strings
RPG::Event | Used for events as subtype of characters
RPG::EventData | Class used for storing special event data of a character
RPG::EventScriptData | Class used for the event script data of an event
RPG::EventScriptLine | Represents an event script line
RPG::EventScriptList | List of event script lines
RPG::Hero | Used for the hero as subtype of characters
RPG::Image | Used for image buffers (8 bit)
RPG::Input | Used for key input
RPG::Map | Used for accessing and manipulating the current map environment
RPG::Monster | Used for monsters as subtype of battlers
RPG::MoveRoute | Used for the move route of an character (also set by the "Move Event" command)
RPG::Music | Used for background music settings
RPG::NamedCatalog< T > | Class inherited from RPG::Catalog in which elements with non-consecutive IDs are stored without waste of memory (i.e. events on a map)
RPG::NamedCatalogPtr< T > | Wrapper class for RPG::NamedCatalog pointers (syntactic sugar)
RPG::ParsedCommentData | Used for parsed event comments (see Event comments guidelines)
RPG::ParsedCommentParameter | Used for parameters of parsed event comments (see Event comments guidelines)
RPG::Picture | Used for in-game pictures
RPG::Screen | Used for the screen, including window properties and FPS
RPG::Sound | Used for sound effect settings
RPG::Switches | Provides easy access to in-game switches
RPG::System | Used for system data which can change in-game
RPG::SystemGraphic | Used to store the system and "system2" graphics
RPG::Variables | Provides easy access to in-game variables


DynRPG: Class Index

Class Index
A | B | C | D | E | H | I | M | N | P | S | V
A
CatalogPtr (RPG)
E
Input (RPG) ParsedCommentParameter (RPG)
Character (RPG)
M
Picture (RPG)
Action (RPG) ColorControl (RPG) Event (RPG)
S
Actor (RPG)
D
EventData (RPG) Map (RPG)
ArrayBaseOne (RPG) EventScriptData (RPG) Monster (RPG) Screen (RPG)
B
DArray (RPG) EventScriptLine (RPG) MoveRoute (RPG) Sound (RPG)
DBActor (RPG) EventScriptList (RPG) Music (RPG) Switches (RPG)
Battler (RPG) DBitmap (RPG)
H
N
System (RPG)
BattleSettings (RPG) DBSystem (RPG) SystemGraphic (RPG)
C
DList (RPG) Hero (RPG) NamedCatalog (RPG)
V
DListPtr (RPG)
I
NamedCatalogPtr (RPG)
Canvas (RPG) DString (RPG)
P
Variables (RPG)
Catalog (RPG) DStringPtr (RPG) Image (RPG)
ParsedCommentData (RPG)
A | B | C | D | E | H | I | M | N | P | S | V


DynRPG: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
  • RPG::Action
  • RPG::ArrayBaseOne< T, size >
  • RPG::Battler
    • RPG::Actor
    • RPG::Monster
  • RPG::BattleSettings
  • RPG::Canvas
  • RPG::Catalog< T >
    • RPG::NamedCatalog< T >
  • RPG::CatalogPtr< T >
  • RPG::Character
    • RPG::Event
    • RPG::Hero
  • RPG::ColorControl
  • RPG::DArray< T, base_ >
  • RPG::DBActor
  • RPG::DBitmap
  • RPG::DBSystem
  • RPG::DList< T >
  • RPG::DListPtr< T >
  • RPG::DString
  • RPG::DStringPtr
  • RPG::EventData
  • RPG::EventScriptData
  • RPG::EventScriptLine
  • RPG::EventScriptList
  • RPG::Image
  • RPG::Input
  • RPG::Map
  • RPG::MoveRoute
  • RPG::Music
  • RPG::NamedCatalogPtr< T >
  • RPG::ParsedCommentData
  • RPG::ParsedCommentParameter
  • RPG::Picture
  • RPG::Screen
  • RPG::Sound
  • RPG::Switches
  • RPG::System
  • RPG::SystemGraphic
  • RPG::Variables


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • accessoryId : RPG::Actor , RPG::DBActor
  • action : RPG::Battler
  • actionStatus : RPG::Battler
  • agility : RPG::DBActor
  • agilityDiff : RPG::Actor
  • aiControl : RPG::DBActor
  • airshipBGM : RPG::DBSystem , RPG::System
  • allowCriticalHit : RPG::DBActor
  • alpha : RPG::Image
  • angle : RPG::Picture
  • animationId : RPG::Battler
  • animationType : RPG::Character
  • appliedPalette : RPG::Image
  • appliedPaletteBrightness : RPG::Image
  • applyPalette() : RPG::Image
  • armorId : RPG::Actor , RPG::DBActor
  • assign() : RPG::DStringPtr
  • atbMode : RPG::System
  • atbValue : RPG::Battler
  • attack : RPG::DBActor
  • attackDiff : RPG::Actor
  • auroraDrawMain : RPG::Screen
  • autoResize : RPG::Image


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • base() : RPG::DArray< T, base_ >
  • basicActionId : RPG::Action
  • battleBGM : RPG::System , RPG::DBSystem
  • battleCommands : RPG::Actor , RPG::DBActor
  • battleEndEraseTrans : RPG::System , RPG::DBSystem
  • battleEndShowTrans : RPG::DBSystem , RPG::System
  • battleGraphicId : RPG::Actor , RPG::DBActor
  • battleStartEraseTrans : RPG::DBSystem , RPG::System
  • battleStartSE : RPG::System , RPG::DBSystem
  • battleStartShowTrans : RPG::DBSystem , RPG::System
  • bitmap : RPG::Canvas
  • blinkTimer : RPG::Monster
  • blue : RPG::ColorControl , RPG::Picture
  • brightness : RPG::Canvas
  • buzzerSE : RPG::DBSystem , RPG::System


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • cameraSubX : RPG::Map
  • cameraSubY : RPG::Map
  • cancelSE : RPG::System , RPG::DBSystem
  • canvas : RPG::Screen
  • charsetFilename
: RPG::DBActor
, RPG::Actor
, RPG::Character
  • charsetId
: RPG::Actor
, RPG::Character
, RPG::DBActor
  • charsetTransparency : RPG::Actor
  • charsetTransparent : RPG::DBActor
  • chipset : RPG::Map
  • chroma : RPG::Picture , RPG::ColorControl
  • classId : RPG::DBActor
  • clear()
: RPG::DStringPtr
, RPG::Image
  • colorControl1 : RPG::Image
  • colorControl2 : RPG::Image
  • command : RPG::EventScriptLine , RPG::ParsedCommentData
  • conditions : RPG::Battler
  • convert16To24Bit() : RPG::Canvas
  • convert16To32Bit() : RPG::Canvas
  • convert24To16Bit() : RPG::Canvas
  • convert32To16Bit() : RPG::Canvas
  • copy() : RPG::Image
  • count()
: RPG::CatalogPtr< T >
, RPG::NamedCatalogPtr< T >
, RPG::Catalog< T >
, RPG::DList< T >
  • create() : RPG::Image
  • criticalHitProbability : RPG::DBActor
  • currentBGM : RPG::System
  • currentLineId : RPG::EventScriptData
  • cursorSE : RPG::System , RPG::DBSystem
  • customBattleCommands : RPG::Actor
  • customExactSpeed : RPG::Character


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • damagePopup() : RPG::Battler
  • damagePopupTimer : RPG::Battler
  • databaseId : RPG::Monster
  • decisionSE : RPG::DBSystem , RPG::System
  • defaultBackdrop : RPG::System
  • defense : RPG::DBActor
  • defenseDiff : RPG::Actor
  • degree : RPG::Actor , RPG::DBActor
  • destroy() : RPG::Image
  • direction : RPG::Character
  • displayedConditions : RPG::Battler
  • doesEventPageExist() : RPG::Event
  • doStep() : RPG::Character
  • draw()
: RPG::Canvas
, RPG::Image
, RPG::Picture
, RPG::Image
  • drawText() : RPG::Image
  • DStringPtr() : RPG::DStringPtr


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • effect : RPG::Picture
  • effectStrength : RPG::Picture
  • enabled : RPG::Character
  • encodedMoves : RPG::MoveRoute
  • enemyAttackSE : RPG::DBSystem , RPG::System
  • enemyDamageSE : RPG::System , RPG::DBSystem
  • enemyDeathSE : RPG::DBSystem , RPG::System
  • erase() : RPG::Picture
  • escapeAllowed : RPG::System
  • evasionSE : RPG::DBSystem , RPG::System
  • eventData : RPG::Event
  • events : RPG::Map
  • executeAction() : RPG::Battler
  • exp : RPG::Actor
  • expPrimary : RPG::DBActor
  • expSecondary : RPG::DBActor
  • expTertiary : RPG::DBActor


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • faceFilename : RPG::System
  • faceID : RPG::System
  • faceImage : RPG::System
  • faceMirrored : RPG::System
  • facePosition : RPG::System
  • facesetFilename : RPG::Actor , RPG::DBActor
  • facesetId : RPG::Actor , RPG::DBActor
  • facing : RPG::Character
  • fadeInTime : RPG::Music
  • fadeOut() : RPG::Music
  • filename
: RPG::Music
, RPG::Picture
, RPG::Sound
  • fixedDirection : RPG::Character
  • flash() : RPG::Battler
  • flashB : RPG::Battler
  • flashG : RPG::Battler
  • flashIntensity : RPG::Battler
  • flashR : RPG::Battler
  • flashTimer : RPG::Battler
  • fleeSE : RPG::DBSystem , RPG::System
  • forbidEventOverlap : RPG::Character
  • frameCounter : RPG::Battler , RPG::System
  • free() : RPG::Image
  • frequency : RPG::Character
  • frequencyTimer : RPG::Character
  • fullScreen : RPG::Screen


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • gameOverBGM : RPG::DBSystem , RPG::System
  • gameOverFilename : RPG::DBSystem
  • get()
: RPG::Catalog< T >
, RPG::DList< T >
, RPG::DListPtr< T >
, RPG::CatalogPtr< T >
, RPG::NamedCatalog< T >
, RPG::NamedCatalogPtr< T >
  • getAgility() : RPG::Battler
  • getAirshipBGM() : RPG::System
  • getAttack() : RPG::Battler
  • getBattleBGM() : RPG::System
  • getBattleCommand() : RPG::Actor
  • getBattleEndEraseTrans() : RPG::System
  • getBattleEndShowTrans() : RPG::System
  • getBattleGraphicId() : RPG::Actor
  • getBattleStartEraseTrans() : RPG::System
  • getBattleStartSE() : RPG::System
  • getBattleStartShowTrans() : RPG::System
  • getBuzzerSE() : RPG::System
  • getCameraX() : RPG::Map
  • getCameraY() : RPG::Map
  • getCancelSE() : RPG::System
  • getCanvasHWND() : RPG::Screen
  • getCharsetFilename() : RPG::Actor
  • getCharsetId() : RPG::Actor
  • getCharsetTransparency() : RPG::Actor
  • getControlMode() : RPG::Hero
  • getCursorSE() : RPG::System
  • getDecisionSE() : RPG::System
  • getDefense() : RPG::Battler
  • getDegree() : RPG::Actor
  • getEnemyAttackSE() : RPG::System
  • getEnemyDamageSE() : RPG::System
  • getEnemyDeathSE() : RPG::System
  • getEvasionSE() : RPG::System
  • getFacesetFilename() : RPG::Actor
  • getFacesetId() : RPG::Actor
  • getFleeSE() : RPG::System
  • getGameOverBGM() : RPG::System
  • getHBITMAP() : RPG::DBitmap
  • getHDC() : RPG::DBitmap
  • getHeight() : RPG::Map
  • getHeroDamageSE() : RPG::System
  • getInnBGM() : RPG::System
  • getIntelligence() : RPG::Battler
  • getItemSE() : RPG::System
  • getMaxHp() : RPG::Battler
  • getMaxMp() : RPG::Battler
  • getName()
: RPG::Character
, RPG::Battler
  • getScanline() : RPG::Canvas
  • getScreenX() : RPG::Character
  • getScreenY() : RPG::Character
  • getShipBGM() : RPG::System
  • getSkiffBGM() : RPG::System
  • getTeleportEraseTrans() : RPG::System
  • getTeleportShowTrans() : RPG::System
  • getTitleBGM() : RPG::System
  • getVictoryBGM() : RPG::System
  • getWidth() : RPG::Map
  • green : RPG::Picture , RPG::ColorControl


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • height : RPG::Image , RPG::Canvas
  • helmetId : RPG::DBActor , RPG::Actor
  • heroDamageSE : RPG::System , RPG::DBSystem
  • hp : RPG::Battler


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • id
: RPG::Battler
, RPG::Character
, RPG::Picture
, RPG::DBActor
  • ignoreImpossible : RPG::MoveRoute
  • image : RPG::Monster , RPG::Picture
  • image2 : RPG::Picture
  • imageMirrored : RPG::Monster
  • init() : RPG::Image
  • innBGM : RPG::DBSystem , RPG::System
  • intelligence : RPG::DBActor
  • intelligenceDiff : RPG::Actor
  • isMonster() : RPG::Battler
  • isMovePossible() : RPG::Character
  • itemId : RPG::Action
  • items : RPG::DList< T > , RPG::DArray< T, base_ >
  • itemSE : RPG::System , RPG::DBSystem


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • key() : RPG::Input
  • keys : RPG::Input
  • keys2k3 : RPG::Input
  • kind : RPG::Action


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • largeWindow : RPG::Screen
  • largeWindows : RPG::BattleSettings
  • layer : RPG::Character
  • layout : RPG::BattleSettings
  • length()
: RPG::DString
, RPG::DStringPtr
  • level : RPG::Actor
  • line() : RPG::EventScriptData
  • lines : RPG::EventScriptData
  • lineSize : RPG::Canvas
  • list
: RPG::Catalog< T >
, RPG::EventScriptList
, RPG::DListPtr< T >
  • loadFont() : RPG::SystemGraphic
  • loadFromFile() : RPG::Image
  • lockEquipment : RPG::DBActor
  • longAction : RPG::Battler


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • magnification : RPG::Picture
  • mapBGM : RPG::System
  • mapID : RPG::Character
  • maxFPS : RPG::Screen
  • maxHp : RPG::DBActor
  • maxHpDiff : RPG::Actor
  • maxLevel : RPG::DBActor
  • maxMp : RPG::DBActor
  • maxMpDiff : RPG::Actor
  • memorizedBGM : RPG::System
  • menuAllowed : RPG::System
  • merge() : RPG::Picture
  • messageActive : RPG::System
  • messageAutoPos : RPG::System
  • messageModal : RPG::System
  • messagePosition : RPG::System
  • messageTransparent : RPG::System
  • mightyGuard : RPG::DBActor
  • millisecondsPerFrame : RPG::Screen
  • minLevel : RPG::DBActor
  • mirrored : RPG::Battler
  • monsterId : RPG::Action
  • move()
: RPG::Character
, RPG::Picture
  • moveCamera() : RPG::Map
  • movementFramesLeft : RPG::Character
  • movementTimer : RPG::Picture
  • moveRoute : RPG::Character
  • moves : RPG::MoveRoute
  • moveWithMap : RPG::Picture
  • moving : RPG::Character
  • mp : RPG::Battler
  • Music() : RPG::Music
  • musicFade : RPG::System


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • name
: RPG::Actor
, RPG::EventData
, RPG::DBActor
  • notHidden : RPG::Battler
  • number : RPG::ParsedCommentParameter


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • offsetX : RPG::Character
  • offsetY : RPG::Character
  • operator char *() : RPG::DStringPtr , RPG::DString
  • operator std::string()
: RPG::DString
, RPG::DStringPtr
  • operator=() : RPG::DStringPtr
  • operator==() : RPG::DStringPtr
  • operator[]()
: RPG::DArray< T, base_ >
, RPG::Catalog< T >
, RPG::Variables
, RPG::CatalogPtr< T >
, RPG::NamedCatalogPtr< T >
, RPG::Switches
, RPG::DListPtr< T >
, RPG::DList< T >
, RPG::NamedCatalog< T >
, RPG::ArrayBaseOne< T, size >
  • originalFrequency : RPG::Character
  • originalX : RPG::Battler
  • originalY : RPG::Battler
  • originX : RPG::Picture
  • originY : RPG::Picture


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • palette : RPG::Image
  • pan : RPG::Music , RPG::Sound
  • parameter() : RPG::EventScriptLine
  • parameters : RPG::EventScriptLine , RPG::ParsedCommentData
  • parametersCount : RPG::ParsedCommentData
  • parentImage : RPG::ColorControl
  • partyMember() : RPG::Actor
  • phasing : RPG::Character
  • pixel()
: RPG::Canvas
, RPG::Image
  • pixels : RPG::Image
  • play()
: RPG::Sound
, RPG::Music
  • pressed() : RPG::Input
  • ptr : RPG::CatalogPtr< T >


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • red : RPG::ColorControl , RPG::Picture
  • repeatPattern : RPG::MoveRoute
  • resize() : RPG::DArray< T, base_ >
  • row : RPG::Battler
  • rowAlt : RPG::Battler


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • s_str() : RPG::DStringPtr
  • saveAllowed : RPG::System
  • saveCount : RPG::System
  • scene : RPG::System
  • set()
: RPG::Music
, RPG::Sound
  • setAnimationType() : RPG::Character
  • setCamera() : RPG::Map
  • setControlMode() : RPG::Hero
  • setFixedStep() : RPG::Character
  • setFPS() : RPG::Screen
  • setNormalStep() : RPG::Character
  • setPalette() : RPG::Image
  • setRow() : RPG::Battler
  • setSystemPalette() : RPG::Image
  • shieldId : RPG::Actor , RPG::DBActor
  • shipBGM : RPG::DBSystem , RPG::System
  • show() : RPG::Picture
  • size : RPG::DArray< T, base_ >
  • skiffBGM : RPG::DBSystem , RPG::System
  • skillId : RPG::Action
  • skillLearning : RPG::DBActor
  • Sound() : RPG::Sound
  • speed
: RPG::Sound
, RPG::Character
, RPG::Music
  • step : RPG::Character
  • stepFrameCounter : RPG::Character
  • stepTimer : RPG::Character
  • stop()
: RPG::Character
, RPG::Music
, RPG::Sound
  • str : RPG::DStringPtr
  • stringParameter : RPG::EventScriptLine
  • switches : RPG::System
  • system2Image : RPG::SystemGraphic
  • systemFont : RPG::System , RPG::DBSystem
  • systemGraphic : RPG::System
  • systemGraphicFilename : RPG::DBSystem , RPG::System
  • systemImage : RPG::SystemGraphic
  • systemTiled : RPG::System , RPG::DBSystem


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • target : RPG::Action
  • targetBlue : RPG::Picture
  • targetChroma : RPG::Picture
  • targetEffectStrength : RPG::Picture
  • targetGreen : RPG::Picture
  • targetId : RPG::Action
  • targetMagnification : RPG::Picture
  • targetRed : RPG::Picture
  • targetTransparency : RPG::Picture
  • targetTransparency2 : RPG::Picture
  • targetX : RPG::Picture
  • targetY : RPG::Picture
  • teleportAllowed : RPG::System
  • teleportEraseTrans : RPG::DBSystem , RPG::System
  • teleportShowTrans : RPG::DBSystem , RPG::System
  • text : RPG::ParsedCommentParameter
  • titleBGM : RPG::System , RPG::DBSystem
  • titleFilename : RPG::DBSystem
  • transparency : RPG::Picture , RPG::Character
  • transparency2 : RPG::Picture
  • transparentWindows : RPG::BattleSettings
  • treeDepth : RPG::EventScriptLine
  • turnsTaken : RPG::Battler
  • twoWeapons : RPG::DBActor
  • type : RPG::ParsedCommentParameter


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • unarmedBattleAnimationId : RPG::DBActor
  • update()
: RPG::Input
, RPG::Screen
, RPG::Picture
  • updateEvents() : RPG::Map
  • useMaskColor : RPG::Image , RPG::Picture
  • userData1 : RPG::Action
  • userData2 : RPG::Action


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • variables : RPG::System
  • vehicle : RPG::Hero
  • victoryBGM : RPG::System , RPG::DBSystem
  • volume : RPG::Sound , RPG::Music


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • weaponId : RPG::Actor , RPG::DBActor
  • width : RPG::Image , RPG::Canvas


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • x
: RPG::Battler
, RPG::Picture
, RPG::Character
Generated on Mon Feb 6 2012 22:24:57 for DynRPG by doxygen 1.7.6.1


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- y -

  • y
: RPG::Battler
, RPG::Picture
, RPG::Character
Generated on Mon Feb 6 2012 22:24:57 for DynRPG by doxygen 1.7.6.1


DynRPG: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~DStringPtr() : RPG::DStringPtr
  • ~Music() : RPG::Music
  • ~Sound() : RPG::Sound


DynRPG: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • u
  • w
  • ~

- a -

  • applyPalette() : RPG::Image
  • assign() : RPG::DStringPtr

- b -

  • base() : RPG::DArray< T, base_ >

- c -

  • clear()
: RPG::DStringPtr
, RPG::Image
  • convert16To24Bit() : RPG::Canvas
  • convert16To32Bit() : RPG::Canvas
  • convert24To16Bit() : RPG::Canvas
  • convert32To16Bit() : RPG::Canvas
  • copy() : RPG::Image
  • count()
: RPG::Catalog< T >
, RPG::CatalogPtr< T >
, RPG::NamedCatalogPtr< T >
  • create() : RPG::Image

- d -

  • damagePopup() : RPG::Battler
  • destroy() : RPG::Image
  • doesEventPageExist() : RPG::Event
  • doStep() : RPG::Character
  • draw()
: RPG::Image
, RPG::Picture
, RPG::Image
, RPG::Canvas
  • drawText() : RPG::Image
  • DStringPtr() : RPG::DStringPtr

- e -

  • erase() : RPG::Picture
  • executeAction() : RPG::Battler

- f -

  • fadeOut() : RPG::Music
  • flash() : RPG::Battler
  • free() : RPG::Image

- g -

  • get()
: RPG::Catalog< T >
, RPG::CatalogPtr< T >
, RPG::NamedCatalogPtr< T >
, RPG::DList< T >
, RPG::NamedCatalog< T >
, RPG::DListPtr< T >
  • getAgility() : RPG::Battler
  • getAirshipBGM() : RPG::System
  • getAttack() : RPG::Battler
  • getBattleBGM() : RPG::System
  • getBattleCommand() : RPG::Actor
  • getBattleEndEraseTrans() : RPG::System
  • getBattleEndShowTrans() : RPG::System
  • getBattleGraphicId() : RPG::Actor
  • getBattleStartEraseTrans() : RPG::System
  • getBattleStartSE() : RPG::System
  • getBattleStartShowTrans() : RPG::System
  • getBuzzerSE() : RPG::System
  • getCameraX() : RPG::Map
  • getCameraY() : RPG::Map
  • getCancelSE() : RPG::System
  • getCanvasHWND() : RPG::Screen
  • getCharsetFilename() : RPG::Actor
  • getCharsetId() : RPG::Actor
  • getCharsetTransparency() : RPG::Actor
  • getControlMode() : RPG::Hero
  • getCursorSE() : RPG::System
  • getDecisionSE() : RPG::System
  • getDefense() : RPG::Battler
  • getDegree() : RPG::Actor
  • getEnemyAttackSE() : RPG::System
  • getEnemyDamageSE() : RPG::System
  • getEnemyDeathSE() : RPG::System
  • getEvasionSE() : RPG::System
  • getFacesetFilename() : RPG::Actor
  • getFacesetId() : RPG::Actor
  • getFleeSE() : RPG::System
  • getGameOverBGM() : RPG::System
  • getHBITMAP() : RPG::DBitmap
  • getHDC() : RPG::DBitmap
  • getHeight() : RPG::Map
  • getHeroDamageSE() : RPG::System
  • getInnBGM() : RPG::System
  • getIntelligence() : RPG::Battler
  • getItemSE() : RPG::System
  • getMaxHp() : RPG::Battler
  • getMaxMp() : RPG::Battler
  • getName()
: RPG::Character
, RPG::Battler
  • getScanline() : RPG::Canvas
  • getScreenX() : RPG::Character
  • getScreenY() : RPG::Character
  • getShipBGM() : RPG::System
  • getSkiffBGM() : RPG::System
  • getTeleportEraseTrans() : RPG::System
  • getTeleportShowTrans() : RPG::System
  • getTitleBGM() : RPG::System
  • getVictoryBGM() : RPG::System
  • getWidth() : RPG::Map

- h -

  • height() : RPG::Canvas

- i -

  • init() : RPG::Image
  • isMonster() : RPG::Battler
  • isMovePossible() : RPG::Character

- k -

  • key() : RPG::Input

- l -

  • length()
: RPG::DString
, RPG::DStringPtr
  • line() : RPG::EventScriptData
  • loadFont() : RPG::SystemGraphic
  • loadFromFile() : RPG::Image

- m -

  • merge() : RPG::Picture
  • move()
: RPG::Character
, RPG::Picture
  • moveCamera() : RPG::Map
  • Music() : RPG::Music

- o -

  • operator char *() : RPG::DString , RPG::DStringPtr
  • operator std::string()
: RPG::DStringPtr
, RPG::DString
  • operator=() : RPG::DStringPtr
  • operator==() : RPG::DStringPtr
  • operator[]()
: RPG::CatalogPtr< T >
, RPG::DList< T >
, RPG::Switches
, RPG::Variables
, RPG::NamedCatalogPtr< T >
, RPG::DListPtr< T >
, RPG::Catalog< T >
, RPG::DArray< T, base_ >
, RPG::NamedCatalog< T >
, RPG::ArrayBaseOne< T, size >

- p -

  • parameter() : RPG::EventScriptLine
  • partyMember() : RPG::Actor
  • pixel()
: RPG::Image
, RPG::Canvas
  • play()
: RPG::Sound
, RPG::Music
  • pressed() : RPG::Input

- r -

  • resize() : RPG::DArray< T, base_ >

- s -

  • s_str() : RPG::DStringPtr
  • set()
: RPG::Music
, RPG::Sound
  • setAnimationType() : RPG::Character
  • setCamera() : RPG::Map
  • setControlMode() : RPG::Hero
  • setFixedStep() : RPG::Character
  • setFPS() : RPG::Screen
  • setNormalStep() : RPG::Character
  • setPalette() : RPG::Image
  • setRow() : RPG::Battler
  • setSystemPalette() : RPG::Image
  • show() : RPG::Picture
  • Sound() : RPG::Sound
  • stop()
: RPG::Character
, RPG::Music
, RPG::Sound

- u -

  • update()
: RPG::Input
, RPG::Picture
, RPG::Screen
  • updateEvents() : RPG::Map

- w -

  • width() : RPG::Canvas

- ~ -

  • ~DStringPtr() : RPG::DStringPtr
  • ~Music() : RPG::Music
  • ~Sound() : RPG::Sound


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • accessoryId : RPG::Actor , RPG::DBActor
  • action : RPG::Battler
  • actionStatus : RPG::Battler
  • agility : RPG::DBActor
  • agilityDiff : RPG::Actor
  • aiControl : RPG::DBActor
  • airshipBGM : RPG::DBSystem , RPG::System
  • allowCriticalHit : RPG::DBActor
  • alpha : RPG::Image
  • angle : RPG::Picture
  • animationId : RPG::Battler
  • animationType : RPG::Character
  • appliedPalette : RPG::Image
  • appliedPaletteBrightness : RPG::Image
  • armorId : RPG::Actor , RPG::DBActor
  • atbMode : RPG::System
  • atbValue : RPG::Battler
  • attack : RPG::DBActor
  • attackDiff : RPG::Actor
  • auroraDrawMain : RPG::Screen
  • autoResize : RPG::Image


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- b -

  • basicActionId : RPG::Action
  • battleBGM : RPG::DBSystem , RPG::System
  • battleCommands : RPG::Actor , RPG::DBActor
  • battleEndEraseTrans : RPG::DBSystem , RPG::System
  • battleEndShowTrans : RPG::DBSystem , RPG::System
  • battleGraphicId : RPG::Actor , RPG::DBActor
  • battleStartEraseTrans : RPG::DBSystem , RPG::System
  • battleStartSE : RPG::System , RPG::DBSystem
  • battleStartShowTrans : RPG::DBSystem , RPG::System
  • bitmap : RPG::Canvas
  • blinkTimer : RPG::Monster
  • blue : RPG::ColorControl , RPG::Picture
  • brightness : RPG::Canvas
  • buzzerSE : RPG::DBSystem , RPG::System


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- c -

  • cameraSubX : RPG::Map
  • cameraSubY : RPG::Map
  • cancelSE : RPG::System , RPG::DBSystem
  • canvas : RPG::Screen
  • charsetFilename
: RPG::DBActor
, RPG::Actor
, RPG::Character
  • charsetId
: RPG::Actor
, RPG::Character
, RPG::DBActor
  • charsetTransparency : RPG::Actor
  • charsetTransparent : RPG::DBActor
  • chipset : RPG::Map
  • chroma : RPG::Picture , RPG::ColorControl
  • classId : RPG::DBActor
  • colorControl1 : RPG::Image
  • colorControl2 : RPG::Image
  • command : RPG::EventScriptLine , RPG::ParsedCommentData
  • conditions : RPG::Battler
  • count : RPG::DList< T >
  • criticalHitProbability : RPG::DBActor
  • currentBGM : RPG::System
  • currentLineId : RPG::EventScriptData
  • cursorSE : RPG::DBSystem , RPG::System
  • customBattleCommands : RPG::Actor
  • customExactSpeed : RPG::Character


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- d -

  • damagePopupTimer : RPG::Battler
  • databaseId : RPG::Monster
  • decisionSE : RPG::System , RPG::DBSystem
  • defaultBackdrop : RPG::System
  • defense : RPG::DBActor
  • defenseDiff : RPG::Actor
  • degree : RPG::Actor , RPG::DBActor
  • direction : RPG::Character
  • displayedConditions : RPG::Battler


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- e -

  • effect : RPG::Picture
  • effectStrength : RPG::Picture
  • enabled : RPG::Character
  • encodedMoves : RPG::MoveRoute
  • enemyAttackSE : RPG::DBSystem , RPG::System
  • enemyDamageSE : RPG::System , RPG::DBSystem
  • enemyDeathSE : RPG::DBSystem , RPG::System
  • escapeAllowed : RPG::System
  • evasionSE : RPG::System , RPG::DBSystem
  • eventData : RPG::Event
  • events : RPG::Map
  • exp : RPG::Actor
  • expPrimary : RPG::DBActor
  • expSecondary : RPG::DBActor
  • expTertiary : RPG::DBActor


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- f -

  • faceFilename : RPG::System
  • faceID : RPG::System
  • faceImage : RPG::System
  • faceMirrored : RPG::System
  • facePosition : RPG::System
  • facesetFilename : RPG::Actor , RPG::DBActor
  • facesetId : RPG::Actor , RPG::DBActor
  • facing : RPG::Character
  • fadeInTime : RPG::Music
  • filename
: RPG::Music
, RPG::Picture
, RPG::Sound
  • fixedDirection : RPG::Character
  • flashB : RPG::Battler
  • flashG : RPG::Battler
  • flashIntensity : RPG::Battler
  • flashR : RPG::Battler
  • flashTimer : RPG::Battler
  • fleeSE : RPG::DBSystem , RPG::System
  • forbidEventOverlap : RPG::Character
  • frameCounter : RPG::Battler , RPG::System
  • frequency : RPG::Character
  • frequencyTimer : RPG::Character
  • fullScreen : RPG::Screen


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- g -

  • gameOverBGM : RPG::DBSystem , RPG::System
  • gameOverFilename : RPG::DBSystem
  • green : RPG::ColorControl , RPG::Picture


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- h -

  • height : RPG::Image
  • helmetId : RPG::Actor , RPG::DBActor
  • heroDamageSE : RPG::DBSystem , RPG::System
  • hp : RPG::Battler


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- i -

  • id
: RPG::Battler
, RPG::Character
, RPG::Picture
, RPG::DBActor
  • ignoreImpossible : RPG::MoveRoute
  • image : RPG::Monster , RPG::Picture
  • image2 : RPG::Picture
  • imageMirrored : RPG::Monster
  • innBGM : RPG::System , RPG::DBSystem
  • intelligence : RPG::DBActor
  • intelligenceDiff : RPG::Actor
  • itemId : RPG::Action
  • items : RPG::DArray< T, base_ > , RPG::DList< T >
  • itemSE : RPG::System , RPG::DBSystem


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- k -

  • keys : RPG::Input
  • keys2k3 : RPG::Input
  • kind : RPG::Action


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- l -

  • largeWindow : RPG::Screen
  • largeWindows : RPG::BattleSettings
  • layer : RPG::Character
  • layout : RPG::BattleSettings
  • level : RPG::Actor
  • lines : RPG::EventScriptData
  • lineSize : RPG::Canvas
  • list
: RPG::DListPtr< T >
, RPG::EventScriptList
, RPG::Catalog< T >
  • lockEquipment : RPG::DBActor
  • longAction : RPG::Battler


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- m -

  • magnification : RPG::Picture
  • mapBGM : RPG::System
  • mapID : RPG::Character
  • maxFPS : RPG::Screen
  • maxHp : RPG::DBActor
  • maxHpDiff : RPG::Actor
  • maxLevel : RPG::DBActor
  • maxMp : RPG::DBActor
  • maxMpDiff : RPG::Actor
  • memorizedBGM : RPG::System
  • menuAllowed : RPG::System
  • messageActive : RPG::System
  • messageAutoPos : RPG::System
  • messageModal : RPG::System
  • messagePosition : RPG::System
  • messageTransparent : RPG::System
  • mightyGuard : RPG::DBActor
  • millisecondsPerFrame : RPG::Screen
  • minLevel : RPG::DBActor
  • mirrored : RPG::Battler
  • monsterId : RPG::Action
  • movementFramesLeft : RPG::Character
  • movementTimer : RPG::Picture
  • moveRoute : RPG::Character
  • moves : RPG::MoveRoute
  • moveWithMap : RPG::Picture
  • moving : RPG::Character
  • mp : RPG::Battler
  • musicFade : RPG::System


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- n -

  • name
: RPG::Actor
, RPG::EventData
, RPG::DBActor
  • notHidden : RPG::Battler
  • number : RPG::ParsedCommentParameter


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- o -

  • offsetX : RPG::Character
  • offsetY : RPG::Character
  • originalFrequency : RPG::Character
  • originalX : RPG::Battler
  • originalY : RPG::Battler
  • originX : RPG::Picture
  • originY : RPG::Picture


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- p -

  • palette : RPG::Image
  • pan : RPG::Music , RPG::Sound
  • parameters : RPG::EventScriptLine , RPG::ParsedCommentData
  • parametersCount : RPG::ParsedCommentData
  • parentImage : RPG::ColorControl
  • phasing : RPG::Character
  • pixels : RPG::Image
  • ptr : RPG::CatalogPtr< T >


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- r -

  • red : RPG::ColorControl , RPG::Picture
  • repeatPattern : RPG::MoveRoute
  • row : RPG::Battler
  • rowAlt : RPG::Battler


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- s -

  • saveAllowed : RPG::System
  • saveCount : RPG::System
  • scene : RPG::System
  • shieldId : RPG::Actor , RPG::DBActor
  • shipBGM : RPG::DBSystem , RPG::System
  • size : RPG::DArray< T, base_ >
  • skiffBGM : RPG::DBSystem , RPG::System
  • skillId : RPG::Action
  • skillLearning : RPG::DBActor
  • speed
: RPG::Character
, RPG::Music
, RPG::Sound
  • step : RPG::Character
  • stepFrameCounter : RPG::Character
  • stepTimer : RPG::Character
  • str : RPG::DStringPtr
  • stringParameter : RPG::EventScriptLine
  • switches : RPG::System
  • system2Image : RPG::SystemGraphic
  • systemFont : RPG::DBSystem , RPG::System
  • systemGraphic : RPG::System
  • systemGraphicFilename : RPG::System , RPG::DBSystem
  • systemImage : RPG::SystemGraphic
  • systemTiled : RPG::DBSystem , RPG::System


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- t -

  • target : RPG::Action
  • targetBlue : RPG::Picture
  • targetChroma : RPG::Picture
  • targetEffectStrength : RPG::Picture
  • targetGreen : RPG::Picture
  • targetId : RPG::Action
  • targetMagnification : RPG::Picture
  • targetRed : RPG::Picture
  • targetTransparency : RPG::Picture
  • targetTransparency2 : RPG::Picture
  • targetX : RPG::Picture
  • targetY : RPG::Picture
  • teleportAllowed : RPG::System
  • teleportEraseTrans : RPG::DBSystem , RPG::System
  • teleportShowTrans : RPG::DBSystem , RPG::System
  • text : RPG::ParsedCommentParameter
  • titleBGM : RPG::System , RPG::DBSystem
  • titleFilename : RPG::DBSystem
  • transparency : RPG::Picture , RPG::Character
  • transparency2 : RPG::Picture
  • transparentWindows : RPG::BattleSettings
  • treeDepth : RPG::EventScriptLine
  • turnsTaken : RPG::Battler
  • twoWeapons : RPG::DBActor
  • type : RPG::ParsedCommentParameter


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- u -

  • unarmedBattleAnimationId : RPG::DBActor
  • useMaskColor : RPG::Image , RPG::Picture
  • userData1 : RPG::Action
  • userData2 : RPG::Action


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- v -

  • variables : RPG::System
  • vehicle : RPG::Hero
  • victoryBGM : RPG::System , RPG::DBSystem
  • volume : RPG::Sound , RPG::Music


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- w -

  • weaponId : RPG::Actor , RPG::DBActor
  • width : RPG::Image


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- x -

  • x
: RPG::Battler
, RPG::Picture
, RPG::Character
Generated on Mon Feb 6 2012 22:24:57 for DynRPG by doxygen 1.7.6.1


DynRPG: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- y -

  • y
: RPG::Battler
, RPG::Picture
, RPG::Character
Generated on Mon Feb 6 2012 22:24:57 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • Action
RPG::Action Member List
This is the complete list of members for RPG::Action, including all inherited members.
basicActionId | RPG::Action
itemId | RPG::Action
kind | RPG::Action
monsterId | RPG::Action
skillId | RPG::Action
target | RPG::Action
targetId | RPG::Action
userData1 | RPG::Action
userData2 | RPG::Action
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • Actor
RPG::Actor Member List
This is the complete list of members for RPG::Actor, including all inherited members.
accessoryId | RPG::Actor |
action | RPG::Battler |
actionStatus | RPG::Battler |
agilityDiff | RPG::Actor |
animationId | RPG::Battler |
armorId | RPG::Actor |
atbValue | RPG::Battler |
attackDiff | RPG::Actor |
battleCommands | RPG::Actor |
battleGraphicId | RPG::Actor |
charsetFilename | RPG::Actor |
charsetId | RPG::Actor |
charsetTransparency | RPG::Actor |
conditions | RPG::Battler |
customBattleCommands | RPG::Actor |
damagePopup(int number, int color) | RPG::Battler |
damagePopup(std::string text) | RPG::Battler |
damagePopupTimer | RPG::Battler |
defenseDiff | RPG::Actor |
degree | RPG::Actor |
displayedConditions | RPG::Battler |
executeAction(bool skipPluginHandlers=false) | RPG::Battler |
exp | RPG::Actor |
facesetFilename | RPG::Actor |
facesetId | RPG::Actor |
flash(int r, int g, int b, int intensity, int duration) | RPG::Battler |
flashB | RPG::Battler |
flashG | RPG::Battler |
flashIntensity | RPG::Battler |
flashR | RPG::Battler |
flashTimer | RPG::Battler |
frameCounter | RPG::Battler |
getAgility() | RPG::Battler |
getAttack() | RPG::Battler |
getBattleCommand(int index) | RPG::Actor |
getBattleGraphicId() | RPG::Actor |
getCharsetFilename() | RPG::Actor |
getCharsetId() | RPG::Actor |
getCharsetTransparency() | RPG::Actor |
getDefense() | RPG::Battler |
getDegree() | RPG::Actor |
getFacesetFilename() | RPG::Actor |
getFacesetId() | RPG::Actor |
getIntelligence() | RPG::Battler |
getMaxHp() | RPG::Battler |
getMaxMp() | RPG::Battler |
getName() | RPG::Battler |
helmetId | RPG::Actor |
hp | RPG::Battler |
id | RPG::Battler |
intelligenceDiff | RPG::Actor |
isMonster() | RPG::Battler |
level | RPG::Actor |
longAction | RPG::Battler |
maxHpDiff | RPG::Actor |
maxMpDiff | RPG::Actor |
mirrored | RPG::Battler |
mp | RPG::Battler |
name | RPG::Actor |
notHidden | RPG::Battler |
originalX | RPG::Battler |
originalY | RPG::Battler |
partyMember(int index) | RPG::Actor | [static]
row | RPG::Battler |
rowAlt | RPG::Battler |
setRow(Row newRow) | RPG::Battler |
shieldId | RPG::Actor |
turnsTaken | RPG::Battler |
weaponId | RPG::Actor |
x | RPG::Battler |
y | RPG::Battler |
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • ArrayBaseOne
RPG::ArrayBaseOne< T, size > Member List
This is the complete list of members for RPG::ArrayBaseOne< T, size >, including all inherited members.
operator[](int index) RPG::ArrayBaseOne< T, size > [inline]
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • BattleSettings
RPG::BattleSettings Member List
This is the complete list of members for RPG::BattleSettings, including all inherited members.
largeWindows | RPG::BattleSettings
layout | RPG::BattleSettings
transparentWindows | RPG::BattleSettings
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • Battler
RPG::Battler Member List
This is the complete list of members for RPG::Battler, including all inherited members.
action | RPG::Battler
actionStatus | RPG::Battler
animationId | RPG::Battler
atbValue | RPG::Battler
conditions | RPG::Battler
damagePopup(int number, int color) | RPG::Battler
damagePopup(std::string text) | RPG::Battler
damagePopupTimer | RPG::Battler
displayedConditions | RPG::Battler
executeAction(bool skipPluginHandlers=false) | RPG::Battler
flash(int r, int g, int b, int intensity, int duration) | RPG::Battler
flashB | RPG::Battler
flashG | RPG::Battler
flashIntensity | RPG::Battler
flashR | RPG::Battler
flashTimer | RPG::Battler
frameCounter | RPG::Battler
getAgility() | RPG::Battler
getAttack() | RPG::Battler
getDefense() | RPG::Battler
getIntelligence() | RPG::Battler
getMaxHp() | RPG::Battler
getMaxMp() | RPG::Battler
getName() | RPG::Battler
hp | RPG::Battler
id | RPG::Battler
isMonster() | RPG::Battler
longAction | RPG::Battler
mirrored | RPG::Battler
mp | RPG::Battler
notHidden | RPG::Battler
originalX | RPG::Battler
originalY | RPG::Battler
row | RPG::Battler
rowAlt | RPG::Battler
setRow(Row newRow) | RPG::Battler
turnsTaken | RPG::Battler
x | RPG::Battler
y | RPG::Battler
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • Canvas
RPG::Canvas Member List
This is the complete list of members for RPG::Canvas, including all inherited members.
bitmap | RPG::Canvas |
brightness | RPG::Canvas |
convert16To24Bit(unsigned short pixel16) | RPG::Canvas | [inline, static]
convert16To32Bit(unsigned short pixel16) | RPG::Canvas | [inline, static]
convert24To16Bit(unsigned int pixel24) | RPG::Canvas | [inline, static]
convert32To16Bit(unsigned int pixel32, unsigned short prevPixel16) | RPG::Canvas | [inline, static]
draw(int x, int y, RPG::Image *image, int srcX=0, int srcY=0, int srcWidth=-1, int srcHeight=-1) | RPG::Canvas |
getScanline(int y) | RPG::Canvas |
height() | RPG::Canvas |
lineSize | RPG::Canvas |
pixel(int x, int y) | RPG::Canvas |
width() | RPG::Canvas |
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • Catalog
RPG::Catalog< T > Member List
This is the complete list of members for RPG::Catalog< T >, including all inherited members.
count() | RPG::Catalog< T > | [inline]
get(int index) | RPG::Catalog< T > | [inline]
list | RPG::Catalog< T > |
operator[](int index) | RPG::Catalog< T > | [inline]
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • CatalogPtr
RPG::CatalogPtr< T > Member List
This is the complete list of members for RPG::CatalogPtr< T >, including all inherited members.
count() | RPG::CatalogPtr< T > | [inline]
get(int index) | RPG::CatalogPtr< T > | [inline]
operator[](int index) | RPG::CatalogPtr< T > | [inline]
ptr | RPG::CatalogPtr< T > |
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • Character
RPG::Character Member List
This is the complete list of members for RPG::Character, including all inherited members.
animationType | RPG::Character
charsetFilename | RPG::Character
charsetId | RPG::Character
customExactSpeed | RPG::Character
direction | RPG::Character
doStep(RPG::Direction direction) | RPG::Character
enabled | RPG::Character
facing | RPG::Character
fixedDirection | RPG::Character
forbidEventOverlap | RPG::Character
frequency | RPG::Character
frequencyTimer | RPG::Character
getName() | RPG::Character
getScreenX() | RPG::Character
getScreenY() | RPG::Character
id | RPG::Character
isMovePossible(int fromX, int fromY, int toX, int toY) | RPG::Character
layer | RPG::Character
mapID | RPG::Character
move(char *data, int length, bool repeatPattern=false, bool ignoreImpossible=true, int frequency=8) | RPG::Character
movementFramesLeft | RPG::Character
moveRoute | RPG::Character
moving | RPG::Character
offsetX | RPG::Character
offsetY | RPG::Character
originalFrequency | RPG::Character
phasing | RPG::Character
setAnimationType(RPG::AnimationType type) | RPG::Character
setFixedStep(int newStep) | RPG::Character
setNormalStep() | RPG::Character
speed | RPG::Character
step | RPG::Character
stepFrameCounter | RPG::Character
stepTimer | RPG::Character
stop() | RPG::Character
transparency | RPG::Character
x | RPG::Character
y | RPG::Character
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • ColorControl
RPG::ColorControl Member List
This is the complete list of members for RPG::ColorControl, including all inherited members.
blue | RPG::ColorControl
chroma | RPG::ColorControl
green | RPG::ColorControl
parentImage | RPG::ColorControl
red | RPG::ColorControl
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • DArray
RPG::DArray< T, base_ > Member List
This is the complete list of members for RPG::DArray< T, base_ >, including all inherited members.
base() | RPG::DArray< T, base_ > | [inline]
items | RPG::DArray< T, base_ > |
operator[](int index) | RPG::DArray< T, base_ > | [inline]
resize(int newSize) | RPG::DArray< T, base_ > | [inline]
size | RPG::DArray< T, base_ > |
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • DBActor
RPG::DBActor Member List
This is the complete list of members for RPG::DBActor, including all inherited members.
accessoryId | RPG::DBActor
agility | RPG::DBActor
aiControl | RPG::DBActor
allowCriticalHit | RPG::DBActor
armorId | RPG::DBActor
attack | RPG::DBActor
battleCommands | RPG::DBActor
battleGraphicId | RPG::DBActor
charsetFilename | RPG::DBActor
charsetId | RPG::DBActor
charsetTransparent | RPG::DBActor
classId | RPG::DBActor
criticalHitProbability | RPG::DBActor
defense | RPG::DBActor
degree | RPG::DBActor
expPrimary | RPG::DBActor
expSecondary | RPG::DBActor
expTertiary | RPG::DBActor
facesetFilename | RPG::DBActor
facesetId | RPG::DBActor
helmetId | RPG::DBActor
id | RPG::DBActor
intelligence | RPG::DBActor
lockEquipment | RPG::DBActor
maxHp | RPG::DBActor
maxLevel | RPG::DBActor
maxMp | RPG::DBActor
mightyGuard | RPG::DBActor
minLevel | RPG::DBActor
name | RPG::DBActor
shieldId | RPG::DBActor
skillLearning | RPG::DBActor
twoWeapons | RPG::DBActor
unarmedBattleAnimationId | RPG::DBActor
weaponId | RPG::DBActor
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • DBSystem
RPG::DBSystem Member List
This is the complete list of members for RPG::DBSystem, including all inherited members.
airshipBGM | RPG::DBSystem
battleBGM | RPG::DBSystem
battleEndEraseTrans | RPG::DBSystem
battleEndShowTrans | RPG::DBSystem
battleStartEraseTrans | RPG::DBSystem
battleStartSE | RPG::DBSystem
battleStartShowTrans | RPG::DBSystem
buzzerSE | RPG::DBSystem
cancelSE | RPG::DBSystem
cursorSE | RPG::DBSystem
decisionSE | RPG::DBSystem
enemyAttackSE | RPG::DBSystem
enemyDamageSE | RPG::DBSystem
enemyDeathSE | RPG::DBSystem
evasionSE | RPG::DBSystem
fleeSE | RPG::DBSystem
gameOverBGM | RPG::DBSystem
gameOverFilename | RPG::DBSystem
heroDamageSE | RPG::DBSystem
innBGM | RPG::DBSystem
itemSE | RPG::DBSystem
shipBGM | RPG::DBSystem
skiffBGM | RPG::DBSystem
systemFont | RPG::DBSystem
systemGraphicFilename | RPG::DBSystem
systemTiled | RPG::DBSystem
teleportEraseTrans | RPG::DBSystem
teleportShowTrans | RPG::DBSystem
titleBGM | RPG::DBSystem
titleFilename | RPG::DBSystem
victoryBGM | RPG::DBSystem
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • DBitmap
RPG::DBitmap Member List
This is the complete list of members for RPG::DBitmap, including all inherited members.
getHBITMAP() | RPG::DBitmap | [inline]
getHDC() | RPG::DBitmap | [inline]
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • DList
RPG::DList< T > Member List
This is the complete list of members for RPG::DList< T >, including all inherited members.
count | RPG::DList< T > |
get(int index) | RPG::DList< T > | [inline]
items | RPG::DList< T > |
operator[](int index) | RPG::DList< T > | [inline]
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • DListPtr
RPG::DListPtr< T > Member List
This is the complete list of members for RPG::DListPtr< T >, including all inherited members.
get(int index) | RPG::DListPtr< T > | [inline]
list | RPG::DListPtr< T > |
operator[](int index) | RPG::DListPtr< T > | [inline]
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • DString
RPG::DString Member List
This is the complete list of members for RPG::DString, including all inherited members.
length() | RPG::DString
operator char *() const | RPG::DString
operator std::string() const | RPG::DString
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • DStringPtr
RPG::DStringPtr Member List
This is the complete list of members for RPG::DStringPtr, including all inherited members.
assign(char *s, int len) | RPG::DStringPtr
clear() | RPG::DStringPtr
DStringPtr() | RPG::DStringPtr
DStringPtr(RPG::DStringPtr &s) | RPG::DStringPtr
DStringPtr(std::string s) | RPG::DStringPtr
length() | RPG::DStringPtr
operator char *() | RPG::DStringPtr
operator std::string() | RPG::DStringPtr
operator=(std::string rhs) | RPG::DStringPtr
operator=(char *rhs) | RPG::DStringPtr
operator=(const char *rhs) | RPG::DStringPtr
operator=(RPG::DString *rhs) | RPG::DStringPtr
operator==(std::string rhs) | RPG::DStringPtr
operator==(const char *rhs) | RPG::DStringPtr
operator==(RPG::DStringPtr &rhs) | RPG::DStringPtr
s_str() | RPG::DStringPtr
str | RPG::DStringPtr
~DStringPtr() | RPG::DStringPtr
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • Event
RPG::Event Member List
This is the complete list of members for RPG::Event, including all inherited members.
animationType | RPG::Character
charsetFilename | RPG::Character
charsetId | RPG::Character
customExactSpeed | RPG::Character
direction | RPG::Character
doesEventPageExist(int id) | RPG::Event
doStep(RPG::Direction direction) | RPG::Character
enabled | RPG::Character
eventData | RPG::Event
facing | RPG::Character
fixedDirection | RPG::Character
forbidEventOverlap | RPG::Character
frequency | RPG::Character
frequencyTimer | RPG::Character
getName() | RPG::Character
getScreenX() | RPG::Character
getScreenY() | RPG::Character
id | RPG::Character
isMovePossible(int fromX, int fromY, int toX, int toY) | RPG::Character
layer | RPG::Character
mapID | RPG::Character
move(char *data, int length, bool repeatPattern=false, bool ignoreImpossible=true, int frequency=8) | RPG::Character
movementFramesLeft | RPG::Character
moveRoute | RPG::Character
moving | RPG::Character
offsetX | RPG::Character
offsetY | RPG::Character
originalFrequency | RPG::Character
phasing | RPG::Character
setAnimationType(RPG::AnimationType type) | RPG::Character
setFixedStep(int newStep) | RPG::Character
setNormalStep() | RPG::Character
speed | RPG::Character
step | RPG::Character
stepFrameCounter | RPG::Character
stepTimer | RPG::Character
stop() | RPG::Character
transparency | RPG::Character
x | RPG::Character
y | RPG::Character
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • EventData
RPG::EventData Member List
This is the complete list of members for RPG::EventData, including all inherited members.
name RPG::EventData
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • EventScriptData
RPG::EventScriptData Member List
This is the complete list of members for RPG::EventScriptData, including all inherited members.
currentLineId | RPG::EventScriptData
line(int index) | RPG::EventScriptData
lines | RPG::EventScriptData
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • EventScriptLine
RPG::EventScriptLine Member List
This is the complete list of members for RPG::EventScriptLine, including all inherited members.
command | RPG::EventScriptLine
parameter(int index) | RPG::EventScriptLine
parameters | RPG::EventScriptLine
stringParameter | RPG::EventScriptLine
treeDepth | RPG::EventScriptLine
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • EventScriptList
RPG::EventScriptList Member List
This is the complete list of members for RPG::EventScriptList, including all inherited members.
list RPG::EventScriptList
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • Hero
RPG::Hero Member List
This is the complete list of members for RPG::Hero, including all inherited members.
animationType | RPG::Character
charsetFilename | RPG::Character
charsetId | RPG::Character
customExactSpeed | RPG::Character
direction | RPG::Character
doStep(RPG::Direction direction) | RPG::Character
enabled | RPG::Character
facing | RPG::Character
fixedDirection | RPG::Character
forbidEventOverlap | RPG::Character
frequency | RPG::Character
frequencyTimer | RPG::Character
getControlMode() | RPG::Hero
getName() | RPG::Character
getScreenX() | RPG::Character
getScreenY() | RPG::Character
id | RPG::Character
isMovePossible(int fromX, int fromY, int toX, int toY) | RPG::Character
layer | RPG::Character
mapID | RPG::Character
move(char *data, int length, bool repeatPattern=false, bool ignoreImpossible=true, int frequency=8) | RPG::Character
movementFramesLeft | RPG::Character
moveRoute | RPG::Character
moving | RPG::Character
offsetX | RPG::Character
offsetY | RPG::Character
originalFrequency | RPG::Character
phasing | RPG::Character
setAnimationType(RPG::AnimationType type) | RPG::Character
setControlMode(RPG::HeroControlMode controlMode) | RPG::Hero
setFixedStep(int newStep) | RPG::Character
setNormalStep() | RPG::Character
speed | RPG::Character
step | RPG::Character
stepFrameCounter | RPG::Character
stepTimer | RPG::Character
stop() | RPG::Character
transparency | RPG::Character
vehicle | RPG::Hero
x | RPG::Character
y | RPG::Character
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • Image
RPG::Image Member List
This is the complete list of members for RPG::Image, including all inherited members.
alpha | RPG::Image |
appliedPalette | RPG::Image |
appliedPaletteBrightness | RPG::Image |
applyPalette() | RPG::Image |
autoResize | RPG::Image |
clear() | RPG::Image |
colorControl1 | RPG::Image |
colorControl2 | RPG::Image |
copy(RPG::Image *image) | RPG::Image |
create() | RPG::Image | [static]
create(int newWidth, int newHeight) | RPG::Image | [static]
create(RPG::Image *templateImage) | RPG::Image | [static]
destroy(RPG::Image *&image) | RPG::Image | [static]
draw(int x, int y, unsigned char *newPixels, int srcWidth, int srcHeight, int srcLineWidth, int maskColor=0) | RPG::Image |
draw(int x, int y, RPG::Image *image, int srcX=0, int srcY=0, int srcWidth=-1, int srcHeight=-1, int maskColor=0) | RPG::Image |
drawText(int x, int y, std::string text, int color) | RPG::Image |
free() | RPG::Image |
height | RPG::Image |
init(int newWidth, int newHeight) | RPG::Image |
loadFromFile(std::string filename, bool throwErrors=true, bool autoResize=true) | RPG::Image |
palette | RPG::Image |
pixel(int x, int y) | RPG::Image |
pixels | RPG::Image |
setPalette(int *newPalette) | RPG::Image |
setSystemPalette() | RPG::Image |
useMaskColor | RPG::Image |
width | RPG::Image |
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • Input
RPG::Input Member List
This is the complete list of members for RPG::Input, including all inherited members.
key(RPG::Key keyId) | RPG::Input
keys | RPG::Input
keys2k3 | RPG::Input
pressed(RPG::Key keyId) | RPG::Input
update() | RPG::Input
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • Map
RPG::Map Member List
This is the complete list of members for RPG::Map, including all inherited members.
cameraSubX | RPG::Map
cameraSubY | RPG::Map
chipset | RPG::Map
events | RPG::Map
getCameraX() | RPG::Map
getCameraY() | RPG::Map
getHeight() | RPG::Map
getWidth() | RPG::Map
moveCamera(int offsetX, int offsetY, int speed) | RPG::Map
setCamera(int x, int y) | RPG::Map
updateEvents() | RPG::Map
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • Monster
RPG::Monster Member List
This is the complete list of members for RPG::Monster, including all inherited members.
action | RPG::Battler
actionStatus | RPG::Battler
animationId | RPG::Battler
atbValue | RPG::Battler
blinkTimer | RPG::Monster
conditions | RPG::Battler
damagePopup(int number, int color) | RPG::Battler
damagePopup(std::string text) | RPG::Battler
damagePopupTimer | RPG::Battler
databaseId | RPG::Monster
displayedConditions | RPG::Battler
executeAction(bool skipPluginHandlers=false) | RPG::Battler
flash(int r, int g, int b, int intensity, int duration) | RPG::Battler
flashB | RPG::Battler
flashG | RPG::Battler
flashIntensity | RPG::Battler
flashR | RPG::Battler
flashTimer | RPG::Battler
frameCounter | RPG::Battler
getAgility() | RPG::Battler
getAttack() | RPG::Battler
getDefense() | RPG::Battler
getIntelligence() | RPG::Battler
getMaxHp() | RPG::Battler
getMaxMp() | RPG::Battler
getName() | RPG::Battler
hp | RPG::Battler
id | RPG::Battler
image | RPG::Monster
imageMirrored | RPG::Monster
isMonster() | RPG::Battler
longAction | RPG::Battler
mirrored | RPG::Battler
mp | RPG::Battler
notHidden | RPG::Battler
originalX | RPG::Battler
originalY | RPG::Battler
row | RPG::Battler
rowAlt | RPG::Battler
setRow(Row newRow) | RPG::Battler
turnsTaken | RPG::Battler
x | RPG::Battler
y | RPG::Battler
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • MoveRoute
RPG::MoveRoute Member List
This is the complete list of members for RPG::MoveRoute, including all inherited members.
encodedMoves | RPG::MoveRoute
ignoreImpossible | RPG::MoveRoute
moves | RPG::MoveRoute
repeatPattern | RPG::MoveRoute
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • Music
RPG::Music Member List
This is the complete list of members for RPG::Music, including all inherited members.
fadeInTime | RPG::Music |
fadeOut(int time) | RPG::Music | [static]
filename | RPG::Music |
Music() | RPG::Music |
Music(RPG::Music &ref) | RPG::Music |
Music(std::string filename, int fadeInTime, int volume, int speed, int pan) | RPG::Music |
pan | RPG::Music |
play() | RPG::Music |
set(RPG::Music &ref) | RPG::Music |
speed | RPG::Music |
stop() | RPG::Music | [static]
volume | RPG::Music |
~Music() | RPG::Music |
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • NamedCatalog
RPG::NamedCatalog< T > Member List
This is the complete list of members for RPG::NamedCatalog< T >, including all inherited members.
count() | RPG::Catalog< T > | [inline]
get(int index) | RPG::NamedCatalog< T > | [inline]
list | RPG::Catalog< T > |
operator[](int index) | RPG::NamedCatalog< T > | [inline]
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • NamedCatalogPtr
RPG::NamedCatalogPtr< T > Member List
This is the complete list of members for RPG::NamedCatalogPtr< T >, including all inherited members.
count() | RPG::NamedCatalogPtr< T > | [inline]
get(int index) | RPG::NamedCatalogPtr< T > | [inline]
operator[](int index) | RPG::NamedCatalogPtr< T > | [inline]
ptr (defined in RPG::NamedCatalogPtr< T >) | RPG::NamedCatalogPtr< T > |
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • ParsedCommentData
RPG::ParsedCommentData Member List
This is the complete list of members for RPG::ParsedCommentData, including all inherited members.
command | RPG::ParsedCommentData
parameters | RPG::ParsedCommentData
parametersCount | RPG::ParsedCommentData
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • ParsedCommentParameter
RPG::ParsedCommentParameter Member List
This is the complete list of members for RPG::ParsedCommentParameter, including all inherited members.
number | RPG::ParsedCommentParameter
text | RPG::ParsedCommentParameter
type | RPG::ParsedCommentParameter
Generated on Mon Feb 6 2012 22:24:56 for DynRPG by doxygen 1.7.6.1


DynRPG: Member List

  • Picture
RPG::Picture Member List
This is the complete list of members for RPG::Picture, including all inherited members.
angle | RPG::Picture
blue | RPG::Picture
chroma | RPG::Picture
draw() | RPG::Picture
effect | RPG::Picture
effectStrength | RPG::Picture
erase() | RPG::Picture
filename | RPG::Picture
green | RPG::Picture
id | RPG::Picture
image | RPG::Picture
image2 | RPG::Picture
magnification | RPG::Picture
merge() | RPG::Picture
move(int x, int y, int magnification, int transparency, int transparency2, int red, int green, int blue, int chroma, RPG::PictureEffect effect, int effectStrength, int duration) | RPG::Picture
movementTimer | RPG::Picture
moveWithMap | RPG::Picture
originX | RPG::Picture
originY | RPG::Picture
red | RPG::Picture
show(std::string filename, int x, int y, bool moveWithMap, int magnification, int transparency, int transparency2, bool useMaskColor, int red, int green, int blue, int chroma, RPG::PictureEffect effect, int effectStrength) | RPG::Picture
targetBlue | RPG::Picture
targetChroma | RPG::Picture
targetEffectStrength | RPG::Picture
targetGreen | RPG::Picture
targetMagnification | RPG::Picture
targetRed | RPG::Picture
targetTransparency | RPG::Picture
targetTransparency2 | RPG::Picture
targetX | RPG::Picture
targetY | RPG::Picture
transparency | RPG::Picture
transparency2 | RPG::Picture
update() | RPG::Picture
useMaskColor | RPG::Picture
x | RPG::Picture
y | RPG::Picture


DynRPG: Member List

  • Screen
RPG::Screen Member List
This is the complete list of members for RPG::Screen, including all inherited members.
auroraDrawMain | RPG::Screen
canvas | RPG::Screen
fullScreen | RPG::Screen
getCanvasHWND() | RPG::Screen
largeWindow | RPG::Screen
maxFPS | RPG::Screen
millisecondsPerFrame | RPG::Screen
setFPS(int fps) | RPG::Screen
update(RPG::Scene scene) | RPG::Screen


DynRPG: Member List

  • Sound
RPG::Sound Member List
This is the complete list of members for RPG::Sound, including all inherited members.
filename | RPG::Sound |
pan | RPG::Sound |
play() | RPG::Sound |
set(RPG::Sound &ref) | RPG::Sound |
Sound() | RPG::Sound |
Sound(RPG::Sound &ref) | RPG::Sound |
Sound(std::string filename, int volume, int speed, int pan) | RPG::Sound |
speed | RPG::Sound |
stop() | RPG::Sound | [static]
volume | RPG::Sound |
~Sound() | RPG::Sound |


DynRPG: Member List

  • Switches
RPG::Switches Member List
This is the complete list of members for RPG::Switches, including all inherited members.
operator[](int index) RPG::Switches [inline]


DynRPG: Member List

  • System
RPG::System Member List
This is the complete list of members for RPG::System, including all inherited members.
airshipBGM | RPG::System
atbMode | RPG::System
battleBGM | RPG::System
battleEndEraseTrans | RPG::System
battleEndShowTrans | RPG::System
battleStartEraseTrans | RPG::System
battleStartSE | RPG::System
battleStartShowTrans | RPG::System
buzzerSE | RPG::System
cancelSE | RPG::System
currentBGM | RPG::System
cursorSE | RPG::System
decisionSE | RPG::System
defaultBackdrop | RPG::System
enemyAttackSE | RPG::System
enemyDamageSE | RPG::System
enemyDeathSE | RPG::System
escapeAllowed | RPG::System
evasionSE | RPG::System
faceFilename | RPG::System
faceID | RPG::System
faceImage | RPG::System
faceMirrored | RPG::System
facePosition | RPG::System
fleeSE | RPG::System
frameCounter | RPG::System
gameOverBGM | RPG::System
getAirshipBGM() | RPG::System
getBattleBGM() | RPG::System
getBattleEndEraseTrans() | RPG::System
getBattleEndShowTrans() | RPG::System
getBattleStartEraseTrans() | RPG::System
getBattleStartSE() | RPG::System
getBattleStartShowTrans() | RPG::System
getBuzzerSE() | RPG::System
getCancelSE() | RPG::System
getCursorSE() | RPG::System
getDecisionSE() | RPG::System
getEnemyAttackSE() | RPG::System
getEnemyDamageSE() | RPG::System
getEnemyDeathSE() | RPG::System
getEvasionSE() | RPG::System
getFleeSE() | RPG::System
getGameOverBGM() | RPG::System
getHeroDamageSE() | RPG::System
getInnBGM() | RPG::System
getItemSE() | RPG::System
getShipBGM() | RPG::System
getSkiffBGM() | RPG::System
getTeleportEraseTrans() | RPG::System
getTeleportShowTrans() | RPG::System
getTitleBGM() | RPG::System
getVictoryBGM() | RPG::System
heroDamageSE | RPG::System
innBGM | RPG::System
itemSE | RPG::System
mapBGM | RPG::System
memorizedBGM | RPG::System
menuAllowed | RPG::System
messageActive | RPG::System
messageAutoPos | RPG::System
messageModal | RPG::System
messagePosition | RPG::System
messageTransparent | RPG::System
musicFade | RPG::System
saveAllowed | RPG::System
saveCount | RPG::System
scene | RPG::System
shipBGM | RPG::System
skiffBGM | RPG::System
switches | RPG::System
systemFont | RPG::System
systemGraphic | RPG::System
systemGraphicFilename | RPG::System
systemTiled | RPG::System
teleportAllowed | RPG::System
teleportEraseTrans | RPG::System
teleportShowTrans | RPG::System
titleBGM | RPG::System
variables | RPG::System
victoryBGM | RPG::System


DynRPG: Member List

  • SystemGraphic
RPG::SystemGraphic Member List
This is the complete list of members for RPG::SystemGraphic, including all inherited members.
loadFont(std::string fontName) | RPG::SystemGraphic
system2Image | RPG::SystemGraphic
systemImage | RPG::SystemGraphic


DynRPG: Member List

  • Variables
RPG::Variables Member List
This is the complete list of members for RPG::Variables, including all inherited members.
dummy (defined in RPG::Variables) | RPG::Variables |
operator[](int index) | RPG::Variables | [inline]